**Objectives**

After completing this lesson, you will be able to:

- Use the basic animation tools in Autodesk® Maya® 2010.
- Animate a bouncing ball using Autodesk Maya.
- Demonstrate and explain the fundamentals of animating in a 3D animation practice.
- Incorporate traditional animation techniques into a modern media.

**Description**

You begin this lesson by placing in the basic key frames of the ball bouncing up and down. Then, you progress to having the ball move from one side of the screen to the other. Next, you layer in the rotations of the ball and end with the squash and stretch.

**Learning Outcomes**

You will learn how to animate a bouncing ball and navigate through the basic animation tools in Autodesk Maya:

- Graph Editor
- Timeline
- Setting keys
- Ghosting

**Introduction**

The Bouncing Ball is probably the all-time favorite first animation exercise taught today. The bouncing ball exercise is a good place to start, because there are not too many controllers to use in a 3D application and because it deals primarily with basic movement. You should have a good idea of what a bouncing ball looks like.

Jump in and get started!
You need to set up some ground rules for animation to get started; for example, setting a frame rate for the third application. You will be using 30 frames per second throughout the lessons.

So, how do you decide which frame rate to use? A rule of thumb for frame rates is that it has to be 30 frames per second for TV or video. On a Hollywood big screen, it will run at 24 frames per second. For video games, it depends on what kind of game you are creating.

To set the frames per second or fps:

- Click Window > Settings Preferences > Preferences.
- In the Preferences window, select Settings.
- In the Settings dialog box, set the time option to NTSC [30 fps].

Other than this change, you use all of the default settings in Maya.
To begin the animation:

- Click File > Open Scene.
- In the Bouncing Ball folder, open the file Bouncing_Ball_Start.mb.

In the Bouncing_Ball_Start.mb file, you will see a multicolored ball with an arrowed curve around it named Ball_CON.

Notice that there are 60 frames to work with in the timeslider at the bottom of the scene. This should be all the frames you need to make the ball bounce. Working at 30 frames per second, you have two seconds.
- On frame 1, select Ball_Con.
- Move the ball up in the Y-axis to about 15 units. You can check this in the Channels dialog box, if you want to be exact.
- Set a key on the Translate Y channel of Ball_Con.

The basic way to set a key in Maya is to press the s key. Using the s hot key will set a key on all the channels at once.

To set a key on a single channel, instead of all the channels by using the s key, you:

- Select Ball_Con.
- Select the LMB.
- In the Channels dialog box, select the channel you want.
- Select RMB on the channel name.
- Select Key Selected from the Channels list.

This is the recommended approach for this example.
• Move the timeslider to frame 10.
• Hold the LMB down in the timeslider and slide the marker to frame 10.

The marker will be on the left side of the frame.

• Move the ball down to the ground plane.
• Again, set a key on the Translate Y channel of Ball_CON.

This gives you a third-of-a-second drop of the ball on the first bounce, since we are using 30 frames per second. The first drop is 10 frames.

• Go to frame 16 and move the ball up about 10 units. Set a key on the Translate Y channel.
• Go to frame 22 and move the ball down to the ground plane again. Set a key on the Translate Y channel.
• Go to frame 27 and move the ball up again about five units this time. Set a key on the Translate Y channel.
• Go to frame 32 and move the ball to the ground plane. Set a key on the Translate Y channel.
• Go to frame 36 and move the ball up .75 units. Set a key on the Translate Y channel.
• Go to frame 40 and move the ball to the ground plane for the final bounce. Set a key on the Translate Y channel.

This will give you the up and down movement of the ball. Now, playblast your scene.

To playblast your scene:

• Select the timeslider.
• Hold the RMB down anywhere in the timeslider.
• Select Playblast from the list that displays.

Note:  
A Playblast is a quick preview of your animation in real time in the default movie player on your computer. Maya will not always give you a real-time preview of your animation the workview.
You now have a moving ball; it’s not moving well, but it is moving.

View 01_Translate_Y_Keyed.qt in the Bouncing Ball folder to see what your ball playblast should look like.

From the playblast of your scene, you can see things that are wrong with the bouncing ball animation. For one thing, the ball slows down before it hits the ground as though it is anticipating the impact of the ground and then hitting some kind of air brakes to slow itself down. This cannot happen in the real world. When an object is falling, it is unable to stop or slow down until it encounters another object or force. This is the basic physics of a falling object.

Also, on frame 33, you can see the ball is going past the ground plane in the Translate Y axis.

Take a look at how you can fix these problems.

- Select Ball_CON. Click Window > Animation Editors > Graph Editors.
A Graph Editor is displayed that resembles the image shown.

- Select the Translate Y option on the left side window.

The curve in the Graph Editor is called a Euler-angle curve. It is how animators change the timing and behavior of an object moving in space. The vertical numbers on the left in the Graph Editor represent 3D units and the horizontal numbers along the bottom represent time in frames. The curve is the representation of movement in one channel in space through time.
The next image shows a curve in the Graph Editor. On the left going up are units in space. Along the bottom, you see time in frames. The curve illustrates the movement of your object through space over time. Time is the constant. Once you set the frame rate, it will always move at that rate. As you can see in the image, the first five red lines are relatively close together, which means little movement. The next five red lines represent larger movement. This is because the object moves farther over the same amount of time. This is how the Graph Editor works. It takes time and practice to completely understand it.
The little dots are keys that you have to set. The lines coming off the keys are tangent handles. You can select the keys and move them up and down to change the unit value. Or you can move them right to left to change the timing or frame they are on. The Tangent handles are used to manipulate the curve between keys. By default, the Tangent handles move together as one, but this can be changed.

- Select the keys on the top of each arch of your Graph Editor.
- Then set them to “flat” tangents by pressing this button in the Graph Editor. This automatically sets the tangents to perfect horizontal lines.
- Select the bottom tangents/keys.

- Set them to “linear” tangents by pressing this button in the graph editor. This automatically points the tangents of your key toward the next or previous key.
Your curve should resemble the one in the Graph Editor.

By making these changes, it enables the ball to hover in the air a little longer at the top of its highest points and speed up as it falls to the ground plane without slowing on the way down. Objects fall to earth at 9.8 meters per square second. But when you drop a ball from a table or from your hand, it has to speed up from being still. Motion is not constant. This is where the animation principle of slow-in and slow-out comes in.

- Playblast your scene or look at `02_Translate_Y_Keyed_TangentFix.qt`.

You see that by just changing the curves between our keys, your bouncing ball looks like it is more closely following the rules of physics. The ball is no longer slowing down before it hits the ground. Also, the ball no longer dips below the 0 unit (Ground Plan) in the Graph Editor and scene.

The curve is not perfect yet, but it’s getting there. One issue you have now with the animation is that the last bounce looks slow compared to the other bounces. The ball seems to hover a little longer at its highest point compared to the previous bounces. This is coming from the “timing” of the last bounce; it has too many frames in between keys.
You can change this in the Graph Editor.

- Select Ball_CON. Open the Graph Editor again if you need to.
- Move the second to last tangent/key from frame 36 to frame 34. Select the key and hold down the SHIFT key. Slide left. (The SHIFT key locks the movement to side-to-side only.)
- Move the last key on frame 40 to 36.

• Playblast again.

**Note:**

Don't ever worry about playblasting and reviewing your work too much. As an animator, you need to see your animation moving in real time to get the timing correct.
View `a3_Translate_Y_Keyed_TangentFix.qt`. Your last bounce matches the timing of the other bounces.

Now you have the ball moving up and down in a convincing way. But you should add some exaggeration to your bounces; add some punch as the ball hits the ground.

Select all the keys in the Graph Editor press these two buttons in the Graph Editor.

This breaks the tangents and enables you to move the handles independently of each other. It also enables you to stretch the handles. It enables you to freely move the tangents handles independently of each other and to get your hands dirty in the Graph Editor.

- Move the handles of the bottom keys/tangents up, almost vertical.
- Keep the top tangents flat but stretch them horizontally out from the key.

Your Graph Editor should now resemble the image shown.
Both of these bouncing balls have the exact same timing (the keys are identical on both but with different curve shapes). The one on the right has exaggerated curves and the one on the left has the default flat and linear curves. The job of the animator is to know when to use what kind of curves and exaggeration.

Tone down exaggeration in the scene and move on to the side-to-side movement across the screen.

The final Graph Editor for the bounces is as shown.

Explore all the options until your animation is the way you like it. Think about the ball as having a personality, or different weights. Create some variations.

- What if your ball is a balloon?
- What if your ball is really big, such as a huge boulder coming down a mountain?
- What if your ball has character, such as a ball with legs?
Now you need to add some sideways movement of the ball, moving from screen left to right. To get the ball to move across the screen as it bounces is easy.

- Select Ball_CON and move the timeslider to frame 1.
- Set a key on the Translate Z channel.
- Go to frame 50 and move the ball over about -30 units in the Z-axis.
- Set a key on the Translate Z channel (it should be right in screen).

Playblast and you should see something similar to 05_Translate_Z_Keyed.qt.

The ball is now moving from left to right on the screen but again does not move correctly. The ball comes to a sudden and abrupt stop at frame 50 as though it is hitting something. You are missing a key animation principle of slow-in and slow-out. As the ball rolls along the ground, friction dampens the roll/speed of the ball and brings the ball to a slowing stop; not a hard sudden stop, such as hitting a wall.

To add this effect, you:

- Select Ball_CON and go to the Graph Editor.

Your Graph Editor should look like this in the translate Z channel
You should see a long blue line that is your translate Z curve again representing movement in space over time. This curve represents a linear curve, which means equal spacing per frame (Constant Speed). Not too many things in the world can move this way. To slow down your ball, you need a curve at the last key.

- Select the last key/tangent.
- Press this button to flatten the curve.

Your curve should resemble the image shown.

- Playblast your scene. You should see the ball come to a slow stop instead of the fast stop from before.

You should see something similar to 06_Translate_Z_Keyed_TangentFix.qt.
Now you have the translation/movement completed.

The ball is moving nicely, but it is just sliding along the ground. So you add some rotation to the ball to create a roll.

- Select Ball_Con.
- Go to frame 1 and set a key on the Rotate Ball channel.
- Go to frame 50. In the Rotate Ball channel, set a key at approximately -400.

Look at your animation by playblasting or scrubbing the timeline (hold down the LMB and slide in the timeline). You should see the ball sliding as it rotates along at the end of the animation like 07_Rotate_Ball_Keyed.qt. The ball is not rotating enough to match the translation. Also the Translation Z has slow-in going into the final frame.

You need to match the slow-in to the last frame of the rotation.

- In the Graph Editor, select the last key/tangent in the Rotate Ball channel.
- Move the key/tangent down to approximately -1740 units.
- In Stats, you can enter in the exact numbers.

You use the trial and error approach to finding the correct number of rotations to match the translation. There is no real trick to it; you just have to eye it by moving the key in the Graph Editor and by scrubbing the timeline to see the movement of the ball. Do not forget to flatten the last key/tangent in the Rotation channel to add slow-in to match the translations.

Your animation at this point should resemble 08_Rotate_Ball_Keyed_Fixed.qt.
Lastly, you need to add squash and stretch to your bouncing ball.

- Go to frame 1 and select the Ball_CON.
- Then key the Squash Stretch channel.
- Go to each frame where the ball is hitting the ground and add squash to it, and key (frames 10, 22, 32, 36).

Make each squash a little smaller than the squash before it. This is because each bounce is smaller and the ball is losing energy after each bounce.

- On the keys, when the ball is at its highest point of the bounces, set the Squash Stretch channel to 1 and key. This enables the ball to return to its original size.

Playblast your scene and review the animation. It should resemble 09_Squash Keyed.qt.

The squashes on the ground hits look okay, but the ball is squashing before it hits the ground. The ball takes a really long time to stretch back to its normal shape after the squash and it never stretches back out on the take-offs from the ground. It is looking a little odd, so it's time to add the stretch!

- Go to each frame before and after the ball hits the ground.
- Stretch the ball out and key.

Remember to make each stretch slightly smaller than the one before it.
• Playblast your scene. It should resemble 10_Squash_And_Stretch_Keyed.qt.

It's looking better, but as you can see here, there is a large spacing gap between the stretch and squash on the floor of each bounce. This will cause a slight flicker in the animation because of the extreme spacing.

Also, you can see that as the ball stretches, the deformation of the ball is straight up and down. The deformation is not tilting with the angle of the ball’s motion through space.
To aid you on the spacing fix, you use the Ghosting tool. It is located in the Animation submenu under Animate > Ghost Selected.

- Select the actual Ball Geometry. Click Animate > Ghost selected.

- Go to the frame before the ball hits the ground and takes off from the ground.

- Set a key on the Translate Y channel.

This enables you to move the ball up and down in the Graph Editor on those frames.

Move the ball in those frames in the Graph Editor to match this image of the stretched ball. It should overlap with the squashed ball on the ground hits.
Repeat the spacing fixes on the other bounces as needed, the same as in the last step.

Now you need to tilt the stretching to match the motion of the ball.

- Go to frame 1 and set a key on the Tilt channel.
- Go to the frames again that are right before and right after the hits on the ground.
- Using the Tilt control, key the tilt of the ball back and forth to match the motion of the ball moving in space.
- Add a key with a 0 value in the Tilt channel on each high point of the bounces.
Here is the final spacing with the ghosting on.

- Click Animation > Unghost All to turn ghosting off.
- Playblast your scene. It should resemble 11_Squash_And_Stretch_Fixed.qt.