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Introduction 
 
 
This student workbook contains a set of exercises that clarify in a practical way the concepts explained in the “Building Information Modeling with Autodesk Revit 
Building Lecture Notes” by Simon Greenwold. 
 
The exercises cover the basic principles of the Autodesk® Revit® Building technology and the building information modeling (BIM) approach. For more training 
information, see the official Autodesk Revit Building training manuals and the tutorials available from the help menu. This workbook explains the different 
functionalities through various exercises, but the emphasis is on the workflow rather than on the tools themselves. 
 
The difficulty of the exercises increases as you proceed through the units, so it is recommended that you do them in sequence. Most units are independent and 
can be done starting with the provided file, named Unit () – Start. Files with the completed exercises are included in the data set folder and can be used to check 
your work. 
 
The workbook is structured in a three-column format (see image below):  

- The first column contains an explanation of all steps necessary to complete an exercise. 
- The middle column contains the images that clarify visually the tasks to accomplish. 
- The third column contains notes on the features and tools that are being used and a few helpful tips. 

 
Practical Instructions to complete the 

exercises 
Images Notes on the features and on the software in general 
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We have prepared the following data for you: 
 

- Workbook (this document) 
- Workbook data sets (placed in a folder, that contains all necessary files, families, and the template prepared for your use) 

 
Before starting the exercises, change the following settings to simplify use of this workbook and provide faster access to the data sets: 
 
1. Copy the provided Workbook Data 

Sets folder onto your desktop. 
2. Open Autodesk Revit Building. 
 
3. From the Settings menu, choose 

Options. 
 
4. Click the File Locations tab. 
 
 
 
 
 
 
 

5. Click the Add Library button.   

 

6. Rename the newly created New Library 
1 to Workbook Data Sets. Click in the 
blank Library Path field next to it, and 
then click the Flash icon at the far right 
of the row.   
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7. Browse to the path where you saved the 
data sets and click OK. 

8. Click the Workbook Data Sets field, and 

using the upper flash sign move it 
up to the first row. 

     
 
You have just created a shortcut to the 
Workbook data folder so that each time you 
go to the File menu to Open or Save, you 
see the folder in the browse window on the 
left so you can access it quickly. 

  
 
 
Note: Exercises for some lecture note units are not available here, and in some cases they have been grouped into a single exercise. The reason lies in the 
workflow approach that does not meet specific feature training requirements. For more information, see the Autodesk Official Training Courseware and the help 
file. 
 
We hope you enjoy learning the principles of Autodesk Revit Building and the BIM approach. 

 
Have fun! 
 



Unit 1 
Theory: CAD Versus BIM 

Autodesk Revit Building: Introduction, Interface, and Sketching 
 
Exercise 1  
In this first unit you start a new project using a template.  
 
Templates are prepared drawing files that contain data according to office or project standards, helping to ensure that all team members working on the same 
project are using the same objects and standards. You can create these templates on your own, according to your office or project requirements. 
 
 

Create a New Project Using the Provided Template  

1. From the File menu, choose New>Project.   

2. Click the Browse button, and then click the 
Revit Workbook library shortcut icon.  
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3. Select the Workbook Metric Template.rte 
template. 

 

A new project file is created. 
 
Each of these templates has unique families, 
views, and possibly sheets already loaded for you 
to work with. 
 
 
 
The path to the default template used for all 
projects is set on the Settings menu: Options>File 
Locations>Default Template file. This determines 
which template is used when you click the New 
Project icon on the toolbar. 

Add Walls  

4. On the Basics Design Bar on the left of your 
screen, click the Wall tool and draw four walls. 
Accept all the default values. The rectangle 
should be about 12 x 10 m. 

 

After you select the Wall tool, the Options Bar 
displays the different options for drawing the wall 
segments. 

 

5. Without exiting the Wall command, change the 
wall type on the Options Bar to Interior 
Blockwork 100 and draw two interior walls, as 
shown in the image. 

 
 

 

 

Select the rectangular shape to draw the external 
walls, and then switch to the linear tool to draw the 
interior walls. 
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Add Doors and Windows  

6. On the Basics Design Bar, click Door and 
place two doors M_Single Flush 0864 x 2134 
mm, as shown in the image. 

 

As you add these two doors, press the spacebar 
before you select a point to flip the swing before the 
door is placed. 
 

7. With the Door tool still active, click the Load 
button on the Options Bar. 

 

Many other door types are installed with the 
software but not available in the general template 
you started with. When you load from library, you 
are bringing in a family of doors and all its types. 
 

8. Browse to the Doors folder, select the 
M_Double Flush door type, and click Open. 

  

9. Change the door type on the Options Bar to 
Double-Flush: and position a door on the left 
wall, as shown in the image 

 

 

10. Press the Esc key twice to exit the command.   
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11. To change the swing direction, select the 
single flush door on the bottom vertical wall 
and click the vertical arrows that appear next 
to it. 
 

 

The horizontal arrows mirror the door along the wall 
it is positioned on. Both vertical and horizontal 
arrow symbols appear in doors, windows, furniture 
components, and in all families that can be 
mirrored or reversed without changing their 
geometry or function. 
 

12. On the Basics Design Bar, click Windows and 
select: M_Fixed 0915 x 1220mm and position 
some windows on the exterior walls. 

13. Right-click and choose Cancel twice to exit the 
command. 
 

 

Windows and doors are tagged automatically if Tag 
on Placement is selected on the Options Bar. To 
avoid automatic tagging, clear the option. 
 
The tags that appear when placing the components 
are set on the Settings menu: Annotations>Loaded 
Tags. 
 
To end a command in Revit Building, you can 
either press Esc two times, or right-click and 
choose Cancel two times. 
 
Alternatively, you can select the next tool you want 
to use. Select the modify tool from the top of the 
Design Bar. Type MD on the keyboard to end most 
commands and return to the basic cursor state. 

Add a Floor  

14. On the Basics Design Bar, click Floor. 

 

Sketch mode is activated when you are designing 
specific sketch-based components or geometry. 
The available options vary depending on the 
component you are designing. 
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15. You are now in sketch mode, and the Design 
Bar has changed. The default method for 
creating floors is by selecting existing walls 
(Pick Walls).  

 
16. Highlight (place the cursor over it without 

clicking) one of the exterior walls and press the 
Tab key to highlight all four walls. Click with 
the left mouse button to select the highlighted 
walls as the floor boundary. Make sure you 
click the interior side of the walls. 
 
 
 

17. Click Finish Sketch on the Design Bar to 
accept the floor sketch. 

  

 

You can re-enter sketch mode any time after 
designing the component by selecting the 
component and clicking the Edit button on the 
Options Bar. 
 
You can draw the desired shape of your object 
(floor in this case) using the Lines tool, but often it 
is much faster and easier to accept the default 
proposed mode. The Pick Walls function 
automatically recognizes the boundary of the 
connected walls and generates a closed loop of 
lines that represents the shape of the floor. 
 
When you use Pick Walls to define your sketch, 
Revit Building snaps either to the exterior/interior 
faces of the wall or to its structural core layer, as 
set on the Options Bar. 
 
This method is used frequently in Autodesk Revit 
Building. By holding your cursor over the object, 
pressing the Tab key, and then clicking, you can 
select connected chains of walls or lines. 
 
This screen capture is not from the project but 
illustrates the nature of the highlights on the 
screen. 
 
 
 
The side of the wall your cursor is on when you 
select a wall determines which side of the wall the 
sketch line is placed on. 
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18. Open a 3D view by clicking the 3D view icon 
on the toolbar. 
 

  

 

 

19. Press the keys SD (in sequence) to activate a 
shaded view or right-click the view and 
choose View Properties. In the Properties 
dialog box, change the Model Graphics Style 
to Shading w/Edges:  
 

  
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
 

You can customize keyboard shortcuts by editing 
the keyboardshortcuts.txt file in the program folder. 
 
You can rotate the model by 

- Pressing the Shift key and the middle 
button of the mouse at the same time, or 

- Clicking the icon on the view toolbar  
  

 
 

To select spin mode, open the View dialog 
box and click Spin: 

  
You can also change to Shading with Edges by 
using the View toolbar at the lower left of the 
drawing window.  
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Modify the Position of the Components   

20. From the Project Browser, open Floor Plans  
Level 1 again by double-clicking Floor 
Plans>Level 1. Select the left exterior wall. A 
temporary dimension appears. Click the 
dimension text, and type 6000 to change the 
room width to 6 meters. 

 
21. Repeat with the right exterior wall to change 

the width of the two rooms to 6 meters. 

 

The units in Autodesk Revit Building are real-world 
units: you can set them to metric or imperial. You 
can access the dialog box for setting units by 
choosing Units from the Settings menu. You can 
also work in millimeters, centimeters, or meters, set 
in the same menu. 
 
Notice that you have just defined a new position of 
the wall, but all other components adjusted 
accordingly. 
 

22. Add walls and doors to create a few more 
rooms, always using the image as a guideline. 

 

By right-clicking a component, you can use the 
Place function, which activates insertion mode for 
the desired component. This command 
automatically inserts an object of the same type as 
the one selected. 
 

 
23. Select the double entrance door and change 

its position by changing the value of the lower 
temporary dimension: Type 2000 in the 
dimension text. 

 
 
 
 
 
 
 
 
 
 
 

  
 
 
 

  

 
Temporary dimensions appear whenever you 
select a component. Edit these dimensions on the 
fly by clicking the text and typing the desired value. 
 
Transform these dimensions into permanent 
dimensions by clicking the icon that appears below 
the dimension line. 
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Add Ceilings  

24. In the Project Browser, double-click Ceiling 
Plans>Level 1. 
 
 
 

25. On the Modeling Design Bar, click Ceiling. 
On the Options Bar, click Compound Ceiling: 
600 x 600mm grid. Click once inside each of 
the rooms to automatically generate the 
ceilings. 

 

Ceilings are also sketch based. The Autogenerate 
tool is helpful, but if you need to change the shape, 
you must select the ceiling and select Edit on the 
Options Bar. 
 
Hold and Tab Key 
Sometimes selecting objects that are co-linear with 
other objects can be difficult. Hold your cursor over 
the edge of a ceiling (which is also the same 
location as a wall). Press the Tab key a couple of 
times to cycle through the objects that are at the 
cursor location. Watch the status bar at the lower-
left corner of the screen. 

 

Add a Roof  

26. From the Project Browser, open Floor 
Plans>Level 2. On the Modeling Design Bar, 
click Roof>By Footprint.  
 
 
 
 
 
 

27. You are in sketch mode. The default sketch 
mode is Pick Walls. On the Options Bar type 
500 in the Overhang box, and make sure that 
Defines Slope is selected. 

  

Roofs can be created by footprint or by extrusion. 
This exercise walks you through creating a roof by 
extrusion. 
 
If the Pick Walls option is selected, the roof 
boundary follows the wall’s position, and any 
further changes to the wall location are 
automatically propagated on the roof shape. 
 
Pick Walls is equivalent to assigning a constraint to 
maintain design intent or structural sense. 
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28. Highlight any exterior wall and press Tab to 
highlight all four. Click to create the roof 
footprint. When clicking, make sure your cursor 
is positioned on the exterior side of the walls or 
the overhang will be on the wrong side. 

 

Tab selecting is a convenient way to select chains 
of components with a one-click operation. It is 
widely used in sketch mode. 

29. On the Design Bar, click Finish Roof. A dialog 
box asks if you want to attach the highlighted 
walls to the roof. Click Yes. 

 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

By clicking Yes, you are attaching the walls to the 
roof and thus defining an explicit relationship: if the 
roof changes height, the attached walls follow 
accordingly. 
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30. Open the 3D view by clicking the 3D Icon to 
see the roof. 

 
 
 
31. Go back to Floor Plan Level 2. 
 
 
 
 
 

 

The 3D view category is automatically created once 
a 3D view is opened. You can customize view 
grouping so the Project Browser can display the 
view groups in many different ways. 
 
 
 
 
 
 
 
 
 

32. Select the roof. On the Options Bar, click 
Edit. 

 

 

33. Open Floor Plan Level 2. Select the left and 
right roof footprint lines. On the Options Bar, 
clear Defines Slope.  
 
 
 
 
 
 

 

Autodesk Revit Building manages the slopes by 
automatically adjusting most geometrical data. If 
the eaves are not correct, use the Align Eaves tool 
to correct the problem. 
 
To select more than a single item, hold down the 
Ctrl key as you select the objects.  
 
Hold down the Shift key to remove objects from an 
existing selection set. 

34. Select the top magenta line. Text displaying an 
angle value appears. Click the blue text and 
change the value to 12. Repeat for the bottom 
line. Click Finish Roof. 
 

 

Sketch lines are displayed in magenta, which you 
can change to any other color: Settings>Line 
Styles>Lines(Sketch). 
 
Change the value of the roof slope by selecting the 
slope defining line and opening its Properties dialog 
box, where you find the angle parameter. 
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Add a Camera (Perspective View)  

35. Open Floor Plan: Site. Go to View Design 
Bar and select the Camera tool. 

 
 
36. Select a point at the lower left to place the 

camera (see image). Select a point at the 
upper right to establish the direction the 
camera is pointing.  

 
 
 
 
 
 
 
 
 
 
 
 
37. Once you have placed a camera, a 3D view 

displays the building (press SD to shade the 
view). 

 

 

The camera creates a perspective view that is 
automatically placed under the 3D group in the 
Project Browser. 
 
 
An easy way to reposition your camera directly in 
perspective view is by opening the Dynamically 
Modify View dialog box and applying the different 
options available for navigating in the 3D 
workspace. 
 
 
Note that you can change or modify elements 
directly in 3D perspective views only by selecting 
the component and opening its Properties dialog 
box. 
 
 
Once the camera view is generated, the camera 
itself is no longer displayed in plan views or 
sections/elevations. To display it, right-click the 3D 
perspective view in the Project Browser and 
choose Show Camera from the context-sensitive 
menu. 



Unit 2 
Theory: Objects 

Autodesk Revit Building: Walls, Floors, and Ceilings 
 
In this unit you cover wall, floor, and roof basics. 
 
 
Add a New Level  

1. Open Elevation East. 

 

Autodesk Revit Building allows editing and creation 
of most components in all available views. 
 

2. Go to the Basics Design Bar and select Level.  Levels are managed as any other entity. 
 

3. Draw a level above Level 2 by drawing a 
horizontal line from left to right. 

 

Note how Autodesk Revit Building helps you snap 
to the beginning and end of the other level lines.  
 

4. Click the elevation text of the level mark, and 
type 8m. 

 

 
Some annotations allow direct editing of their 
properties (in this case: level height). 
 
Revit Building automatically recognizes the different 
units used for editing if the unit suffix is added after 
the value. 
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Modify the Roof Position 

5. Select the roof. Right-click and choose
Properties. 
 
 
 
 
 
 
 
 
 
 
 
 
 

6. Change the Roof Base Level to Level 3. 

  

  

 
Levels are managed as any other entity. 
 
Levels are a data element in Revit Building. Although 
they look like a standard annotation, they are the basis 
for vertical control for most components in the building 
model. 
 
 
 
 
 
 
 
 
 
 
 
 
 
Change component constraints at any time during 
the design process. 

Change Wall Type  

7. Open the 3D view. 
8. Select the four exterior walls at once (hold your cursor over one wall and press the Tab key). On the 

Options Bar, change the wall type to Exterior – Brick on Mtl. Stud. 

The template contains many different wall types: 
walls, roofs, floors, ceilings, stairs, and railings are 
system families and cannot be loaded from an 
external file except by using the Transfer Project 
Standards command on the File menu. 
 
Note that you must have at least two projects open in 
the same session for the tool to be available. 
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9. Zoom in the 3D view to see the different finishes and material of the wall type. 
 

 

 

Add a Floor Slab on Level 2  

10. Open Floor Plan Level 2. 
 
11. Right-click the Floor plan Level 2 in the 

Project Browser and choose Properties. In the 
Properties dialog box, change the Detail Level 
from Coarse to Medium. 

 
12. Change the Underlay field to None. 
 
13. On the Basics Design Bar, select Floor. You 

are in sketch mode. Hold your cursor over one 
exterior wall, and press Tab. Click to select the 
four exterior walls. 

 
14. On the Design Bar, click Finish Sketch. 
 
 
15. Click Yes when the dialog box appears: 

  

 

Views have many different properties that filter the 
information of the underlying data model and define 
how it is displayed. 
 
When clicking the wall-defining line for the floor 
slab, make sure that 
 

- The option Extend to Core is flagged on the 
Options Bar. 

 
- The green lines that appear while 

highlighting the walls are in the middle of 
the wall (or slightly off center). This is the 
exterior face of the core of the wall. 
Alternatively, if the cursor is inside the 
building, to the line between the gypsum 
finish and the stud.  
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This option correctly cleans up the intersections 
among walls and the floor. 

Constrain Walls to a Different Height  

 
16. Open the 3D view. Select the two visible exterior walls and the roof, and then click the Hide/Isolate icon 

on the View toolbar. 

Hide/Isolate is a view-specific tool that is useful 
when working in a 3D view displaying a lot of data. 
 
When the tool is active and a component is hidden 
or isolated, the icon on the View toolbar changes 
color to indicate that the view contains hidden data. 

                              

 

 
17. Select one interior wall. Right-click and choose Select All Instances. On the Options Bar, click Attach. Click 

the floor located on Level 2. You might get a warning dialog box. Ignore it. 

 



Autodesk Revit Building Student Workbook Autodesk 

 22 

                              

An explicit relationship between the interior walls 
and the slab above is established. 

 
18. Click the Hide/Isolate icon, and on the View 

toolbar click Reset Temporary Hide/Isolate. 
Close the dialog box. 

 
 

  
 

 

19. Rotate the 3D view, as shown in image. 

 

 

20. Select the front wall (containing the double door). On the Options Bar, click Detach, and then select the 
roof. 
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You can remove explicit relationships at any time. 

21. Right-click the wall and choose Properties. 
 
 
 
 
22. Change the Top constraint value from 

Unconnected to Up to Level: Level 2 and the 
Top offset field to 800. 

 

  
 
 

 
 
 
 
 

 
 

Add a Curtain Wall and Modify Its Properties  

23. Open Floor Plan Level 2. On the Basics 
Design Bar, click Wall and change the wall 
type on the Options Bar to Curtain Wall: 
Exterior Glazing. Before you start drawing, 
set the height to Level 3 on the Options Bar. 

 
24. Draw a vertical wall, as shown in the image. 
 

 

Curtain walls are considered as wall families. Most 
of the Instance parameters are the same as for the 
basic wall families, but the Type parameters are 
completely different. 
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25. Open the 3D view. 
 
26. From the Project Browser, click 

Families>Walls>Curtain Wall and right-click 
Exterior Glazing. Choose Properties. 

There are many different ways to access a family’s 
Properties dialog box. 
 

27. Change the pattern to the spacing as shown. 
Click OK to close the dialog box and see the 
changes in the model. 

 

 
28. Select the curtain wall, and on the Options Bar 

click Attach, and then select the roof. 
  

 

 
The pattern layout properties refer to the curtain 
gridlines. 
 
The available options allow for flexible editing. 
 
 
This Curtain wall type contains only the grid 
divisions. Mullions must be placed after positioning 
the curtain wall. 
 
To add mullions, on the Modeling Design Bar, click 
Mullion and click any curtain grid. 
 
 
 
 

Add a Section  
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29. Open Level 1, and on the Design Bar click 
Section. 

30. On the Options Bar, Set Type to Section : 
Building Section.  

 

31. Draw a building section, as shown in image. 

 

Like a level, creating a building section also creates 
a view that represents the section. 
 
Reverse section views by clicking the arrow 
symbols that appear next to the section head. 
 
Note: Place the section mark to the left of where 
you placed the curtain wall. 
 
Section heads and tails can be turned on or off 
and toggled among the available loaded ones by 
clicking the circular arrow symbols next to the 
section head and tail. 
 

 
32. Open the section by double-clicking the 

Building Section view that was automatically 
created in the Project Browser. 

 
 
 
 
 
33. Select the floor slabs on Level 1 and Level 2 

(use the Ctrl key) and on the Options Bar 
change the type to Generic 300mm. 
 

 

 
 
 
 
 

 
Another way to switch to the section view is by 
double-clicking the section marker in plan view. 
This method works only if the section mark is 
deselected, showing a blue section bubble. 

Modify the Curtain Wall Division, and Change a Curtain Panel into a Door Panel  
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34. Select the first gridline from the bottom of the 
curtain wall, and on the Options Bar click Add 
or Remove Segments. Click the middle 
segment to remove it. 

 
 
 
35. Using the Tab key, select the new curtain 

panel that is twice as big as the other ones 
(position the cursor next to the side of the 
panel and press Tab until it is highlighted). 
Open the Properties dialog box by clicking the 
icon on the Options Bar. 
 

 
 
 
36. Click Load and navigate to Metric 

Library>Doors>M_Curtain Wall Dbl 
Glass.rfa. 

 
 
 
37. Click OK to accept and close the Properties 

dialog box. Open the 3D view to see the 
change.  

 
 
 
 
 
 
 
 
38. From the Window menu, choose Close Hidden

Windows. 

 

  

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Load family components as needed during the 
design process. 
 
 
 
 
 
 
 
 
 
 
 
 
As you work with the different views, they remain 
open until you close them. Close Hidden Windows 
enables you to free computer memory by closing 
those windows that you are not using. 

Copy Components from One Level to the Other  
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39. Open Floor Plan Level 1.  
 
40. From the Window menu, choose Tile. 

Tiling windows allows you to work in more than one 
view at a time. 
 
 
This tool is particularly useful for selecting objects 
that may not be available to select from any one 
view. 
 
Any windows that you have minimized at the time do 
not tile.  
 

41. In plan view, draw a selection window around
the building. Use the Filter Selection button to 
filter only the windows in the selection set. 

 
 

 

The default selection with the cursor movement is as 
follows: 
• Left to right: Include only those objects entirely 

within selection box. 
• Right to left: Include any element that lies within 

or is crossed by the bounds of the selection box. 
 
When selecting individual components: 
 
• Ctrl+click adds to the selection set. 
• Shift+click removes from selection set. 

42. Press the Shift key and remove the windows on 
the left side (on the vertical wall and the first
ones from the left on the horizontal walls) from
the selection set. 

 

 



Autodesk Revit Building Student Workbook Autodesk 

 28 

43. From the Edit menu, choose Copy to 
Clipboard. Then from the Edit menu, choose 
Paste Aligned>Select Levels by 
Name>Level 2. 
 

 

Paste Aligned can be used on multiple levels at the 
same time by pressing Ctrl and clicking the level 
names in the dialog box. 

Modify a Wall Profile  

44. Open Floor Plan: Site.   
45. On the Basics Design Bar, click Wall and, from 

the Options Bar, select wall type: 
Generic200mm 
Height: Unconnected – 1500. 

  

46. Draw four walls using the rectangle template 
from the Options Bar to create the wall around 
the building, as shown in image. 

 

Change wall height as well as any other wall 
property after it has been positioned by opening the 
Wall Properties dialog box. 
 

47. Open the 3D view. 
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48. Select the north wall, and click Edit Profile on 
the Options Bar. You are in sketch mode. 

 

 

49. Select the top line of the wall and erase it. 
Create a new top profile for the wall using 
lines. Rotate the model for better visibility; 
use image as a guideline. 
Click Finish Sketch when done. 

 

When editing the wall profile, you are in sketch 
mode, and some specific rules are applied: 

- All wall constraints are removed while 
sketching. 

- The line that is constrained (usually the 
bottom and top lines) displays a lock if you 
select it. 

 

50. Repeat the process with the south wall. 

 

You can create rectangular openings in curved 
walls but not edit the profile. To achieve a different 
profile you must cut the wall with an in-place family. 



Unit 3 
Theory: Families and Nested Families 

Autodesk Revit Building: Editing Types 
In this lesson you work with families and types. You create a new wall type and window type from existing types in the project.  
 
For the wall, you create a type with a sweep for a base and a reveal (cut-out) at the top. You also split the brick, adding a new component to the wall base. Wall 
types are system families. They do not exist outside the project environment.  
 
Window families can be defined outside the project as RFA files or family files. For the window, you duplicate an existing window type to create a new size 
window. 
 
Nested families and the Family Editor are explained in Units 10 and 11. This unit explains how to duplicate, edit, and manage a system family such 
as a wall. 
 
 
 

1. Open file Unit 3 – Complete. Open to the 3D 
view and orient the view as shown. 

 

 

Duplicate a Wall Type 
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2. Right-click one of the exterior walls, and 
choose Properties. 

 

To access a component Properties dialog box, 
select the component and do one of the 
following: 
• Right-click the component, and choose 

Properties 
• Select the component, and click the 

Properties icon on the Options Bar 
 
Sketch-based families have a Properties button 
on the Design Bar while in sketch mode. 
 

3. Click the Edit/New button. 
 

 

 

4. Click Duplicate and enter Exterior-Brick on Mtl. 
Stud with Base as the new name for the wall 
type. 

 

 
It is a good idea to always duplicate an 
existing type instead of editing it directly, 
which would change the standard Autodesk 
Revit Building library. You can easily purge 
excess types later. 
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5. Click the Structure Edit button. 
 
6. Click the Preview button in the bottom left of 

the dialog box. 

 

The Preview pane displays the components in 
the views selectable from the drop-down 
menu below the preview. 
 

Load and Add a Wall Sweep   

7. Click the Edit button under the Structure field. 

 

 



Autodesk Revit Building Student Workbook Autodesk 

 33 

8. Default view is plan structure. In the drop-down 
menu located on the left pane, select Section. 

 

Every wall component has the following 
properties: layer, function, material, and 
thickness. Wall components can “wrap” 
around the wall end or at inserts. 
 
The layer determines how wall components 
clean up with each other.  
 
The material determines what hatch is shown 
when the wall is cut in section or plan or viewed 
in elevation along with the shading and 
rendering textures. Materials also affect how 
walls clean up.  
 
Note that the lower part of the structure window 
becomes active only if you switch the preview to 
Section.  
 
 
Note that the lower part of the structure 
window becomes active only if you switch the 
preview to Section. 
 

9. Click the Sweeps button in the right pane. The 
Wall Sweeps dialog box opens. 

 

 
Sweeps and reveals are profile-based. The 
sweep and reveal dialog boxes allow for 
direct profile loading. 
 

10. In the Wall Sweeps dialog box, click the Load 
Profile button. 

11. Browse to the Metric Library>Profiles. 
12. Click M_Wall Sweep Brick Soldier Course.rfa. 
13. Click Open. 

 
 



Autodesk Revit Building Student Workbook Autodesk 

 34 

 
 

14. In the Wall Sweeps dialog box click the Add 
button. 

15. Add one sweep: 
• Wall Sweep - Brick Soldier Course 1 Brick 
• Material = Brick Soldier Course 
16. The other values should default to the values 

shown. 

 

 

17. Use the drop-down dialog box to set the profile 
to the Soldier Course : 1 Brick. 

18. Click the Material line. 
19. Click Browse icon. 
20. In the material selection page, double-click 

Masonry Brick Soldier Course. 
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21. Click OK to return to the Edit Assembly dialog 
box. 

 
 
 
 

Add a Reveal  A reveal is like a sweep, but instead of adding to 
the wall form, it subtracts from it. The process 
and dialog boxes are the same. 

22. Click the Reveals button. 

 

 

23. Click the Add button.   
24. Set the reveal profile to M_Reveal-Brick 

Course : 1 Brick. 
25. Set distance to 3200. 
26. Set offset to 20. 

The profile determines the shape. 
 
The distance determines how high to place the 
reveal on the wall. 
 
The offset moves the reveal into or out of the 
wall. 



Autodesk Revit Building Student Workbook Autodesk 

 36 

27. Click OK to return to the Edit Assembly dialog 
box. 

The reveal has been applied to the wall. The 
reveal displays as the profile shape until you 
return to the drawing window. 

28. Click OK two times to return to the drawing 
window. 

 

The sweep and reveal are applied to the wall. 
The sweep adds a soldier course base. The 
reveal removes a strip from the brick at 
3200mm. 

More on sweeps 

Walls cannot have vertical sweeps set in the type, 
but they can be added manually from Modeling 
Design Bar>Host Sweep>Wall Reveal/Wall Sweep. 
You can also use this tool to create a horizontal 
instance of sweeps or reveals. 

 
Sweeps and reveals clean up correctly at angles and at 
inserts unless the inserted family contains specific solid 
elements in the family itself (that is, an exterior or interior 
door frame) that may interfere with the sweep/reveal. 

It is possible to grip-edit sweep at inserts and 
corners to redefine them. It is also possible to 
modify the sweep return around the corner. 
Select any sweep and check the available 
options on the Options Bar. 

Split the Brick Layer  You can split the vertical components of a wall, 
adding different materials. 

29. Return to the Edit Assembly dialog box for the 
wall you have been working with. 

  

30. Click the wall with the reveal and sweep. Right-
click and choose Properties. Click Edit>New. 
Click the Structure Edit button. 
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31. Click the Split Regions button. Hold your 
cursor over the masonry brick exterior layer on 
the preview, and click near the bottom of the 
wall to divide the brick structure into two parts. 

 

 

Once the regions are divided, it is not 
possible to edit the width of the component, 
as the system sets the default value to 
“variable thickness” according to how it is 
used within the wall type. That is, you could 
assign the same layer material to two different 
regions, laying on two different components, 
each with a different width. 
 
You can split wall components into as many 
regions as you want, but creating complex 
walls should be done only when the design 
idea and the construction method are clear. 
Otherwise, editing the regions can become 
difficult when there are many of them. 
 

32. Click the Modify button, and click the line 
dividing the two brick regions. 

] 
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33. With the edge selected, use the temporary 
dimension that appears to move the line to 900 
mm above the bottom of the wall. Click the text 
of the temporary dimension, and type 900. 

 

 

Add a New Wall Component   

34. Click Layer 1. Click the Insert button to create 
a new layer. 

 
 

 

 

35. Change component settings: 
 

a. Function: Finish 2 [5] 
b. Material: Finishes - Exterior - 

Render - Tan, Textured  
c. Thickness: Do not change 
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36. Make sure the layer row with the new 
component is selected. Click the Assign Layer 
button.  

 

 

37. Click the lower part of the exterior brick 
component in the Preview pane to assign the 
new wall component to it. 
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38. Click OK twice to close the dialog boxes. 
 
39. Select the remaining three exterior walls, and 

change their type from the Options Bar to the 
newly created type. 

 

 

Load a Window Family   

40. From the File menu, choose Load from 
Library>Load Family and navigate to the 
default Metric Library>Windows folder. 

 
 
41. Activate the preview in the browsing window to 

see previews of the window types. 
 
 
42. Select the window family called M_Casement 

3x3 with Trim.rfa. 

This is one of many ways to load families. In 
Unit 2 you loaded a family directly from the 
component’s Properties dialog box. You will see 
more ways to load families later. 

Duplicate a Window Family    
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43. From the Project Browser, select 
Families>Windows>M_Fixed, right-click 0915 
x 1220mm, and choose Select All Instances.  

 

Selecting families from the Project Browser is 
a convenient way to create a selection set for 
a specific family type. Because it is not view 
specific, it selects all types contained in the 
model. 
 
You can also select all instances by right-
clicking one of the windows in any view and 
choosing Select All Instances from the context-
sensitive menu. 

44. On the Options Bar, change the window type to 
M_Casement 3x3 with Trim 0915 x 1220mm. 

  

45. Without deselecting the windows, right-click 
and choose Properties. 

 

 

46. Click the Edit/New button. 

 

The Edit/New button opens the Type’s element
Properties dialog box. You can define Type 
parameters and Instance parameters during 
family creation. 

47. Click the Duplicate button.  Duplicating the window type and modifying 
the window family does not automatically 
update the family file (RFA) stored outside the 
project file. You export the family to your 
library at the end of this exercise. 
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48. Create a new type named 1100 x 1400mm. 

 

It’s a convention to name types using their 
size so that other people using families can 
easily trace and understand them. In a team, 
conventions are a fundamental part of the 
design process optimization in order to share 
the data consistently. 
 

49. Change Height value to 1400 and Width value 
to 1100. 

 

There are many parameters in this dialog box 
that vary in type: length, material, text, and other 
component-specific properties. Try changing the 
materials to see what happens. 

50. Click OK twice to close all dialog boxes.   
Export the Window Family   

51. From the File menu, choose Save to Library 

 

Remember to save in a location that makes 
sense. In this example it is the Workbook 
Data folder. Always keep your personal 
libraries separate from the default installed 
library. 
 

52. From the Family to Save drop-down menu, 
select the family M_Casement 3x3 with Trim. 

 

If you save your libraries in the same folder as 
the Revit Building libraries, you might lose all 
of them if you forget to pull them out before 
upgrading to the next release of the software.  
So, make it a habit to create your own library 
folder. 
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Unit 4 
Theory: Parameters 

Autodesk Revit Building: Dimensions, Doors, and Windows 
 
In this unit you explore dimensioning of doors and windows.  
 
Dimensions for Locating Objects 
When you work with doors, you work with both the temporary and permanent dimensions. Temporary dimensions appear any time a model object is selected in a 
view. When the object is deselected, the dimension disappears. Permanent dimensions are an annotation placed in the current view. Permanent dimensions are 
specific to the view and do not show up in other views. Dimensions are much more than instructions to the contractor to build these elements at this location. 
Dimensions in Revit Building are one of the mechanisms for locating objects accurately in the building model. 
 
Dimensions for Modifying Subcomponent Locations Within a Family 
In the second section of this exercise you work with dimensions within the window family. Many families have parameters allowing control of the relationships and 
locations of the subcomponent parts. This relationship is often established by family type. Modifying these parameters affects all instances of that type. Also 
defined by the family are instance parameters. A general rule is that the instance parameters control the location of an object within its host. Each of these 
parameters is determined by the author of the family. They can differ from family to family, and you will become familiar with accessing both the instance 
parameters and type parameters when working in the Revit Building environment.  
 
Add Doors and Locate with Temporary Dimensions 

1. Open file Unit 4 – Start. Open Floor Plan 
Level 2. Zoom into the east area of the 
building. 

 
 

 

These walls have been added for you. 
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2. From the Basic Design Bar select Door and 
from the Options Bar, select door type: 
M_Single-Flush: 0762 x 2134mm. 
 

3. On the Options Bar, clear Tag on Placement. 

 

 

4. Position the cursor over the vertical wall, as 
shown in the image. 

 

 
The door opening side is defined while 
positioning the door by moving the cursor 
from one side of the wall to the other. 
 

 
Pressing the spacebar while positioning 
allows changing of the swing direction. 
 

5. Click to place the door. Try to place it so that 
the opening is in front of the perpendicular 
wall. 

 

A Warning dialog box displays if there is a 
conflict between the door and the wall. 
 

 
If you want, you can ignore this warning and 
resolve the problem later.  

Click the Close X to
dismiss the warning or just proceed to the next
door. 
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6. On the Basic Design Bar, click Modify, and 
select the door.  

 

 
 

When you select a door, two symbols appear.  
Use them to invert opening side and/or swing 
direction. 
 

  Invert swing. 

 Invert side. 

7. Click the text of the dimension that is attached 
to the horizontal wall in the middle. The value 
becomes editable. Type 5cm and press Enter. 

 
 

 

8. On the Basic Design Bar, click Door and from 
the Options Bar, select door type: M_Single-
Flush: 0864 x 2134mm.
 

9. On the Options Bar, clear Tag on Placement. 
 

10. Place doors, as shown in the image. Use 
temporary dimension to get an idea of location 
relative to walls.  
 

 

 
 

 

11. Select door on the right side. Temporary 
dimensions appear, but they won’t help you to 
adjust the position for this door, which must be 
placed in the adjacent room. 

 

 
 

You can edit temporary dimensions with the  
control boxes (blue squares) on each witness 
line. Just click a control box and drag it to a 
new position or right-click it and choose Move 
Witness Line from the context-sensitive 
menu.  
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12. Drag the blue square to a new position (face of 
the vertical wall) and then release to validate 
the position, as shown in image.  
 

13. Click the text of this dimension, and the value 
becomes editable. Type 10cm and press 
Enter. 

 

 
 

Note: You can click these control boxes (blue 
squares) to move the witness line to another 
reference point. Following is an example for a 
wall, but it works for doors, windows, and so 
on. 
 

 
 
Click these control boxes to move the witness
line to another reference point. There is a
limited set of points the witness lines will find
with this method.  
 
By dragging this control box, you can move to
entirely different objects. 

 
14. Select the door on the left side. With 

temporary dimensions, adjust the position so 
that the door is placed 20cm from the vertical 
wall on the left. 

15. Click horizontal control arrows to flip the door. 

 

 
 

 

16. With the door still selected, click the symbol
( ). The temporary dimension becomes a
permanent dimension. 

 

 
 

You can use permanent dimensions to 
annotate your design, and they can be useful 
to place a relationship between components. 
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17. Press Esc twice and select the permanent 
dimension that you just placed. Click the blue 
lock near the dimension line. 

 
 

When you click to lock the dimension, you 
are creating an explicit relationship. If you 
move the wall, the door retains its position 
relative to the wall. 
 
If you delete a dimension that establishes a 
relationship, Autodesk Revit Building displays 
a warning asking what you want to do. You 
can delete the dimension and keep the 
relationship or simply delete the dimension 
and the relationship. 

18. On the Basic Design Bar, click Modify. Select 
the three doors (use Ctrl to multiselect), and on 
the Edit toolbar, click Mirror. 

 

 

 

19. On the Options Bar check that Pick and Copy 
are selected. Click the horizontal wall on the 
right side. 

 

 
 

Use the Options Bar to 
• Draw or select an axis for the mirror.  

  
  
• Choose if you want to copy the mirrored 

objects. 

  

Load a Door Family and Change a Type 
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20. From the File menu, choose Load from 
Library>Load Family. Navigate to the Doors 
folder where you have saved the data set. 
Select Double-Raised Panel with 
Sidelights.rfa and click Open. 
 

21. Open the 3D view and rotate the model so that 
you can see the double door. 

 
 
 
 

The easiest way to rotate the model is by 
pressing the Shift key and the middle button 
of the mouse at the same time. 
 

22. Select the door, and from the Options Bar, 
select Double-Raised Panel with Sidelights: 
1830 x 2134 mm in the type selector. 

 

 
 
 

 

Change Type and Instance Parameters 

23. Open Floor Plan Level 2.  
 

24. On the Basic Design Bar, click Window and on 
the Options Bar, click Load. 

 
25. Navigate to the Metric library\Windows folder, 

select M_Casement with Trim.rfa, and click 
Open. 

 
26. On the Options Bar, click M_Casement with  

You can a load a family in a project in many 
different ways: 
 

- Choose Load from Library>Load 
Family from the File menu 

- Select the corresponding button on 
Design Bar and click Load on the 
Options Bar 

- Drag a family from Microsoft® 
Windows® Explorer and drop it into 
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Trim: 0610 x 0610mm and clear Tag on 
Placement. Add two windows on the vertical 
wall (east side) using the image as a guide. 

 
 

Revit Building 

27. Using temporary dimensions, adjust the 
window’s position at 400mm from the horizontal 
wall. 
 

 

 
 

The casement window is like the casement 
3x3 window, but without the muntins. 
Different geometry, different family. 

28. Zoom around the windows. 
 

29. Select a window, and on the Options Bar click 
Properties. 

  
 

You can right-click to display the context-
sensitive menu and then choose Properties. 
 

 
 

30. In the Element Properties dialog box, click 
Edit/New. 
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31. In the Type Parameters dialog box, change the 
Window Inset parameter to 100mm. 

  
 

 

32. Click OK in the Type Parameters dialog box 
and OK in the Element Properties dialog box 
to accept change and exit. 

  
 

Before    After 
 

Window Inset is a type parameter. If you 
modify a type parameter, all the instances in 
the project that belong to the same type are 
modified accordingly.  
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33. Go to Elevation East and select the two 
windows. 
 

34. On the Options Bar, click Properties. 

 

When you change an instance parameter, 
only the selected components are modified. 

35. In the Element Properties dialog box, change 
the Sill Height parameter to 1705mm. 

 

  
 

 

36. Click OK in the Element Properties dialog box.

 

 

 



Unit 5 
Theory: Representations 

Autodesk Revit Building: Views, Visibility, and Sheets 
This unit covers the display features and capabilities of Autodesk Revit Building, as well as covering some different presentation methods. 
This unit includes four exercises: 

• Exercise 5a leads you through adding a section and detail callout. This exercise also covers adding views to sheets. 
• Exercise 5b adds some material to the roof of the building. 
• Exercise 5c illustrates some fine-tuning control over the visibility and cleanup of wall in plan view. 
• Exercise 5d demonstrates how to create a sun and shadow study for your model. 
• Exercise 5e shows how to import a model created in Autodesk Revit Building to Autodesk® 3ds Max® software for visualization. 
•  

Unit 5, Exercise A: Sections, Views, and Sheets 
In this exercise you add a section to the building. You then adjust the view properties for the section and add a detail callout to the section view. At the end of the 
exercise you create a new sheet and composite the views on the sheet. 
 
 
This unit covers the display features and capabilities of Autodesk Revit Building. 

1. Open file Unit 5a – Start. Open Floor Plan 
Level 1.  
 

2. Zoom into the two first rooms on the left side of 
the building. 

 
 

 

 
 

 

3. Right-click in the view, and choose View 
Properties.  

You don’t have to open a view to edit the 
properties. You can simply right-click a view 
in the Project Browser and then choose 
Properties from the context-sensitive menu. 
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4. In the Element (view) Properties, change the 

detail level parameter to Coarse and click 
OK. 

 

 
 

Note that in coarse mode the wall structure is 
no longer displayed. 
 
When you set the detail level, the stucture is 
displayed. This setting is also accessible from 
the View toolbar. 
 
Autodesk Revit Building allows three different 
levels of detail (Fine, Medium, and Coarse). 
Objects in the project display correctly for 
each detail level.  
 
The Detail level of a view is also available 
from the drawing window toolbar. 
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5. Open Floor Plans - Level 2. 
 
6. Right-click in the view, and choose View 

Properties. 
 
7. In the Element Properties dialog box, change 

the Underlay parameter to Level 1. 

 

 
 

Autodesk Revit Building enables you to 
choose which view you want to use as an 
underlay. The view is displayed in gray, but 
you can use these elements for alignments or 
as a reference for new objects.  
 
Any level in the building can be used as an 
underlay, or simply choose level below or 
level above. 
 
You can choose to view the underlay in plan 
or reflected plan (ceiling) view. 
 

 
8. Open Floor Plans – Level 1. 

 
9. On the Basic Design Bar, click Section. Set 

Type Section: Building Section. 
  

 

 
10. Draw a line from left to right. Use the image as 

a guide. 

 

The direction used to draw the section line 
defines the direction of the section. 
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11. Click in a white area to end the command and 
return to the Modify tool. This should deselect 
the section at the same time. 
 

12. Double-click in the middle of the circle of the 
section bubble in the project. (The section 
bubble should be blue when you do this. In 
other words, it should not be selected.)  

 

You can also right-click the section line and 
then choose Go to View. 
 

 
 

13. Use the window view toolbar to select Shaded 
with Edges. 

14. Type WT on the keyboard to tile the windows. 
Close any windows you do not want to see, 
and type WT to tile the windows again. 

 

 

 

There are four model graphics style modes: 
 - Shading with edges 
 - Shading 
 - Hidden lines 
 - Wireframe 
 
You have created a new view in the project. 
This view is automatically added to the 
Project Browser under Sections. 
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15. Go to Floor Plans – Level 1. 
 
16. Select the section line. Some symbols are 

displayed next to the section line.  

 Flip the section. Cycle through 
different symbols for the section line. Change 
the symbol at each end of the section line. 

17. Click the arrow symbols to flip the section. 
 

18. Open the section view. 

 
 

 

19. In Floor Plans – Level 1, select the horizontal 
section line. 
 

20. Drag the blue double arrow (in the middle of 
the green dashed line) so that this point is 
above the exterior south wall. 

 

 
 

When you move this point, you change a 
view parameter value: Far Clip Offset. You 
can change it in the view properties by 
assigning a value in the field. 

 
21. Make the section view active. 

 

The section view is now cut by the far clipping 
plane. 
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Add a Detail Callout 
 

 

22. From the Design Bars View tools, click 
Callout.  

23. On the Options Bar, change the Type to Detail 
Callout. 

24. Check that Scale is set to 1 : 20. 

 

 
 

You can modify the scale later in the callout 
view properties. 

25. Draw a detail frame (click and drag) around 
the intersection between the floor and the 
exterior wall on the right side of the building, 
as shown in the image. 
 
 

 
 

Adjust the size of the frame and replace the 
bubble by dragging the blue grips. 

26. Double-click the bubble that is attached to the 
callout frame. 

 

A callout view can be opened like the section 
view. Right-click the symbol, and then choose 
Go to View. 
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27. Select the frame around the view. Use the blue 
grips to resize the view so that you see only 
what you want to show in this callout. 

 
 

Display this frame in any graphical view. It's a 
view parameter named: Crop Region. 
 

 
 

In a callout view (as in any other view) you 
can use detail tools. See Unit 14 for a 
complete description of this process. 

 
 

28. From the Project Browser, right-click Floor 
Plans - Level 1, and choose Duplicate.  

 

 
 

Duplicate a view with detailing (Duplicate with 
Detailing) or without (Duplicate). If you 
choose Duplicate, then none of the detail 
components (those that are view specific, 
such as dimensions, tags, annotations) are 
duplicated. 
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29. From the Project Browser, right-click Copy of 
Level 1, and choose Rename from the 
context-sensitive menu.  
 

30. In the Rename dialog box enter a new name 
for the view: Level 1 – Area, and click OK. 

 
  

 

31. From the Window menu, choose Close Hidden 
Windows. 
 

32. In the Project Browser open Floor Plans –
Level 1. 

 
33. From the Window menu, choose Tile. 
 
34. You can now see the views side by side. 
 

 

 
 

 

35. In any view, move a wall. Notice that in all 
other views, that wall moves accordingly.  
 

 
 

Keep in mind that it's the same wall in the 
same building. When you move that wall in 
any view, all other views where that wall is 
visible automatically update. 
 
Even if you copy a view you can choose to 
display it with a different scale, different detail 
level, different shading mode, and so forth.  
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Working with Shade and Shadow 
 

Autodesk Revit Building provides the ability to 
work with shade and shadow directly in any 
view. This is part of the view properties called 
advanced model graphics. 

36. Set the West Elevation current.  

 
 

  

37. Right-click in the view, and choose View 
Properties. 

 
 

 

  

38. Click the Advanced Model Graphics>Edit 
button. 

 
 

  

39. Select Cast Shadows.  
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40. Click the browse arrow for Sun and Shadows 
Settings. 

 
 

 

  

41. Change the preset to Sunlight from Top Left.  

 
 

This is in relationship to the plan view of the 
building. 

42. Click OK three times to return to the drawing 
window. 

 
 

 

The shadow is now generated on the 
elevation. 
 
If the shadows do not show up immediately, 
change to a different view and return to this 
or try the refresh key (F8) on your keyboard. 

Creating Sheets 

 

In Autodesk Revit Building, a sheet is another 
view of the building model. Sheets are listed in 
the Project Browser in their own category 
directly above the family list. The overall flow is 
as follows: 
• Create a sheet. 
• Place any view (plans, sections, elevations) 

on the sheet by dragging it onto the sheet 
view. 

• Adjust the properties of the plan view to 
meet your presentation needs. 
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43. In the Project Browser, right-click Sheet and 
choose New Sheet from the context-sensitive 
menu. 

 

 

44. In the Select a Titleblock dialog box, click OK 
(use the default A1 metric). 

 

To choose another title block, you have to 
first load them in your project. To load a title 
block, click the Load button in the Select a 
Titleblock dialog box.  

45. From the Project Browser, drag Floor Plans – 
Level 1 onto the sheet. 

 

Autodesk Revit Building won't let you place 
the same view twice on a sheet or the same 
view on two separate sheets. Instead, you 
duplicate the view you want place on two 
separate sheets.  
 
The crop region determines the size of the view 
on the sheet. By default, the view is set to the 
extents of the objects in this view.  
 

46. In the Project Browser, right-click Floor Plans – 
Level 1, choose Properties, and change View 
scale parameter to 1: 100. Click OK. 

 

The view’s scale determines how large an 
area it takes up on the sheet. 
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47. Open Floor Plans Level 1. 
 
48. Select the elevation marker with a window 

selection with the cursor. 
 
49. Drag the elevation marker away from the 

surrounding low wall. 
 

   

The elevation mark has two pieces: the 
square and the triangle. Select them both. 

50. Open the sheet.  
 
51. Notice that the size of the view now 

incorporates the new location of the elevation 
marker. 

52. Move the view into the middle of the sheet.    

The title of the view also moves with the plan 
view. 

53. Click the view border to activate the blue grips. 
54. Grip stretch the right grip to make the title line 

shorter. 
 

 

 

55. Drag the title line at the lower left underneath 
the plan view into place. 

 
56. Hold your cursor over the title mark and press 

the Tab key until you cycle through to 
Viewports: Viewport: Viewport 1: Shape 
Handle. 

 

 

If you cannot get the tooltip to appear with 
Viewports: Viewport: Viewport 1: Shape 
Handle, watch the status bar at the lower left 
for the same information. 
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57. Click the left mouse button, and drag the title 
mark into place. 

 

 

Adjust the Crop Region for the View 
 

 

58. In the Project Browser right-click Floor Plans – 
Level 1 and choose Properties. 

 
59. Turn on the crop region for the view. 
 
60. Set Level 1 current. 

 

 

61. Select the crop region, and drag the blue grips 
toward the building. 

 

 

62. The drawing sheet now reflects the smaller 
bounds established by the crop region. 

 

Relocate and resize the title mark to match 
the new bounds of the view. 
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63. Open the sheet. 
 
64. Select the viewport in the sheet. 
 
65. Click the Properties button. 

 

The properties of the viewport are linked to 
the properties of the view, in this case Floor 
Plan Level 1. 

66. Change the scale of the viewport to 1:50. 

 

When the view scale changes back to 1:50, the 
size on the sheet changes.  
 
If the title mark is selected as part of the 
viewport, you can just drag the ends of the 
title mark into position. Also use the Shape 
handle.  

67. In the Project Browser right-click Floor Plans 
– Level 1 and change View Scale parameter 
to 1:100. Click OK. 
 

68. Move the view on the sheet in the upper left. 
 
69. In the same way, place elevations (west/north) 

and the Section 2. 

 

Take a look at the symbol of the section line. 

Autodesk Revit Building recognizes what 
sheet this section is positioned on and 
automatically fills in this information in the 
section bubble. Place the section on any 
other sheet, and the bubble updates. Section 
bubbles are families that can be customized 
to display other information. 
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Unit 5, Exercise B: Display Control of Materials 
This exercise takes you through creating a material for the roof in the project from the last exercise. 
 
Exercise Setup   

1. Open file Unit 5b – Start.  

2. Set Floor Plans : Level 3. 

  

3. Right-dlick in the view, and choose View 
Properties. 

4. Click the Edit button next to View Range.  

 

5. Set the top offset to 10000. 

6. Set the Cut plane offset to 10000. 

7. Click OK to close the dialog boxes. 
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Create a New Roof Type 
 

  

8. Click the roof and click the Properties button 
on the Options Bar. 

  

9. In the Roof properties dialog box: 

a. Change the roof type to Steel Bar Joist – 
Steel Deck - EPDM Membrane. 

b. Click the Edit/New button. 

 

10. In the Type properties dialog box: 

a. Click the Duplicate button and name the new 
roof type Steel Truss - Insulation on 
Sheathing with Metal Roof. 

b. Click the Structure’s Edit button. 

  

11. In the Edit Assembly dialog box: 

a. Click the Preview button if you do not see a 
preview by default (a last used setting). 

b. Click Layer 5’s material, and then click the 
browse arrow that appears. 

 

12. Click the Light Gauge Steel Joist material.  
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13. Repeat for layer 4, changing the material from 
Metal – Deck to Wood – sheathing – 
Plywood. 

14. Change the thickness of this layer to 19.  
Do not close the Edit Assembly dialog box yet. 

Create a New Material and Assign to the Roof 
Type 
 

In this section you continue editing the 
assembly but create a new material on the fly. 

All materials defined in the project file can be 
accessed by choosing Materials from the Settings 
menu.  
 
In this example you access these material definitions 
directly from the Edit Assembly dialog box. 

15. Click Layer 1’s material, and then click the 
browse arrow that appears. 

  

16. Click the Metal Panel entry, and then click the 
Duplicate button. 

 

17. Enter Metal – Roofing Standing Seam as 
the name of the new material. 

  

18. Click the Color button in the Shading portion 
of the Material dialog box, and pick a teal 
green color for the roof. 

This color is used only when the view is set to shading 
or shading with edges. 

 There currently are no standing seam materials 
provided with the software. If you have a JPG, you can 
create an AccuRender material from the image file. For 
this exercise as we are not going to render this 
building, leave this material as you find it. 



Autodesk Revit Building Student Workbook Autodesk 

 69 

 The Surface Pattern is empty for this material. There is 
no Standing Seam fill pattern either. You will create 
these patterns on the fly. 

Create a New Fill Pattern for the Material 
 

In this section you create a new fill pattern on 
the fly to use in the material you just created. 

 

19. Click the Browse arrow to the right of the 
empty surface pattern field. 

  

20. In the Fill Patterns dialog box: 

a. Click the Drafting radio button. 
b. Click the New button. 
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21. In the New Pattern Dialog box: 

a. Set Orientation in Host Layers to Align with 
Element. 

b. Click Simple radio button. 
c. Name the pattern Standing Seam. 
d. Set the line angle to 90. 
e. Set the line spacing to 7. 
f. Click the Parallel Lines radio button. 
 

 

 

22. Click OK six time to close all dialog boxes 
and return to the drawing window. 

Drafting patterns change their scale depending on the 
view scale. Changing the scale of the view to 1:20 
keeps the plotted distance between the lines 
consistent to 7mm. 
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Create a Model Fill Pattern and Assign to the 
Material 
 

In this section you modify the material to use a 
new model fill pattern. 

 

23. From the Settings menu, choose Fill 
Patterns. 

 

 

24. This time click the Model radio button, and 
then click the New button. 

  

25. In the Add Surface Pattern dialog box set: 

a. Type = Simple 
b. Name = Standing Seam 
c. Line Angle = 90 
d. Line Spacing = 750 mm 
e. Parallel Lines 

26. Click OK to close all dialog boxes. 
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27. From the Settings menu, choose Material. 

 

 

28. Set the new roof material’s surface pattern to 
Standing Seam (Model). 

 

 Model surface pattern dimensions are set by the fill 
pattern definition and do not vary by drawing scale. 

 

Unit 5, Exercise C: Fine-Tuning Wall Cleanup and Display 
This exercise illustrates some of the different display and cleanup control you have over walls in your Revit Building project. 
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Exercise Setup   

1. Open file Unit 5c – Start. Open Floor Plan 
Level 1.  

2. Verify the view’s detail level is set to Coarse. 

 

 

Set Fill for Coarse Level Display Revit Building walls have a separate control for the 
display detail level “Coarse”. This coarse fill pattern 
and color enable you to poche the entire width of the 
wall regardless of the number of components in the 
wall. 
 
This setting is a type parameter for the wall. 
 

3. Select any wall, and open its Properties 
dialog box. 

  

4. Click the Edit/New button to access the wall’s 
type properties. 
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5. Verify that the coarse scale fill color is Black. 

 

 

6. Click in the Value field of the Coarse Scale 
Fill Pattern parameter, and click the browse 
arrow that appears in the field. 

 

7. Click Solid Fill for the fill pattern. 

 

 

8. Click OK two times to close all dialog boxes 
and return to the drawing window. 

 

 

Because this is a type parameter, you need to repeat 
this process for all wall types used in the project. 
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Global Control of Linework Display of the 
Walls: Object Styles 

 Revit Building walls have a separate control for the 
display detail level “Coarse”. This coarse fill pattern 
and color enable you to poche the entire width of the 
wall regardless of the number of components in the 
wall. 
 
 

9. Set the View Detail level to Medium. 

 

 

10. From the Settings menu, choose Object 
Styles. 

 
 
 

 

11. On the Model Objects tab of the Objects 
Styles dialog box, scroll down the list of 
objects and expand the Walls category. 

 

The Object Style dialog box controls the lineweight, 
color, and linetype.  
 
This is also the location where you can assign 
materials to obects. 
 
In all cases if the object is set to “By Category” for any 
of these parameters, these are the values referred to. 

12. Change the Walls Cut Line color to Blue and 
the Common Edges to Red. 

Changes you make in the Object Styles dialog box are 
global and apply to all views. 
 

13. Click OK to return to the drawing window.  The object styles are now applied to all wall types in 
the project. The Wall’s Cut (pen 5 and blue) refers to 
the outer edge of the wall. The Wall’s subcategory 
Common refers to the lines common to the layers 
within the wall. 
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Override of Linework Display of the Walls: View 
Visibility/Graphics by Category 

Each view has its own override to the global 
object style settings. A couple of the previous 
exercises have used this control to manipulate 
how objects are displayed in specific views.  
 

The Visibility/Graphics dialog box also holds overrides 
to the wall component display graphics. 
 

14. Open the View properties for Floor Plans: 
Level 1. 

15. Click the Edit button for the Graphics 
Visibility. 

 

16. Click the Walls Cut Line style and set the 
override line color to a dark green. 

17. Click OK to close all dialog boxes and return 
to the drawing window. 

 
 

These changes are only for the current view. 

 

18. Return to the view’s Visiblity/Graphics 
override dialog box, and on the Model 
Objects tab set the Cut Pattern Color to dark 
red. 

19. Click OK to return to the drawing window. 

The override applies to all cut patterns for all layers in 
the wall type. 
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Override of Linework Display of the Walls: View 
Visibility/Graphics and Cut Line Styles 

  

20. Return to the view’s Visiblity/Graphics 
override dialog box. 

a. Select the Cut Line Style check box. 
b. Click the Edit button. 
c. Set the Structure[1] to Line Weight 5. 

21. Click OK to close all dialog boxes and return 
to the drawing window.  

 

Any layer in the wall type definition assigned to the 
structure layer now has the wider (pen 5) lineweight 
assigned to it. 

 
 

22. Return to the view’s Visiblity/Graphics 
override dialog box. 

a. Click the Cut Line Style’s Edit button. 
b. Set Core Layer Clean-up to Use Function. 

23. Click OK to close all dialog boxes and return 
to the drawing window. 

 

This setting affects only the layers within the core of 
the wall type’s definition. 

 

24. Return to the view’s Visiblity/Graphics 
override dialog box. 

a. Click the Cut Line Style’s Edit button. 
b. Set Core Layer Clean-up to Use Common 

Edge Style. 

25. Click OK to close all dialog boxes and return 

 

This setting affects only the layers within the core of 
the wall type’s definition. Joins between individual 
walls are shown, but using the common edge style 
graphic line. 
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to the drawing window. 

    

26. Repeat the step and set Core Layer Clean-up 
to No Edge. 

 No edges are shown at the core cleanup condition 
between joins. 

    

Wall Cleanup and Joins Revit Building walls automatically clean up as 
they are added to the project. This section of 
the exercise guides you through control of 
some special conditions. 

 

27. Zoom into Condition A in the project. 

28. Click the Edit Wall Joins tool on the toolbar. 

 

 

 

29. Hover your cursor over the intersection of the 
walls until you see a square appear around 
the intersection. Click that area. 

Once an intersection has been selected to edit, the 
configuration control appears on the Options Bar. The 
Next and Previous buttons cycle through various ways 
this intersection can be cleaned up. 

30. Click the Square Off radio button and then the 
Next button until you cycle through to the 
solution shown at right. 
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31. While Still in the Edit Wall Joins mode, click 
the intersection of the inverted T at condition 
C. 

 

This illustrates a condition that might happen a new 
wall abuts an existing wall. In this case you do not 
want the core penetrating through the existing 
(horizontal) wall. 

32. On the Options Bar, use the Display drop-
down to select Don’t Clean Join. 

 

 
 

The join is disallowed, and the wall does not cut 
through the existing brick face. 

 

33. Click the Modify tool to exit the Edit Wall 
Joins Function, and zoom into the other 
intersection at condition C. 

 This condition is similar to the last; however, there are 
three walls that make up the intersection. You cannot 
disallow all joins because you still want the two 
existing walls to clean up. 

34. Click the right wall of the three walls at this 
intersection, and right-click on the blue end 
grip of this wall. 

35. Choose Disallow Join from the context-
sensitive menu. 
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36. Drag the wall end to the exterior face of the 
existing brick. 

 

 

Wrap the End of the Wall  You have control over the wrapping behavior 
of each of the components in a wall type 
definition. 

 

37. Zoom into Condition B in the project. 

38. Open the type properties of the horizontal 
wall. 

 

In this case the brick does not wrap around the end of 
the wall to provide closure to the curtain wall. 

39. Change Wrapping at Ends to Exterior. 

40. Click OK to close all dialog boxes and return 
to the drawing window. 

 

The exterior layers now wrap the end of the wall. 

 
 

 Within the Structure of the wall type, you can control 
which layers wrap. 
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Join Geometry You have control over the wrapping behavior 
of each of the components in a wall type 
definition. 

 

41. Right-click the wall at condition D, and 
choose Create Similar. 

42. Draw a vertical wall from the number 1 to 2. 

As long as the walls do not cross near the end of a 
wall, the walls will clean up. 

 
 

43. Right-click the wall at condition e, and choose 
Create Similar. 

44. Draw a vertical wall from the number 3 to 4. 

 

If crossing walls do not clean up, you can use the join 
geometry tool to force the cleanup. 

45. Click the Join Geometry tool on the toolbar. 
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46. Click one of the walls, then the other. The two walls now clean up with each other. 

 
 
 

Unit 5, Exercise D: Sun and Shadow Studies 
This exercise leads you through using the sun and shadow features of Revit Building. 

 
 

Exercise Setup    

1. Open file Unit 5d – Start.  

2. Set the 3D Views : {3D} current. 

3. Click the Show Mass tool on the toolbar. 
 

 

Duplicate the 3D View Create a new view for the sun studies. While not required, you could do the sun study in the 
3D view. Because many of the settings for the sun 
studies are view specific, creating a view specifically 
for the sun study is a good idea. 

4. Click the Dynamically Modify View tool. 

 

 



Autodesk Revit Building Student Workbook Autodesk 

 83 

5. In the Dynamic View dialog box: 

a. Click the Expansion bar at the right of the 
Dynamic View dialog box. 

b. Click Orient to a Direction, and click 
Southwest Isometric. 

c. Click the Save icon. 

  

1      2   3    4  

6. Name the new view Southwest Isometric Sun 
Study. 

 

Set the Sun Study Parameters The parameters that drive the sun study’s 
function are held in the advanced model 
graphics for the view.  

You can access the advance model graphics either 
through the view properties or via the context-sensitive 
menu of the drawing area window, as shown here. 

7. Click the Shadows pop-up menu of the 
drawing window, and then click Advanced 
Model Graphics. 

 

 

8. In the Advanced Model Graphics dialog box: 

a. Select the Cast Shadows check box. 
b. Click the Sun and Shadows Settings arrow. 
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9. In the Sun and Shadow Settings dialog box: 

a. Click the Single-Day tab. 
b. Change the place settings, date, and time 

interval to your preferences. 
c. If you do not have a toposurface in the 

model (discussed in chapter 12), leave the 
Ground Plane at Level check box selected. 

10. Click OK to close all dialog boxes and return 
to the drawing window. 

 

 
 

Preview the Sun Study in the View With the sun study parameters set, you are 
now ready to view the sun and shadows cast 
on the building model.  

 

11. Click the Shadows pop-up menu of the 
drawing window. 

a. Choose Preview Solar Study. 
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12. On the Options Bar, click the Play button.  

 

 The sun study plays through the day, cycling at the interval specified in the sun and shadow settings.  

 
Click the Next Frame button to manually walk through the study. 

Export the Sun Study to an AVI File With the sun study parameters set and 
previewed, you are ready to export the sun 
study to a movie format file. 

 

13. From the File menu, choose 
Export>Animated Solar Study. 
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14. In the Save As dialog box, set the following: 

a. Name the AVI file. 
b. Change the frames per second to 1 as we 

have left the default at 1 frame per hour. 
Having 15 frames per second would make 
for a very short AVI file! 

c. Adjust the format display mode and 
dimensions to your preferences.  

15. Click the Save button. 

 

16. Change the compression codec if you want, 
and click OK. 

 

The compressors available depend on what software 
is installed on your machine. Full Frames is the most 
compatible compression method, but also produces 
the largest file. 



Importing an Autodesk Revit Building Model into Autodesk 3ds Max 
 
The following exercise describes how to import an Autodesk Revit Building model into Autodesk® 3ds Max® software for visualization. 
 

Set up Your Model for Export 
  

1. Before exporting your model, find the 
appropriate 3D view. Either use the default 3D 
view, or create your own by placing a camera. 
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2. If you prefer to set up a camera, simply go to a 
plan view. From the View menu, choose 
New>Camera. 

 

 

  

 

 

 

3. Place the camera to create the appropriate view. 
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4. With the camera in place, your 3D view is now 
ready for export. 

 

 

 

Export Your Model 
 

Autodesk Revit Building exports data in a variety of file formats, 
including DWG™ format. 

 

5. To export your design to the DWG format, from 
the File menu, choose Export>DWG, DXF, 
DGN, SAT. 

 

 

 

6. Choose a location to save your exported model, 
accept the default values, and click OK. When 
exporting a camera view, you see an alert 
indicating that the entire model, including 
everything not seen in the current view, will be 
exported. Click OK. 
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Link Your Model to 3ds Max 
 

You can either import DWG files into a 3ds Max session or link them. 
Linking a DWG file to a 3ds Max session gives you the advantage of 
making subsequent changes in Revit Building and reloading them, via 
an exported DWG file, into 3ds Max without any data loss. 
 

 

7. To link the DWG file, from the File menu, choose 
File Link Manager. 
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8. When the File Link Manager dialog box appears, 
click the File button on the Attach tab and 
browse to the exported DWG file. 

 

 

 

9. Select the DWG file and click Open. 
 

 

Make sure that any cameras 
created in Revit Building are also 
available in 3ds Max.  
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10. In the File Link Manager dialog box, click the 
Presets tab and modify a Named Preset. 
 

11.  If you do not want to modify an existing preset, 
copy it and then modify it. 

 

 

 

12. There are several options on this tab. To ensure 
that your Revit Building cameras are available in 
3ds Max, make sure the Views check box is 
selected. 
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13. Save your modifications and then go back to the 
Attach tab in the File Link Manager dialog box.  

 
14. Click the Attach This File button to load the 

DWG file into 3ds Max. Then click Close. 
 

 

 

15. Your model is now loaded into 3ds Max. 
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16. Once the model is loaded, you can change the 
view to one of the camera views created in Revit 
Building by simply right-clicking the view name in 
the upper-left corner of the viewport and 
choosing Views>Camera: View # (where # 
represents the number of the Revit Building 
camera). 

 

 

Your Autodesk Revit Building 
model is now ready for 
visualization in 3ds Max! 
 

 

Units 6–8 
Theory: Design Constraints 

Autodesk Revit Building: Levels, Reference Planes, and Grids 
This unit covers the basics of design constraints. You create gridlines, and then use the array tool and look at the constraint tools it offers. You then add walls, 
constraining them to the gridlines. In the second part of this unit, you create a roof by extrusion that is constrained to reference planes. 
 
 
Create Gridlines in a New Project 
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1. From the File menu, choose New>Project.  
 

2. Click the Browse button and navigate to the  
folder that contains Workbook Metric 
Template.rte provided with the data set. 

 
 

 

 

3. In the Project Browser, open Elevations 
South. 

 

Double-click the black triangle of an elevation 
symbol in the project to automatically open 
the corresponding elevation.  

 
4. On the Basics Design Bar, click Level and 

click two points below Level 1. It does not 
matter where you click (use the image as a 
guideline).  
 

 To place a new level you must be in elevation 
view or in a section view. 
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5. On the Basics Design Bar, click Modify and 
select the level you’ve just added. 
 

6. Drag the blue dot on the left until it is aligned 
with the existing ones. 
 

7. Do the same for the blue dot on the right. 

Autodesk Revit Building helps you here: As 
soon as the points are aligned, Revit Building 
displays a green dashed line along these 
points. You then see a blue padlock symbol, 
which indicates that all the points are locked 
together. If you move one, all the others 
follow the move.  

8. With the level still selected, click the text of the 
temporary dimension of this new level. 
Change the value to 600mm. 

 

If you know the absolute elevation of a level, 
you can type it directly by clicking the text 
that is below the level line. 

 
9. Click the squiggle grip to offset the mark from 

Level 1. 

 

 

10. Drag the blue circle grips to adjust the leader 
away from the mark. 

    
 

 

11. Click the name of the new Level (Level 3) and 
change this name to T.O.F. (Top of 
Foundations). Revit Building asks if you want 
to rename the corresponding view. Click Yes. 
 

 

  

Each time you create a level, a view for that 
level is automatically created by Revit 
Building. If you don’t want a view for a level, 
clear Make Plan View on the Options Bar. 
 

 
 
You can choose to rename the level from the 
Project Browser by right-clicking this view 
and choosing Rename from the context-
sensitive menu. 
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Add Grid Lines Gridslines and level line marks behave much the same 
way and have similar controls for the marks. 

 

12. From the Project Browser, open Floor Plans  
Level 1. 
 

13. On the Basics Design Bar, click Grid.  

 

14. Click two points to place the first vertical 
gridline. Pick from bottom to top, or south to 
north. 

 

The direction used to draw the gridline 
defines the side where the bubble is 
attached. 

 
If you draw it in the wrong direction, you can 
use the check box that appears at the end of 
the gridline when the gridline is selected. 

 

 

 
Note: Same applies to level markers. 
 

15. On the Basics Design Bar, click Modify and 
select the gridline in the project. 
 

16. On the Edit toolbar, click Array. 
 

On the Options Bar, set the following: 
a.  Keep Linear. 
b.  Keep Group and Associate selected. 
c.  In the Number box type 5. 
d.  Keep Move to 2nd. 

 
17. Click the gridline, move your cursor to the 

right, and on your keyboard type 6m and press 

 

 
 

 
When you‘ve finished the array, you can 
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Enter. 
 

easily change the number of copies. If 
necessary, click an element in the array to 
display the number of copies. 

Adjust Arrayed Elements Modifying a dimension between arrayed elements will 
modify all arrayed elements. 

 

18. Click Gridline 2, and on the Options Bar, click 
Activate Dimensions.  

 

 

19. Click the dimension that appears, and type 20 
to enter  5.7m for the distance  

The entire grid system adjust to the new
dimension. 

Add Horizontal Grids   

20. On the Basics Design Bar, click Grid. 
 

21. Click two points to place the first horizontal 
gridline from right to left. 

 
22. Press Esc twice. 

 

 

23. Zoom around the bubble of the horizontal 
gridline. 
 

24. Select the gridline. Click the text in the bubble, 
change the value to A, and press Enter. 
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25. Create an array with this gridline. Clear the 
Group and Associate check box. The distance 
between two lines should be 4m and the 
number of copies set to 4. 
 
 

 
 

Arrays in Autodesk Revit Building are 
powerful. You can move one element in the 
array and all the others move accordingly. 
Note, however, that this occurs only if you 
have selected Group and Associate from the 
Options Bar before array creation. 
 

Add a Foundation Wall 
 

 

26. Right-click in the view, and choose View 
Properties from the context-sensitive menu. 
 

27. In the Element Properties dialog box, click 
Edit next to View Range. 

 
28. From the View Depth drop-down list, select 

Level Below. 
 
29. In the View Range dialog box, click OK. 
 
30. In the View Properties dialog box click OK. 
 

 

 

  

The foundation wall is positioned below the 
current level. If you don’t change view depth, 
you cannot see the new wall that you are 
going to add. 
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31. On the Basics Design Bar click Wall. 
32. On the Options Bar: 

a.  Select Basic Wall: Foundation - 300mm 
Concrete. 

b.   Set Depth to Level T.O.F. 
c. Check that alignment is set to Wall 

Centerline. 
d.  Clear Chain. 

 
33. Draw a first wall from intersection between 

lines 1-A and intersection 1-C. Click the lock 
symbol to lock the wall with the gridline. 
 

 
 

 

34. Using the image as a guide, add five walls. All 
of them must be locked with the corresponding 
gridline. 

 
 

If you’ve used the Chain option, you probably 
don’t see the padlock symbol. Use the Align 
tool to lock the relationship between the 
gridline and the wall. 
 

 
35. Right-click in the view, and choose View 

Properties. 
 

36. In the Element Properties dialog box, click 
Edit next to View Range. 

 
37. In the View Depth drop-down list, select 

Associated Level. 
 
38. In the View Range and View Properties 

dialog boxes, click OK. 
 

 

The foundation walls disappear because they 
are not in the view range.  
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39. On the Basics Design Bar, click Wall: 
40. On the Options Bar: 

a. Set type: Basic Wall: Generic- 200mm. 
b. Set Height to Level 2. 
c. Check that alignment is set to Wall 

Centerline. 
d. Clear Chain. 

 
41. Using the image as a guide, add these walls. 

All of them must be locked with the 
corresponding gridline. Lock each wall section 
immediately after drawing it. 

 
 

 

42. Select the gridline 2. With the Move tool, move 
this gridline 300 mm to the right. 

 
 

 
 

The distance between each vertical gridline is 
maintained. Each vertical bay is increased by 
300mm because they are in a group created 
by the Array tool. This constrains their 
movement, so what you do to one bay is 
applied to all bays. 
 
Because the walls are constrained to the 
grids, they move with the gridlines. 

43. Select all the vertical gridlines, and on the 
Options Bar, click Ungroup. 

 
44. Press Esc. 
 
45. Repeat for the horizontal gridlines. 

 

Each gridline can now be moved individually. 
 
Now that you've ungrouped the element, the 
number of elements in the array can no 
longer be changed automatically.  
 
The gridlines adjust as if you had used the 
Copy tool to create the five gridlines. 
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46. On the Basic Design Bar, click the Dimension 
tool.  

47. Click gridline 1 (on the line). 
48. Click gridline 2. 
49. Click in a white area of the screen above grid 

D to place the dimension. 

      

 

50. Select gridline 2 and change the dimension 
value to 2m. 

 
 

The grids are no longer constrained by the
array, but the walls are still constrained to the
gridlines. 

Add Structural Columns to Gridlines Like the foundation walls, structural members are often 
drawn down from the current level to the level below. This 
is a setting like walls on the Options Bar. 

If you do not see the Structural tab on the 
Design Bar, you can add it by right-clicking 
anywhere on the Design Bar and choosing it 
from the context-sensitive menu. 

51. Go to Floor Plans Level 1. 

 

 

52. On the Structural Design Bar, click Structural 
Column. 

53. On the Options Bar, set Level 2 as the height. 
  

 

Structural components are automatically 
locked with gridlines. 
 
Click exactly at the intersection: zoom in if 
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54. Click the intersection between gridline B and 
2. 

 

 

necessary. 
 
You have a choice as to the direction to draw
the columns, up or down (height or depth). 
  
Most of the structural elements, including the
foundation, are drawn extending down. This
includes the foundation wall and the structural
columns.  
 
 

55. On the Options Bar, click Grid Intersection 
and select gridlines B, C, 3, 4. 

 
56. On the Options Bar, click Finish. 
 
57. Press Esc twice. 

 
 

To enable multiselect, press the Ctrl key or 
select by frame. 
 
Click two points that define the frame. The 
direction used to create the frame determines 
selection mode. 
 

 
58. Select the four interior columns. 
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59. With the columns selected, right-click 
Properties. 

60. Verify: 
Base Level = Level 1 
Top Level = Level 2 
Top Offset = 0 

61. Click OK. 
 

 

Create an Extruded Roof  In this section you create two reference planes, 
as well as an extruded roof that is constrained 
to the reference planes. 

62. Go to Floor Plans Level 1. 
 

63. On the Basics Design Bar, select Reference 
Plane. 

 
64. Add a reference plane on the west and east 

sides of the building. 
 
 

 

 
 

Drawing a reference is like drawing a line; 
you simply click two points (start, end). 

65. Press Esc twice. 
 

66. Select the reference plane on the west side. 
 
67. Change the value of the temporary dimension 

to 300mm. 
 
68. Convert the temporary dimension to a 

permanent one and lock it. 
 
69. Perform the same operations for the east side. 

 

To convert a temporary dimension into a 
permanent dimension, simply click the 
symbol below the dimension line. 
 

  
To lock the dimension, select it and click the 
blue lock symbol near the dimension line. 
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70. Select the west side reference plane, and on 
the Options Bar, click Properties. 
 

71. In the Element Properties dialog box, type 
Roof Shape in the Name parameter. 

 
72. Click OK in the Element Properties dialog 

box. 
 

 
 

 
 

  

 
Once you name a reference plane, it displays
that name when selected. 

Add a Roof by Extrusion 
 

In this section, you use the reference plane 
as a work plane to draw an extruded roof. 

73. Open 3D view, and click Work Plane Visibility 
on the Tools toolbar. 

 

The blue grid is the work plane on which you 
are working when you create the sketch. In 
most cases Revit Building automatically 
creates a work plane that enables you to 
sketch. If Revit Building can't find a solution, it 
prompts you to select a suitable work plane. 

74. On the Basics Design Bar, click Roof>Roof 
by Extrusion. 
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75. In the Work Plane dialog box, select Roof 
Shape in the Name drop-down list. 
 

76. Click OK in the Work Plane dialog box. 
 
 

 

As you can see, if you name a reference 
plane, it automatically creates a work plane. 
This is a useful feature. 
 
Work planes can be defined by a face on an 
object (a wall, for example), a reference 
plane, or a line. 
 
Notice that each of the gridlines is 
automatically considered to be a work plane. 

77. In the Roof Reference Level and Offset 
dialog box, click OK to accept Level 2 as a 
reference level for the roof. 

 

 
 

Work plane is aligned with the reference 
plane placed previously. 
 
Click the Work Plane Visibility tool again if it 
has turned off.  
 

 
To sketch the roof, it would be easier to have 
a point of view perpendicular to the work 
plane. 
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78. Press F8 on your keyboard. 
 

79. Expand the Dynamic View dialog box, and 
click Orient to a Plane.  

 
 
 

 

80. In the Select Orientation Plane dialog box 
select Roof Shape in the Name drop-down 
list. 
 

81. Click OK in the Select Orientation Plane 
dialog box. 

 

 

 

82. With the Lines tool selected on the Design 
Bar, click Arc (Passing Through Three 
Points) on the Options Bar. 
 

83. Draw an arc with the image as a guideline. 
 
84. On the Design Bar, click Finish Sketch. 
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85. From the View menu, choose 

Orient>Northwest. 
 

86. Highlight an exterior wall, press Tab on your 
keyboard, and click to select the walls. 

 
87. On the Options Bar, click Attach and select 

the roof. 
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88. Go to Floor Plans Level 2. 
 

89. On the Tools toolbar, click Align. 
 

90. Click the east reference plane. 
 

91. Click the edge of the roof. 
 
 

 
 

 

Create a Strip Footing 

 
 

 

92. Open the 3D view.  
93. Click the Work Plane Visibility tool to turn off the

grid. 
 

 

94. On the Structural Design Bar tab, click
Foundation>Wall. 

 

The Continuous Footing tool adds a spread
footing at the base of a wall. In this case, you
add the continuous footing at the bottom of the
lower of the two walls. 
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95. Click the lower wall to add the continuous
footing to the lower stem walls. 

  

 

 
 

  
 

Now that your model is filled out, explore the
constraints still on the walls and gridlines.  

 



Unit 7 
Theory: Design Information Organization 

Autodesk Revit Building: Components, Groups, Categories, and Subcategories 
This unit has two exercises. The first exercise provides a quick overview of the organizational structure of Autodesk Revit Building design objects.  
The second exercise explores the user-created organizational system of Revit Building groups. 
 

Unit 7, Exercise A 
In this exercise you create and apply a view template to explore the categories and subcategories of object styles that are the basis for object organization and 
structure in Revit Building.  
Create a New View and Apply a View Template 

 
 

1. Open file Unit 7a – start. 
 
2. The file should open with the Floor Plan Level 

2 active.  
 
 
3. The plan view has a view template assigned to 

it (Architectural Plan 1-50). 
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4. In the Project Browser, right-click Floor Plans: 
Level 2 and choose Duplicate with Detailing. 

 

 
Duplicate with Detailing copies the annotation 
elements that are placed in that view. 
 
The new view has dimensions, tags, and other 
annotation copied from the original view. 
 
Although you could use Duplicate rather than 
Duplicate with Detailing here, you are going to 
take care of these elements with a view 
template. 

5. Right-click Floor Plans: Copy of Level 2, and 
choose Rename.  

 
6. Rename this to Level 2 Furniture. 

 
7. Tile the Level and Level 2 Furniture views. 

 

8. Hold the Control key and select both the Level 
2 and Level 2 Furniture views. 
 

9. Right-click and choose Apply View Template. 
 

10. Click OK. 

 

 
Both views have now been updated with the 
new set of visibility parameters stored in the 
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view template. 
11. Right-click the Level 2 view in the project 

browser. 
 

12. Choose Apply View Template. 
 

13. Click the Architectural Plan 1-50. 
 

14. Click OK. 

 

The Level 2 view is returned to its original 
state. 

Edit the Furniture Plan View Template  In this section you edit the view template 
parameters to turn off the furniture and door 
tags. 

15. From the Settings menu, choose View 
Templates. 

16. Set the view template to edit to Funiture Plan 1 -
50. 

17. Under Visibility, click Edit.  

 

 

18. On the Model tab note that Plumbing Fixtures 
is set to By Category. 

 

When a view uses the By Category setting, it 
is looking to the Settings>Object Styles for its 
display parameters. There are no overrides 
set for this view template. 

19. Expand the Furniture category. 

 

These are the subcategories of Furniture. In 
general, subcategories are established by the 
families as you load them into the project. 
You create a new subcategory later in the 
exercise. 
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20. Click the Annotation tab. 
• Clear Door tags. 
• Clear Furniture tags. 
• Verify that Dimensions, Elevations, and 

Sections are cleared. 
21. Click OK two times to return to the drawing 

window. 

 Clearing these elements tells Revit Building 
not to display them when you apply this view 
template. 

22. Set the Level 2 Furniture view current.  
 

23. From the View menu, choose Apply View 
Template and select Furniture Plan 1-50. 
Note how some components disappear while 
others appear. 

 

 

The door tags and furniture tags have been 
turned off for this view only. 
 
You can save visibility settings in View 
Templates and recall them to be assigned at 
any point to any view. The visibility settings 
define what categories and subcategories are 
visible within a view. 
 
To save the active visibility setting that you 
define as a view template, go to menu 
View>Save as View Template. 
 
To apply a view template, go to menu 
View>Apply View Template. 
 
To change View Template settings, go to 
menu Settings>View Templates. 

Change an Object Style Globally The object styles control the linework representation for 
all the objects. Changes you make in this dialog box affect 
all views that do not have an override in place. 

Use Category/Subcategory structure to 
manipluate the settings for the lineweight, line 
pattern, and material for the objects. 

24. From the Settings menu, choose Object 
Styles. 

 

The Object Styles dialog box has three tabs: 
Model Objects, Annotation Objects, and 
Imported Objects. 
 
You can control the appearance of model and 
annotation objects from the first two, while on 
the third tab you can control display settings 
for imported objects such as DWG format files 
(line color, weight, style). 
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25. Scroll down the window to Plumbing Fixtures 
and change color to Red. Click OK. 

 

Because styles are not view specific, 
changing the color of a category affects the 
display of that category in all views. 

26. Open the Level 1 plan view. 
 

27. Verify that the plumbing fixtures have assumed 
the new color settings. 
 

28. Close the Level 1 Plan view.  

 

Create and Assign a Subcategory  Subcategories are primarily used by families as 
a means of providing visibility, lineweight, and 
material assignment control of the 
subcomponent of the family. 

29. Scroll and expand the Furniture category. 

 

 

30. Click the New button, to add a subcategory 
called Bedroom Closet.  

 

 

31. Click OK, and change the subcategory color 
to Orange by clicking the color column. 
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32. Select the furniture item inside the closet in the 
main bedroom (see image). It’s an in-place 
family. On the Options Bar, click Edit. 
 

 

 

33. Select the shelves of the closet (see image), 
right-click, and choose Properties. 

 

 

34. Change the subcategory to Bedroom Closet. 
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35. Select the symbolic lines defining the closet, 
right-click, and choose Properties. Assign the 
subcategory Bedroom Closet. 

 

 

36. Click OK to close window, and on the Design 
Bar, click Finish Family. Note the color 
change of the components. 
 

37. The visibility of the Bedroom Closet 
subcategory can be switched off even if the 
rest of the furniture is visible. Open the 
Visibility settings for this view and expand the 
Furniture category. The Bedroom Closet 
subcategory is now available.  

You can override the color of the category or 
subcategory by opening the visibility settings for 
the view and setting a view override. 
 

 
 
 
 



Autodesk Revit Building Student Workbook  Autodesk 

 118 

 
Unit 7, Exercise B 
The second exercise explores the user-created organizational system of groups.  
 
 
Create a Group   

1. Open the data set Unit 7b – start.rvt. 

 

 

2. Verify that the Floor Plans Level 1 is current.   
3. Zoom into the desk and chair.   
4. Select the wall, shelf, door, window desk, and 

chair. 

               

 



Autodesk Revit Building Student Workbook  Autodesk 

 119 

5. Click Group on the toolbar. 

  

 
The group is created, but is named Group 1. 
It is a good habit to name your groups as you 
create them. 

6. While the group is still selected, on the Options 
Bar, click Properties. 

 

 

7. In the Properties dialog box, click Edit/New. 

 

 

8. In the Type Properties dialog box, click 
Rename. 

  

9. Name the new group Typical Office. 

 

 

10. Click OK until you are back in the drawing 
window. 

 The group has three grips. The middle grip is the 
insertion point of the group. 
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11. Drag the insertion grip to the lower-left corner 
of the space. 

                

 

Array the Office Group   

12. With the group still selected, click the Array 
tool, and on the Options Bar set: 

a. Array type = linear  
b. Clear Group and Associate 
c. Number = 6 
d. Move to 2nd 
e. Constrain = selected 

 
 

 
 

 

13. Click anywhere in the drawing window for the 
first point of the array. 

  
 

14. Drag to the right.   
15. Type 3m and press the Enter key. 

  
 

 
The array is created. You cleared Group and 
Associate because the office parts are already in 
a group. 
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Modify Groups  You can modify, add, or subtract from the 
objects in the group. 

16. Click any of the groups. 

 

The group is open for editing. Those objects not 
in the group are dimmed and not accessible. 

17. On the Options Bar, click the Edit Group tool. 

 

 

18. Redesign the office: 
• Move the desk, chair, and lamp toward 

the window.  
• Move the door against the right wall.  
• Rotate the shelf. 

 

When you are editing the group, you can move 
the group components around, but you cannot 
add new components directly. 

 
The Design Bar lets you operate only on the 
objects already in the group. 

19. On the Design Bar, click the Finish Group 
tool.  

 
The change is propagated through each of the 
offices. Even objects such as doors and 
windows that have relationships to the other 
elements can belong to and be modified by 
groups. 

Add Components to a Group  To add components to a group, they must first 
exist in the project. 
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20. Use the Component tool to add an M_ Chair-
Corbu to the left office. 

  

 

21. Click any of the groups. 
 
22. On the Options Bar, click Edit Group. 

  

23. Click the Add to Group tool. 

 

 

24. Click the chair you added. 

 

 

25. On the Design Bar, click the Finish Group tool.
 

 
The chair is added to each of the offices. 

Duplicate the Group  Once a group is defined in the project, it acts 
much like any other Revit Building object. You 
can create types based on the original. 

26. Click the left office group.   
27. On the Options Bar, click Properties. 
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28. Click the Edit/New button. 

 

 

29. Click the Duplicate button. 

 

 

30. Name the new group Vice President Office. 

 

 

31. Click OK to return to the drawing window. 

 

The group selected when you accessed the 
properties takes on the new group definition. 

Modify the New Group   

32. Select the Vice President Office groups. 

 

 

33. On the Options Bar, click the Edit Group tool. 
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34. Copy the M_Chair – Corbu and remove the 
shelf to make room for it. 

  

35. Change the desk type to M_Desk 1830 x 
915mm. Move it into place. 

 

 

36. Change the chair type to Executive. 

 

 

37. On the Design Bar, click the Finish Group 
tool. 

 

Changes to the Vice President Office group do 
not affect the other groups in the project 
because they are of a different type. 

Apply Group Type to Another Group   

38. Click the group on the far right. 

 

 

39. Change the group type on the Options Bar to 
Vice President Office. 
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40. Save and close the project. 

 
Groups can be powerful tools for working with sets of 
objects within the Revit Building environment. 

On your own, further explore the use of groups. Create an
entry for the building. Can you create groups that you can
swap out for one another, showing different solutions to
the entry design? 

You can insert groups using the Design 
Bar>Modeling tab>Model Group tool.  
You can export groups and load groups using 
the File menu: Save to Library and Load from 
Library. These files are stored as RVG files 
outside the project (RVT) environment. 



Unit 8 
Theory: Domain-Specific Knowledge 

Autodesk Revit Building: Roofs 
 
This exercise takes you through adding some more detail to the roof in addition to taking a look at how to put together multiple roofs to achieve different forms. 
 
 
 
Exercise Setup 
 

  

1. Open the data set Unit 8 - start.rvt. 

  

This data set is the same as the building at the 
end of exercise 7b. The southwest corner has 
been added and a new level called Upper Roof 
has been created.  

2. Clip the Extruded Roof. 

 

Any extruded roof (as opposed to a roof by footprint) can
be cut using the Cut Plan Profile tool. 
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3. Set the Upper Roof Plan view current. 

4. Click the roof in the plan. 

5. On the Options Bar, click the Cut Plan Profile 
tool.  

This process initiates sketch mode. Just draw 
the shape you want to remove from the extruded 
roof. This must be a closed shape. 

6. Draw a shape that follows the outer edge of the
upper walls. 

 

Notice the linework on the south and west sides 
is outside the roof. Try not to make the lines 
coincident with the edge of the roof.  
 

7. On the Design Bar, click the Finish Sketch 
button.  

 

The shape that was sketched is now removed 
from the extruded roof. 

Roof by Footprint: Pick Walls Versus Lines with
Offsets 
 

Here you create an upper roof on the entry walls. An
earlier unit illustrates Roof by Footprint, and here we
discuss some of the limitations and workarounds using the
roof you create in this section as a basis for a slightly more
complex (to Revit Builidng) roof. 
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8. Set the Upper Roof view current 

9. Click the Roof>Roof by Footprint tool. 

 

10. On the Sketch Design Bar, click Pick Walls.  

 

 

11. On the Options Bar, set: 

a. Defines Slope = selected 
b. Overhang = 600 
c. Extend to Wall Core = selected 

12. Click the two east walls to create the lines as 
shown at right. 

 

 

13. On the Sketch Design Bar, click Lines.  

 

 

14. On the Options Bar, set: 

a. Draw method = Pick Lines 
b. Defines Slope = selected 
c. Offset = 600 

15. Draw the two lines on the west side shown in 
the image. 
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16. Use the Trim tool to clean up the corners of the 
linework. 

 

 

17. On the Sketch Design Bar, click Roof 
Properties.  

18. Set the slope angle = 30.000°. 

19. Click OK to return to the drawing window. 
 

 

20. On the Sketch Design Bar, click Finish Roof. 

 

The roof is created, but not symmetrical to the 
entry walls. This is because of the differences in 
the lines created by picking walls versus using 
the Lines tool. 

21. Add a section as shown here. 

 

 

22. Open the Section view and tile the two views; 
Section 1 and Upper Roof.  

The sketch lines drawn with the Lines tool 
originate at the edge of the roof at the level the 
roof is constrained to (left side of image).
 
The sketch lines drawn with the Pick Walls tool 
establish the facia edge of the roof below the 
level by a distance determined by the slope of 
the roof over the overhang setting.  
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Notice also that the Pick Walls tool had Extend 
to Core selected. The outside face of the core 
(the metal studs) of the wall is used and the 
overhang of 600 is calculated from this point 
rather than the exterior face of the entire wall. 
As such, the overhang on the “Picked Walls” is 
slightly less than the overhang of the drawn line 
segments 

Align Eaves 
 

Align Eaves is a tool in the sketch mode of a footprint type
roof. 

 

23. Set the Upper Roof view current.  
 

24. Click the roof.  
 

25. On the Options Bar, click the Edit button.   
 

26. Click each of the lines and use the temporary 
dimensions to adjust the distance to the face of 
the wall to 600. 

    

 

27. On the Sketch Design Bar, click the Align 
Eaves tool.   

 

28. Click the eave to align to (the southeast line). 
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29. Click the eave to align (the southwest line).  

30. Repeat for the northern lines. All the sketch 
lines should now be set to the same value.  

 

31. On the Sketch Design Bar, click Finish Roof.  The roof should now be symmetrical to the underlying
entry walls. 

 

Create Multiple Roofs 
 

Sometimes you need to create two or more roofs to
complete the shape you are looking for. Any roof with a
discontinuity in the form probably needs to be created
from two different roof objects. This section guides you
though creating a simple example of such a roof, as
shown at the right. 

 

32. Open the roof sketch for editing. 

a. Set the Upper Roof view current. 
b. Click the roof. 
c. On the Options Bar, click the Edit button. 

 

 

33. On the Sketch Design Bar, click Roof 
Properties.  

34. Click OK to return to the drawing window. 
 

 

35. Delete the southwest line.  
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36. On the Sketch Design Bar, click Lines, and on 
the Options Bar set: 

a. Draw method = Draw 
b. Defines slope = Cleared 
c. Offset = 0 

37. Draw the three lines on the west side shown in 
the image. Verify that these lines do not define 
slope.  

 

 

38. On the Sketch Design Bar, click Finish Roof.  

 

 

39. If you want, you can extend the wall to the roof: 

a. Open a 3D view. 
b. Click the southwest wall. 
c. On the Options Bar, click Top/Base Attach. 
d. Click the roof to attach to.  

 

Add the second roof to complete the form. 
 

 

40. Set the Upper Roof view current. 

41. Click the Roof>Roof by Footprint tool. 

42. Use the Lines tool to draw the lines shown at 
the right. 

 

Note only the outermost line defines a slope. 
The other three do not. 

43. On the Sketch Design Bar, click Finish Roof.  

 

The roof is finished, but like the first roof in the 
exercise the linework is based at the upper roof 
level rather than the eave of the existing roof. 
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44. Open the section view and use the Move tool 
and snaps to move the roof into place using 
the roof beyond as the reference. 

   

 

Create Fascias and Gutters 
 

Revit Building provides the ability to sweep a shape
around the edge of a roof. This can be any shape stored in
a roof sweep type of profile family. The odd thing about
many of the sweeps is that although the shape definition is
stored in a family (RFA file) the definition is buried (or
nested) in a system family definition in the project file. 

 

45. Open the 3D view of the project.  
 

46. Click the Modeling tab of the Design  
Bar, and then click the Host Sweep>Roof 
Fascia tool. 

 

47. There is only one type defined in this project. 

 

Note the fascia is a system family (defined only
in the project, not as an RFA file). There are
other families you can load and use in the
project but you would need to duplicate this type
and assign the loaded profile into the type
parameters of the new type. 
 

48. Click the upper edge of the fascia area of a 
roof. 

 
 

49. Continue clicking edges to add the fascia to  
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each edge of the roof.  

50. Click the Modeling tab of the Design  
Bar, and then click the Host Sweep>Roof 
Gutter. 

 

 

51. Click the fascia edge about the entry door. 

 

Be careful as you select. Because the inside 
face of the fascia, the roof and the outside face 
of the fascia are all very close together, it is 
easy to add the gutter to wrong edge. 

Create Soffits 
 

Creating a soffit in Revit Building is much like creating a
roof. 

 

52. Set the Upper Roof level current.  
 

53. Click Roof>Roof Soffit.  
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54. Draw two sets of lines as shown in the 
illustration. 

 

Although there are automatic selection tools that 
allow you to select roofs and walls, because this 
is not just a single roof, you may find it easier to 
draw the lines manually. 

55. On the Sketch Design Bar, click the Roof 
Soffit Properties and set the Height Offset 
From Level to  -300.0. 

 

 

56. On the Sketch Design Bar, click Finish 
Sketch. 

  

57. Click the Join Geometry tool. 

58. Click the soffit, and then click the roof. 

 

The two geometries are joined and the profile 
line wraps both objects. 
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Unit 9 
Theory: Delaying Specificity 

Autodesk Revit Building: Massing 
There are two exercises in this unit. This first exercise guides you through the process of adding mass elements to a Revit Building project. The second illustrates 
the software’s ability to import SketchUp files and how to use them as mass elements. 

Unit 9, Exercise A: Mass Components and Building Maker 
In this exercise you work with Autodesk Revit Building software’s Building Maker. Building Maker is a collection of tools that includes 
• Mass elements composed of solid forms and void forms 
• Walls, floors, roofs, and curtain systems associated with the mass faces 
 
The general workflow in this exercise is to create the mass forms, apply the building elements to the faces, modify the forms, and then update the building 
elements to the new geometry of the changed form. 
 
 
Create a Mass Element   

1. Open file: Unit 9a – Start.rvt.  
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2. In site view, right-click the Design Bar and
choose Massing from the context-sensitive 
menu to show the Massing Design Bar if it is 
not already visible. 

 

Design Bars can be displayed or hidden to 
optimize screen space. 

Add a Mass   
3. On the Massing Design Bar, click Create 

Mass. 
 
 
  

Both Additive (Add Mass) and Subtractive 
(Cut Mass) Masses are created in sketch 
mode.  

4. Click OK in the Show Massing dialog box if it 
appears. 

  

5. Give the massing a name. 

 

 

6. The Massing dialog box appears. Click Solid 
Form>Solid Extrusion. 

 

Forms can be created in four standard ways, 
(extrusion, blend, revolve, sweep) and can be 
either solid or void. Voids are subtractive forms 
that cut geometry from solid forms. 

7. On the Options Bar: 
a. Enter 25m.  
b. Click the pick lines (the pencil 
symbol).  

 

Sketch lines can be drawn or selected. When 
selecting, it’s possible to automatically lock the 
lines to the original drawing by clicking the Lock 
option on the Options Bar. 

8. Zoom in the upper-right city block and highlight
one of the lines that defines the building
footprint. 
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9. Press Tab to chain-select all the lines. 

 

Like selecting a chain of walls, you can click 
connected lines to generate sketch lines by 
using the Tab key. 

10. Click Finish Sketch to complete the mass. 

 

Quit Sketch discards the lines that were 
drawn in sketch mode. 
 

11. Repeat steps 6–10 to create a mass for the 
small building on the same block. 

  

12. Click Finish Mass to complete the mass. 

 

This is a nested series of sketch modes. One 
mode takes you to the mass creation set of 
Design Bar options. When you start a solid or 
void, you drop down one more level and the 
Design Bar changes to a more familiar sketch 
mode. You must click Finish Sketch and 
Finish Mass to complete the command. 

13. Change to the 3D view. 

 

You have drawn two shapes in the mass 
element sketch mode. These will be two parts 
on a singular mass element when selected. 

14. Return to the site view and repeat the process 
with all the building footprints in the blocks. 
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15. Set the mass heights as shown in the image on 
the right. Note: Because some masses have 
two loops of lines, as in the building in the 
upper left, use Tab to select both of the closed-
line loops. 
Name the Building in the southwest corner 
Building 3. You work with this building later in 
the exercise. 

 

Change heights (or depths) after creating the 
masses by selecting the mass, opening its 
Properties dialog box, and changing the value 
in the Beginning and End fields. 
 
 
 
 
Note that for some of the buildings, you may 
have to complete the sketch by drawing lines 
instead of just selecting them. 
 
Create the building at the lower right as two 
different solids within one mass element. 
Don’t try to make it two parts of the same 
solid extrusion. 

16. Open the 3D view. Type SD for a shaded view
of the massing. 

 

 

17. Select the southwest mass and resize it by 
dragging the blue grips that appear (there is 
one grip for each face). 

 

Edit masses directly in any view by dragging the 
grips. 

25 m 25m 

12 m 

36 m 

28 m 
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Edit the Southwest Mass to Add a Void The process of adding a void—or subtractive solid—is the
same as creating the original solid. 

 

18. With the southwest mass selected, click Edit 
on the Design Bar. 

 

19. Click Void Form>Void Extrusion. 

 

 

20. On the Sketch Design Bar, click Set Work 
Plane.  

 

Setting a work plane allows automatic change 
of the coordinate system in a simple way. 

21. The Work Plane dialog box appears. Select 
Pick a Plane. 

 

Select any face, reference plane, or gridline as 
an active work plane. In the name drop-down 
are named reference planes, levels, and 
gridlines. 

22. Click the vertical face of the mass located on 
the lower-left block. 

 

In this case, you are selecting a vertical face 
directly in the 3D view. 

 
23. On the Design Bar, click the Work Plane 

Visibility button to see the active work plane. 
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24. Select the Lines tool and draw a rectangle- 
based sketch. Autodesk Revit Building has 
automatically changed the relative coordinate 
system to vertical. 

 

Switch to an elevation view, or create a section 
if you prefer not to draw in axonometric view. 

25. On the Options Bar, set the depth of the mass 
to 20m. 

 

In this case, the depth refers to the horizontal 
plane, as you are drawing on a vertical plane. 

26. Click Finish Sketch. 

 

 

27. Drag the shape handle of the void until it snaps 
to parallel geometry to make void cut 
completely through the solid. 

     

  
 

The void appears as an orange shape. 

 
You do not need to be exact with the void. Once 
you are done with mass sketch mode, the void 
disappears. 

28. Click Finish Mass to complete the mass. 
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29. Select the southwest massing (the one you 
have been working with). 

 

 

30. On the Options Bar, click the Floor Area 
Faces button. 

 

 

31. Select the check boxes for all the levels. 

 

Each level that intersects the massing is a 
candidate for a floor area face. These faces 
enable you to place floors and do quantity 
takeoffs from the massing object. Planes are 
drawn at each level.  

 
Already at this phase you can get feedback 
from the building information model such as the 
total floor area of the floor faces in the design. 
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Make a Gross Floor Area Schedule Revit Building provides the ability to get information from 
the rough mass model, enabling you to dynamically see 
changes in either the graphical form of the mass, or in the 
tabular form of a schedule. 

For the schedule to work, the floor areas must 
first be assigned to the mass object. 

32. From the View menu, choose the 
Schedule/Quantities tool. 

  

33. Select the Mass category. 

 

 

34. Click OK.   
35. Add fields: 

• Family and Type 
• Gross Floor Area 
• Gross Volume 
• Description 

  

36. Click OK.   
37. Add a description to Building 3—Office Building 

and click OK at the type change prompt. 

 

A gross building volume and floor area schedule 
can be generated and placed in a sheet. 
 
Only the building for which you created the floor 
areas shows a value in the Gross Floor Area 
column of the schedule. 
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Add the Physical Floor Component The floor areas created previously are simple vertical 
divisions of the mass that have no thickness. Use the 
Floor  by Face tool to add floors into the mass. 

You cannot use the Floor by Face tool until 
you have the floor faces created. 

38. Isolate the southwest building. 
• Open the 3D view. 
• While pressing the Ctrl key, click each of 

the three building masses without floor 
assignments. 

• From the drawing window’s View toolbar, 
click Hide Object. 

 

Use Hide Object/Isolate Object to work on one 
object in the project. 

39. Use the View menu to orient the view to the 
southwest. 

 

 

40. Change the height of the lower wing to just 
under one of the floor area faces. 
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Add Floors to the Building  Now that you have created the mass of the 
building, you can start adding the building 
elements. 

41. On the Massing tab of the Design Bar, select 
Floor by Face. 

  

 

42. On the Options Bar: 
• Set floor type to Insitu Concrete 225mm. 
• Verify that Select Multiple is selected.  

 

43. Drag a window around the whole building. 

 

 

44. On the Options Bar, click the Create Floors 
button. 

 

The floors are automatically generated. 

45. On the Massing tab of the Design Bar, click the 
Walls by Face tool. 
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46. On the Options Bar, set: 
• Wall Type = Exterior Brick on Mtl. Stud 
• Draw Type = Pick Face (House Icon) 
• Height = Automatic 
• Loc Line = Core Face Exterior  

 

 
 

 

47. Click the walls shown at right. 

 

Spin the model to select these faces. Hold 
down the scroll wheel and move the cursor to 
spin the model. 

48. Click the Show Mass tool. 

 

This tool enables you to move back and forth 
between seeing the massing and the floors and 
walls or just the floors and walls. 

49. Click the Show Mass tool to show the mass 
again. 

  

Adjust the Building Envelope (Massing)   

50. Click the Modify tool.   
51. Select the mass.   
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52. Use the triangular face grips to modify the 
lower wing (see illustrations at right): 

• Top face down one level  
• South face half the distance to the street 

     

If stray portions of the mass show up as you 
grip the mass faces, use the Edit button to 
access sketch mode and adjust the void 
extrusion to clean up. 

53. Click any white area to deselect the building.  The building elements are now out of sync with 
the mass model. 

Update the Walls and Floors   

54. Select the floor exposed by dropping the top 
face. 

  

55. On the Options Bar, click the Remake button. 

 

 

56. Repeat, selecting the south wall of the lower 
wing. 

  

57. Repeat for the lower three floors. 

 

 

Add Curtain Wall System   
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58. On the Massing tab of the Design Bar, click the 
Curtain System by Face tool. 

 

 

59. Verify that the curtain system is set to 1500 x 
3000mm.  

 

60. Select the remaining exterior faces.   
61. On the Options Bar, click the Create System 

tool. 
  

Adjust Curtain Wall System   

62. In the Project Browser, expand Families> 
Curtain Systems>Curtain System. 

  

63. Right-click the 1500 x 3000mm type, and 
choose Properties. 

 

 

64. In the Type Parameters set the Layout (Grid 1) 
(vertical spacing of the horizontal grid) to Fixed 
Distance and 1000.
 

      Set the Layout (Grid 2) to Fixed Distance and   
2000. 

 

Because you are editing the type, the changes 
you make apply to all curtain systems in the 
project. 

65. Click Rename and enter 2000 x 1000mm for 
the name. 

 

 

66. Click OK two times to return to the drawing 
window. 
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67. From the Modeling tab on the Design Bar, click 
the Mullion tool, and on the Options Bar click 
All Empty Segments. 

 

 

68. Click a curtain system face of the model.   
69. Repeat for the remaining curtain system faces. 

 

 

Add Roof  The process of adding a roof is the same as 
that for adding walls or floors.  

70. On the Massing tab of the Design Bar, click the 
Roof by Face tool. 

  

71. On the Options Bar, set: 

• Roof type = Steel Bar Joist – Steel Deck –
EPDM Membrane 

• Level = 9 

 

 

72. Select the top face.   
73. On the Options Bar, click the Create Roof tool.   
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74. Repeat, adding a roof at level 3 for the lower 
wing. 

 

 

75. On the drawing window view toolbar, click the 
Isolate tool and select Reset Temporary 
Hide/Isolate. 

 

Note that if you come back to this project later, 
you may have to click the Show Mass tool to 
see the mass elements. Show Mass is not 
turned on by default in a new session. 

 
 

Unit 9, Exercise B: Importing SketchUp Files 
In this exercise you import a SketchUp file directly into the project as well as import a SketchUp file into a mass family as it is created. 
 
 
Exercise Setup   

1. Open file: Unit 9b – Start.rvt.   
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2. Set the view 3D Views>North East Iso 
current. 

3. Click the Show Mass tool on the toolbar. 

 

 

Import a SketchUp Model   

4. From the File menu, choose Import 
Link>CAD Formats. 

 

 

5. In the Import/Link dialog box, set: 

a. Files of Type = SketchUp 
b. File Name = Unit 9b – NW building.SKP 
c. Select Link (Instead of Import) 
d. Click Preserve Colors 
e. Click Origin to Origin 
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6. Click Open 

 

The SketchUp model is read into the Revit Building 
project.  

Import a SketchUp Model into an In-Place Mass 
Family 

While the SketchUp model is displayed in the Revit
Building project, it acts as a solid block. If you want more
flexibility with the SketchUp model, you can import it into
an in-place mass or a Revit mass family (RFA). 

Once the SketchUp file is nested inside a mass, 
you can use the Building Maker features as 
explained in Unit 9, Exercise A. 

7. Click the Create Mass tool to start the In-
Place Mass routine. 

 

 

8. Name the new mass Building 5.   

9. Repeat the steps in the first part of this 
exercise to import a SketchUp model. Import 
the SketchUp file: Unit 9b – NE 
building.skp. 

 

10. On the Design Bar, click the Finish Mass 
button.  
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11. Apply walls, floors, and roof of your 
choosing. 

 

If you need assistance with this process, review the 
previous exercise for step-by-step instructions on 
applying walls, floors, and roofs to faces of the 
mass (Building Maker functions). 

Turn off the SketchUp Model As with any other imported file, you have control over the
visibility of the graphics of the linked file. 

 

12. Type VV to access the views graphic 
overrides. 

  

13. Clear the Imports in Families check box.  

 

 

 



 
 
 



Unit 10 
Theory: Component Design 

Autodesk Revit Building: Family Editor 
This workbook unit is to be used with Lecture Units 10 and 11. Unit 10 builds a shelf unit as a furniture family using solids.  This shelf is the basis for the multiple 
exercises in Unit 11.  This exercise is long, so give yourself enough time to finish it, or save it in a location that you have access to later. 
 
This exercises uses dimensions and align tools extensively. You should be familiar with these tools before you start this exercise. 

 
Exercise 10: Creating a Component Family 
In this unit you create a furniture family, as 
shown in the image. 

 

 

1. From the File menu, choose New>Family. 
 

2. In the dialog box, open the template called 
Metric Furniture.rft.  

 

 

 
 

The Family Editor opens: note that the work 
environment is similar to the project mode. 
The Design Bar provides just one Family Bar. 
The usual bars are not available (Site, 
Modeling, Structural, and so forth) because 
they are not used for family creation. The 
Project Browser does not differ much: there 
are plan views, elevations (which are named 
differently), and the 3D views. In the menus, 
some tools are not accessible (dimmed). 

3. Save this file: 
• From the File menu, choose Save As.  
• Browse to the data set folder that contains

the workbook exercise files. 

 

Note: The completed RFA files for Units 10 
and 11 are in the Completed rfa folder here. 
The other shelf units in this folder are starting 
points for Unit 11 exercises. 
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• Open the RFA folder in this location. 
• Save this file as Unit 10 Shelf Unit. 

Create Overall Reference Planes  When you are working with families, you are creating 
reference planes. These reference planes are assigned 
the parameters that drive the geometry. 

 

4. In the Project Browser, open Floor Plans>Ref 
Level. 

 
5. Right-click the horizontal reference plane and 

choose Properties. 
 

 

 

 
 
 
 

In this view there are two reference planes. 
The intersection of these two planes 
represents the insertion point of the family. In 
this case, this point is the rear (back) and the 
middle of the piece of furniture. Begin by 
changing the name of this reference plane. 

6. In the Properties dialog box, change the name 
to Back and verify that Is Reference: Back is 
selected. Click OK to exit. 

 

 
 

Reference planes are important in the 
creation of families. It is on these lines that 
you base the parameters of your family; 
they are references for the geometry. 
Adding reference planes is easy. Simply 
specify a starting point and a final point (just 
like drawing a line). The length of the line 
symbol is not important. If necessary, you 
can resize it using the grips that appear at 
its ends when it is selected. 
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7. Click the reference plane button on the Design 
Bar and add three planes, as shown in image 
(don’t worry about the distances between each 
plane). 

 

You must be able to vary the width and 
depth of your piece of furniture, so you add 
two new parameters to your family. To 
create a parameter you must add a 
dimension and assign it a label. The depth 
of the furniture family corresponds to the 
distance between the two horizontal 
reference planes; the width corresponds to 
the distance between the two vertical 
reference planes (right and left). 

8. On the Design Bar, click the Dimension 
button, and add a dimension line between the 
two horizontal reference planes. 

 

 

9. On the Design Bar, click the Modify button 
and select the dimension. On the Options Bar, 
from the Label list select Add Parameter. 

 

You can also right-click the dimension line 
and choose Edit Label from the context-
sensitive menu. 
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10. In the Properties dialog box for the 
parameter, enter Depth as the name. The 
options suggested by default are that this is a 
Type parameter.  

 
11. Set the Group Parameter Under to 

Dimensions. 
 
12. Click OK.  

 
 

The Group Parameter Under setting is an 
organizational structure for the parameters. 

 
A dimension that is associated with a label 
(parameter) displays the parameter name in 
the dimension string. 

13. On the Design Bar, click the Dimension 
button and add a dimension between the 
three vertical reference planes (click each 
line and position the dimension line with a left 
mouse-click). 

 
14. Click the EQ symbol that appears. 

 
 

The vertical reference plane between the 
two other planes is the axis of the furniture. 
Thus, it must be equidistant between the 
planes on the right and left. To achieve this 
and keep it as a constant during the design, 
you need to add a dimension between the 
three reference planes and activate the 
equality constraint (symbol EQ). 

15. Repeat the earlier steps to add the width 
parameter. 
• Add a dimension (between two outside 

vertical reference planes). 
 

• Click dimension, and then click Add 
Label on the Options Bar. 

 
Set the label:  

Name = Width  
Group = Dimensions 
Type parameter 
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16. On the Design Bar, click the Family Types 
button, change the Depth and Width values, 
and then click Apply.  

 
17. Click OK. 

 
 

During family design, it is important to test 
the parameters to check that all is working 
properly. You have just added two 
parameters in your family. You can test 
them by changing some of their values. 
During this test, reposition the reference 
planes. You should not receive any error 
message. 
 
This is called flexing the family parameters. 

18. In the Project Browser, click Front view. 
 
19. Add a horizontal reference plane, add a 

dimension between the reference plane on 
the ground and the one you have just added, 
and transform this dimension into a 
parameter named Height (also a type 
parameter in the Dimension group). 

 
 

20. Flex the family by changing parameter 
values in the Family Types dialog box. 

 
21. Save your project.  

 
 

Remember to save your work regularly. You 
can decide to create a new tree structure of 
files under the main Library folder. It’s a 
good idea to keep your personal libraries 
separate from the installed library. 

Create Side Supports  Now that the reference planes are in place the side 
supports are created with the solid extrusion tool. 

 

22. Activate the view Ref. Level.   

23. On the Design Bar, click the Solid tool, and 
choose Solid Extrusion from the flyout. 

 Sketch mode is used for creating forms. 
The Design Bar displays the tools available 
to create the sketch, which must be a 
closed loop. 
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24. On the Design Bar, click the Lines button. 

 
 

 

25. On the Options Bar, click Rectangle. 

 

 

26. Trace two rectangles, as in the image (the size 
is not important). 

 

 

27. Use the Align tool to lock the left sketch line to 
the left reference plane, as in the image. 
• Click Align tool. 
• Click left reference plane. 
• Click left line of the left rectangle sketch 

line. 
• Lock this alignment by closing the lock 

symbol that appears (click the symbol). 

 

 

28. Repeat the process for the right rectangle, 
locking the right edge to the right plane. 
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29. Use the Align tool to lock the top left sketch 
line to the top reference plane, as in the 
image. 
• Click Align tool. 
• Click top reference plane.  
• Click top line of the left rectangle sketch 

line. 
• Lock this alignment by clicking the lock 

symbol. 

 
 

 

30. Repeat the process for the right rectangle top 
sketch line. 

 

 

31. Repeat this process for the bottom sketch 
lines, locking them to the lower reference 
plane.  

 
 

 
 
 

 
 

 

The sketch lines shown here should now be 
aligned/locked with their respective reference 
planes. 

  

 
 

When you dimension a sketch like this, you 
want to run the dimension to the reference 
plane rather than the sketch line.  
 
This allows the sketch to flex as you use the 
dimensioned label parameters to drive the 
reference plane geometry. 

32. Click the Modify tool. 
 
33. Select the sketch line on the right side of the 
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rectangle you just dimensioned. 
 

34. Click the dimension text and change the 
value to 19mm. 

 
35. Lock the dimension by clicking the lock 

symbol. 

 
 

36. Repeat the process for the sketch on the right 
side. 

 
37. Click Finish Sketch. 
 
38. Save the family. 

 

 

39. In the Project Browser, select Front view. 
 
40. Select the 3D geometry. Blue grips that can be 

used for dragging the faces appear. 
 
41. Drag the grip that allows changing of the 

height of the solid element until you reach the 
top reference plane. 

 
42. Click the lock symbol to lock the alignment. 

   
 

You can also use the Align tool to 
accomplish this task. 

 
Because you drew two rectangles in the 
sketch mode, you have only one vertical 
grip that controls the height of both side 
frames. 
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43. The vertical sides are finished. Test your work 
by varying the parameters of the family (width, 
height, depth) in the Family Types window 
(flexing the model). The 3D geometry must 
update consequently and no error message 
should appear. To see the effect of the 
parameters well, open a 3D view. 
 

 
Create Reference Planes for the Shelves   

44. Open view Ref. Level in the Project Browser. 
 
45. Add a horizontal reference plane just above 

the one that defines the depth of the furniture 
family. 

 

 

46. Add a new dimension line between the bottom 
reference plane and the one you just created. 

 
47. Select the reference plane and change the 

dimension text to 15mm. 
 
48. Lock the dimension. 
 

 

 

49. Open the front view. 
 
50. Add two horizontal reference planes, as 

shown in the image. 
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51. Add the two dimension lines, as shown in the 
image. 
 

52. Set the top dimension value to 34mm and the 
bottom one to 50mm. 

 
53. Lock the dimension lines. 
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54. Add four more reference planes, as shown in 
the image. 

 

 

55. Click Dimension and then click the four 
reference planes, as well as the two created in 
the previous step. 

 
56. Click the EQ symbol. 
 
57. Flex the model by changing parameter 

values. 
 
58. Save the file. 

 

 
 

A few words to explain these reference 
planes: two of them cannot move. They are 
constrained by locked dimensions (50 and 
34). The other four are spaced regularly 
because of the dimension line that 
constrains the distance between them. 
Thus, if the height of a piece of furniture is 
modified, the top and bottom parts are 
fixed, whereas the distance between the 
four other planes is adjusted to satisfy the 
equality constraint. 

Add Base Trim   

59. Open view Ref. Level. 
 
60. On the Design Bar, click Solid Form>Solid 

Extrusion.  
 
61. On the Design Bar, click Lines, and then on 

the Options Bar, click the rectangle template.  
 
62. Draw a rectangle, as shown in image. The 

size is not important. 
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63. Click the Align button on the toolbar. 
 
64. Click the internal face of the upright and then 

click the nearest line of the rectangle. 
 
65. Lock this alignment by clicking the lock symbol 

to close it.  

 
66. Repeat the process on the right side. Don’t 

forget to lock the alignment. 
 

 
 

 

67. With the Align tool, click the horizontal 
reference plane on the bottom and then click 
the nearest horizontal line of the sketch. 

 
68. Lock this alignment by clicking the lock symbol 

to close it. 
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69. Add a dimension between the reference plane 
immediately above the one that defines the 
depth and then on the line that you did not 
lock. 

 
70. Select the line, and in the dimension text 

change the value to 19mm.  
 
 
71. Select the dimension and lock it. 
 
72. Click Finish Sketch. 

 

 

 
Notice when you finish the sketch that the 
dimension disappears.  

 
It is still there when you edit the sketch. This 
is a useful way to keep your families free from 
extra dimension clutter but can make it difficult 
to track when a family gives you 
overconstrained errors. 

73. Open the front view. 
 
74. Click Align. 
 
75. Click the reference plane that is directly below 

the top of the solid you just created, and then 
click the top of the solid. Lock the alignment by 
clicking the lock symbol. 

 

 
76. Flex the model. 
 
77. Save the family. 
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Add Shelves   

78. Open Ref Level.   

79. Right-click the lowest horizontal reference 
plane, and choose Properties. 

  

80. Rename the reference plane to Front of 
Case. 

 

 

81. Repeat and rename the second reference 
plane Shelf Front. 

 

We refer to these reference planes now by 
these names. 

82. Open the front view. 
 
83. On the Design Bar, click Solid Form>Solid 

Extrusion.  
 
 
84. On the Design Bar, click Lines, and then on 

the Options Bar, click the rectangle 
template.  

 
85. Draw six rectangles, as shown in image. The 

size is not important. 
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86. Click the Align tool, and on the Options Bar, 
click Multiple Alignment.  

 
87. Click the interior face of the left upright and 

then click the left vertical lines of the 
rectangles (one at a time).  

 
 
88. Lock each alignment (you must lock each line 

individually after aligning it). 

 
89. Repeat the process for the lines on the right 

side. Remember to lock the alignments. 

 

These alignments allow the horizontal racks 
to remain in contact with the vertical 
uprights if the furniture family’s width is 
resized. You should now force the 
horizontal lines of the rectangles; the lines 
of the bottom of the rectangles must be 
respectively aligned with the reference 
planes that are subjected to the equality 
constraint.  
 
Then you need to place a dimension 
between each reference plane and the top 
line of the rectangles: one adjusts 
dimension and one locks the dimension. 
Thus, if the height of the furniture changes, 
the racks cannot vary in thickness. Thanks 
to the equality constraint, they reposition 
themselves correctly to divide the obtained 
space. 
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90. Click the Align tool, and on the Options Bar, 
clear the Multiple Alignment option. 

 
91. Click the reference plane right above ground 

level and then on the bottom horizontal line 
of the lowest rectangle. Lock the alignment. 

 
92. Repeat the alignment process with the 

horizontal reference planes and the bottom 
lines of the rectangles, as shown in image. 
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93. Add a dimension line between the reference 
plane and the top line of the rectangle 
located on the bottom, as shown in image. 

 
94. Select the line and change the dimension 

text to 19mm. 
 
95. Lock the dimension. 
  

 

96. Repeat the process for all horizontal lines 
(located on the top of the rectangles). 
Remember to lock the dimensions. 

 
97. Click Finish Sketch. 

 

 

98. Open Ref. Level. 
 
99. Select the 3D geometry, as shown in image. 

The blue grips appear. 
 
100. Drag the lower blue grip to the reference 

plane Shelf Front, as shown in image. Click 
the lock symbol. If the lock symbol does not 
appear, use the Align tool.  
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101. Flex the model. 
 
102. Save the family. 
 
 
 
 

 

 
Add Vertical Supports   

103. In the Project Browser, open front view. 
 
104. Add two vertical reference planes, as 

shown in image. 
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105. Add a dimension line between the two 
reference planes you just added and the 
ext,ernal ones, as shown in image. 

 
106. Click the EQ symbol. 

 

 

107. On the Design Bar click Solid 
Form>Solid Extrusion.  

 
108. On the Design Bar, click Lines, and then 

on the Options Bar click the rectangle 
template.  

 
109. Draw six rectangles, as shown in image. 

The size is not important. 
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110. Click Align on the toolbar. On the 
Options Bar, select the Multiple Alignments 
options. 

 
111. Click the left reference plane (see image) 

and align the three rectangle lines, as shown 
in image. 

 
 
112. Lock each alignment as you make it. 

 
 

113. Repeat the process with the remaining 
rectangles and the right reference plane. 

 

 
 

All these alignments are locked to maintain 
this constraint when you change the value 
of the width parameter of the furniture 
family. 
 
As you draw these rectangles, you can 
draw on top of the reference planes, and a 
lock appears. You can lock it at this time for 
the same effect. 

        

114. Click Align. On the Options Bar, clear the 
Multiple Alignment option. 

 
115. Align the bottom line of the two bottom 

rectangles, as shown in image.  
 
116. Lock the alignment. 
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117. Repeat the process with the top lines (see 
image). 

 
 

118. Repeat the process for all the rectangles. 

 

It is now necessary to manage the 
thickness of vertical separations. You 
operate in a way identical to the preceding 
stages, namely, a dimension locked 
between the reference plane and the 
unconstrained line of the rectangle. But 
before that, you align the sides of the 
rectangles between them (on the left and 
right). 

119. Click Align on the toolbar. On the Options 
Bar, select Multiple Alignment. 

 
120. Click the right vertical line of the bottom 

left rectangle, and then click the right vertical 
lines of the rectangles on top of it (see image). 

 
121. Lock each alignment as you make it. 
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122. Repeat the process for the rectangles on 
the right side. 
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123. Place a dimension line between the 
vertical lines of the bottom left rectangle (see 
image). 

 
124. Select the line, and in the dimension text 

change the value to 19mm. 
 
 
125. Select the dimension and lock it. 

 

Because the right sides of this set of 
rectangles are locked together, you need to 
place only one dimension to control all 
rectangles in that set. 

126. Repeat the process for the right rectangle. 
 
127. Click Finish Sketch. 

 

 

128. Open Ref. Level view. 
 

129. Select the 3D geometry, and use the blue 
grips to align the bottom face with the Shelf 
Front reference plane, as shown in image. 

 
130. Lock the alignment. 
 

 



Autodesk Revit Building Student Workbook Autodesk 

 178 

131. Flex the model. 
 
132. Save the family. 

 
133. Start a new project to insert this family. 
 
134. From the File menu, choose Load from 

Library>Load Family.  
 
135. Navigate to where you saved the family 

and open it. 
 
136. On the Design Bar (Basic) click the 

Component button. You can now place your 
family. 

 

To test your new family in a project, you 
have to load it in a project. You can then 
insert it from the Component tool. Do not 
forget that your family is parametric! To find 
the parameters Width, Height, and Depth, 
open the type properties of the family. 



 
 
Unit 11 
Theory: Propagation of Constraints 

Autodesk Revit Building: Alignment, Locking, and Constraints 
 
This unit is to be used with Lecture Units 10 and 11. Unit 11 builds on the family created in Unit 10. This unit has several exercises designed to illustrate various 
capabilities of the family within Autodesk Revit Building.  
• Exercise A: Add the symbolic line representation to create the coarse, medium, and fine detail views. In addition, this exercise works with in-place family editing 

from the project environment. 
• Exercise B: Add a material parameter to control the materials assigned to shelf unit. 
• Exercise C: Add a glass door and assign a visibility parameter to control the display of the glass element. 
• Exercise D: Work with nested families to add a drawer unit to the family, using the parent shelf parameters to drive the geometry of the nested family. 
• Exercise E: Fine-tune the family, adding control of family elements through the use of subcategories. 

In this unit, you complete the furniture family created in the previous unit by adding more components to it. See image. 
 
The family that you created in the first part of the exercise requires more work so you can use it properly. You need to generate its 2D 
representation, associate all necessary materials, and define the levels of detail. Later in the exercise, you can experiment with nested 
families and formulas—an enormously powerful part of the Family Editor. 



Autodesk Revit Building Student Workbook Autodesk 

 180 

Unit 11, Exercise A: In-Place Family Editing and Symbolic Line Representation 
 
When you create a family, you need to define how that family behaves in different views (plan, section, elevation, 3D). The first important decision is its 2D 
representations: will the display of the family in plan view simply result from a cut 3D view, or should it be represented with a simple 2D sketch? In this case, it is 
not generated from the 3D model, but is represented with a 2D sketch that you create. After you have defined the way your family (object) is displayed in 
different views, you need to define its representation in different scales (coarse, medium, fine) for all views. So, this is your objective: 
 

 Coarse Medium Fine 

Plan View 

Section, 
Elevation, 3D 
View 

Display representation is generated from the 3D model 

 
You need to add two new sketch drawings to your family—one for its Coarse-Medium representation and one for the Fine representation. You use the symbolic 
lines for these sketches. You set the visibility of the objects in the family such that only the sketch lines display in the project and not the 3D elements of the shelf. 
Open a Project and Load the Shelf 

 
 

1. Open Unit 11a – Start.rvt. 
 

 

2. Verify that the view Floor Plans: Level 2 is 
current. 

 

 

3. From the File menu, choose Load from 
Library>Load Family to launch the Browse 
dialog box. 
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4. Browse to the Workbook data set folder and 
open the rfa folder within it.  

 

5. Select the Shelf Unit 11a.rfa. 
 

 

6. Click Open. 
 

 

Place the Shelf Unit 
 

 

7. From the Basic menu, click the Component 
tool. .   

The type should be set to Shelf Unit 11a. By 
default, the last loaded component is set 
when you use the Component tool. 

8. Place an instance on the north wall of the 
master bedroom. 

 

The shelf has no symbolic lines. What is 
displayed in the drawing window is the solid 
form elements cut at the cut plane of the 
view. 

 

Create a Cropped 3D View 
 

Create a 3D view that has an active section 
box. Use section boxes to slice away parts 
of the model to show the interiors. 

9. Set the 3D view current. 
 

 

10. Press the F8 key to bring up the Dynamic View 
dialog box. 
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11. Click the disk icon in the Dynamic View dialog 
box.  

 

12. Enter 2nd Floor 3D for the name.  

13. Click OK. 
 

 

14. Right-click in the drawing window, and choose 
View Properties.   

 

15. Select Section Box in the view properties and 
click OK. 

 

 

16. Select the section box that appears in the 
drawing window. 

 

Turn on Shade mode if you want. 
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17. Use the face grips to cut away the roof, south 
walls, and east walls. 

  
 

Edit the Shelf Family in Place To facilitate the creation of the 2D sketch, you are going 
to duplicate the Ref Level view. Revit Building lets you 
associate different levels of detail to different views: one 
for Fine and another for Coarse/Medium. 

You make only one view for both Coarse 
and Medium because the 2D geometry for 
these two representation is the same. 

18. Select the shelf unit, and on the Options Bar 
click Edit Family. 

 

 

19. Click Yes to open the family for editing. 

 

 

Set up Duplicate Views of the Ref. Level View 
 

 



Autodesk Revit Building Student Workbook Autodesk 

 184 

20. In the Project Browser under Floor Plans, 
activate the view Ref. Level. 
 

21. Right-click Ref. Level and choose Duplicate. 
 
22. Right-click the newly created Copy of Ref. 

Level, choose Rename, and change the name 
to Ref. Level (Coarse - Medium). Click OK. 

 
 

      
 

 

23. Repeat the operation and create a new 
duplicate named Ref. Level (Fine). When you 
click OK, Revit Building asks if you want to 
rename the corresponding view and level. 
Confirm with OK. 

 

 

24. Set Ref. Level (Fine) current. 
 

 

25. Use the drawing window view toolbar to set 
the Detail Level to Fine. 

 
26. Using the same method, assure that Ref. 

Level (Coarse - Medium) has Coarse set as 
detail level in its properties. 
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27. Make sure that Ref. Level (Coarse - 
Medium) is the active view (if not, double-
click it). 

 
 

28. On the Design Bar, click Symbolic Lines. 
 
29. On the Options Bar: 

• Click the Arrow sign (Select). 
• Select the Lock item. 

 
30. Select the four lines: bottom left, left, top, and 

right, by clicking them, as shown in the image. 

 
 

A check in the Lock box means that the 
selected lines automatically lock to the 
geometry from which they have been 
generated. 
 
You need to trim the symbolic lines you have 
just created. But because there is a lot of 
overlapping geometry, this can be a tedious 
task. To simplify it, Autodesk Revit Building 
offers a temporary Hide/Isolate option to 
hide all 3D geometry, as well as the 
reference plane. You then have a pure 2D 
sketch drawing that is much easier to work 
with. 

 

31. Click the Modify tool, and select the vertical 
separations as shown.  
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32. From the drawing window view toolbar, select 
the Hide/Isolate icon. 

 
33. Choose Hide Category from the context-

sensitive menu. 

 

 

34. Select a reference plane and again click Hide 
Category. 

 

 

35. On the Tools toolbar, click Trim. Verify that 
the Options Bar mode is set to Trim/Extend 
to Corner. 

 
36. Trim the lines to close the rectangle. 

 

 

 
 

 
 

 

You have just finished defining the 2D 
sketch for the Coarse – Medium level of 
detail. What remains is to tell Revit Building 
which lines should not be associated to the 
Fine level of detail. 
 

37. On the Design Bar, click Modify and then 
select the line that represents the front of the 
furniture. 

 
38. On the Options Bar, click the Visibility 
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button. 
 
39. In the Family Element Visibility Settings 

dialog box, clear the Fine check box. Thus the 
selected line is invisible in views set to this 
level of detail. 

 
40. Click OK to confirm. 

 
 

41. Activate the Ref. Level (Fine).  
42. Right-click in the drawing window and choose 

Zoom Fit. 
 

 

43. Use the same methods to 
• Hide the Reference Plane category 
• Add five Symbolic lines as shown - Pick 

Lines – Lock 
• Hide the solid geometry category 
• Clean up the symbolic lines, as shown 
• Set the visibility of the newly created 

lines to Fine 

 

Remember to use the Symbolic Lines Pick tool 
with the lock so the symbolic lines are related 
to the solid geometry. The solid geometry is 
driven by the family type parameters. If you 
just hide everything and draw the lines, they do 
not flex with the model. 

44. Click OK. 
  

 

Flex the Family 
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45. Tile the screen so you have both views next 
to each other. 

 
46. Try modifying the Width or Depth parameter. 

Note that the 2D geometry reflects the change 
and updates automatically. 

 

 

Use Window>Close Hidden Windows before 
you use Window>Tile. This keeps all the 
windows you have open (which is often quite a 
few) from cluttering up the view. Leave the 
project that you started with open for the next 
step. 

 
47. Activate the 3D view and select the entire 

geometry. 
 
48. On the Options Bar, click the Visibility button 

and clear the Plan/RCP check box. 
 
49. Click OK. 
 

 

In Plan/RCP views you are going to use the 2D 
geometry you just created as representations 
for Plan/RCP. For all other ways, the 
representation is generated from the 3D model 
and in all levels of detail. 

Reload the Family into the Project At this point you can either load the family back into the 
project or save the family out and overwrite the original 
RFA file. Or use the Save As command to create a new 
family based on these modifications. 

Here, you load the family into the project. 

50. On the Design Bar, click Load into Projects. 

 

This step loads the family into any projects you 
have open. If you have more than one project 
open, you are prompted as to which you would 
like to load the family into. 
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51. Click Yes to overwrite the existing version. 

 

At this point your work has been transferred 
into the current project. You do not need to 
save the family you are working on, but you do 
need to save the project file. 

52. Use the Window menu to change back to the 
shelf project. 

 

 

53. From the File menu, choose Close to close 
the family file.  

 

54. Do not save changes. They are already 
transferred to the project.  

 

55. Save the project. 
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Unit 11, Exercise B: Material Parameters 
In this exercise you add materials to the shelf.  
 
Although you could assign material directly to the solid extrusions as part of their properties, this definition would be static, lacking the ability to control the 
materials in the project. Autodesk Revit Building provides a parameter type that enables you to apply materials once the object is in a project. This can be either  a 
type or an instance parameter. 
 
 
 
Create New Material Parameters 

 
 

1. Open Workbook data sets\ Unit 11b Shelf -
Start.rfa. 

 

This is a family file in the same folder as the 
other exercise data files, though it is a family 
RFA file rather than a project RVT file. 

2. On the Design Bar, click Family Types. 
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3. Click Parameters Add. 
In the Parameter Properties dialog box set 
the following: 

• Name = Finish 
 

• Groups Parameter Under = 
Materials and Finishes 
 

• Type = Material 
 

• Type button 
 

4. Click OK. 
 

 

 
 

 
 

For the moment, your family is fully 
parametric in respect to its dimensions, but 
you will add a new type of parameter that 
allows the user to parametrically change the 
material associated with the furniture as well. 
For now, you create just one material 
parameter to apply to the entire 3D geometry. 

5. View the new parameter in the Family Types 
dialog box. 

 
6. Click OK to return to the drawing window.  

 
 

 

The Finish Parameter is now part of the family
definition. At this point it is not assigned to any
particular element. 
 
If you did not make the Finish Parameter, then
you would not have access to this control once
the family was in a project. Only those
parameters appearing in the Family Types
dialog box are available for editing in a project. 
You need to assign this parameter to the 
solid extrusions.  
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7. Select all 3D geometry and click Properties. 
 

 

   
The material parameter is a hard-coded property of a solid extrusion. You need to assign the family 
parameter Finish you just created to this property. Assign a family parameter to an element property to 
control the element from within a project. 
 

 
8. In the Element properties, click the button to 

the right of Material.  

 
 
9. In the Associate Family Parameters dialog 

box, click the Finish parameter. 
 
10. Click OK in all open dialog boxes. 
 

 

 
 

 

If you want, you could create a new material 
within the Family Editor and associate it as 
the default material for the family. All 
materials created in the family are going to be 
automatically created in every project where 
this family is loaded. If an existing material 
has the same name, the family material is 
overwritten. That is why it is advisable to give 
your materials specific names. 
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11. From the File menu, choose Save.  
 
12. Close the family. 
 
13. Start a new project and load your family. Insert 

a few instances of this family in the project and 
try changing their parameters. Note that all 
modifications are propagated in all instances 
of this family. This is because you have 
defined all family parameters as Type 
parameters. 
 

 
 
 
 
 

Unit 11, Exercise C: Visibility Parameters 
In this exercise you add glass doors to the shelf unit. You have now worked with two types of parameters.  
 
 
Parameter Type Name Assigned to Contols 
Length Width, Depth, Height Dimension Geometry 
Material Finish Solid Extrusion properties Material assigned to the solid 
 
In this exercise you create two glass doors for the shelf unit. You create a new parameter in the family that is a Yes/No parameter type. Yes/No parameters have 
several uses. In this exercise you assign the Yes/No parameter to the visiblity of the glass doors. This enables you to turn them off in a project if you do not want to 
see them. They are still defined in the family, but not visibly. 
 
This exercise continues from the last exercise. If you worked through Exercise 11B, and were successful in both applying materials and manipulating the 
dimensions parameters, you can continue working on your family in this exercise. 
 
In this exercise you add and constrain new references as well as create solid extrusions and voids. Go back to Unit 10 if you need to review these tasks. 
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Create Reference Planes for the Door Pulls 

 
 

1. Open  Workbook data sets\ Unit 11c Shelf - 
Start.rfa. 

 
2. Activate the front view.  
 
3. Add the three new reference planes shown in 

the illustration. 

 

Families recognize logical conditions like 
Yes/No. You use that to control the visibility 
of the glass doors within the shelf unit. The 
next task is to create the geometry of the 
glass doors.  
 
These reference planes are used to locate 
the glass door handles later in the exercise. 
 
 

4. Add the constraining dimensions shown in the 
illustration. 

 

5. Activate the view Ref. Level (Fine). 
 
6. If the view shows a red background to the 

Hide/Isolate tool, click the Hide/Isolate button 
and then click Reset Temporary Hide/Isolate. 

 
7. Click Reset to see everything. 
 

 

To facilitate the creation of the glass doors, 
name one of the reference planes. The effect 
is to create a work plane on which you can 
trace your sketch of the doors. Just imagine 
you are inserting a sheet of paper on which 
you are simply drawing a sketch. 
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8. Activate the Ref. Level. 
 
9. Select the horizontal reference plane that is 

second from the bottom, and on the Options 
Bar, click the Properties button. 

 
10. In the Properties dialog box, change the name 

to Glass and click OK. 

 

 

11. Activate the front view. 
 
12. On the Design Bar, click Solid Form>Solid 

Extrusion. 
 
13. On the Design Bar, click Set Work Plane. 
 
14. In the Work Plane dialog box, select Glass 

from the Name list. 
 
15. Click OK. 
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16. On the Design Bar, click Lines. 
 
17. On the Options Bar, click Select and select the

Lock check box. 
 
18. Click the lines that form the first shelf, as 

shown. 
 

 

For a sketch to be valid for an extrusion, it 
should not have T intersections and its line 
must be in a closed loop. Since this is not the 
case for your sketch, you need to fix it. 

19. On the Tools toolbar, click the Split tool. 
 
20. On the Options Bar, click Delete Inner 

Segment and select the two middle vertical 
lines as well as the bottom one. 

 
21. Repeat for the line above. 

22. Click Trim.  
23. Set the trim mode to Trim /Extend to Corner. 
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24. Repeat for the other side. 

 

 

25. On the Design Bar, click Extrusion Properties.
26. Set -8mm for the Extrusion End (this means 

that the glass starts on the interior side of the 
furniture). 

 

 
 
 

The value positive or negative when drawing an
extrusion from a reference plane depends on
the direction you first drew the reference plane
(right to left or left to right).  
 
If you get it wrong here, you can always change
it after you are finished with the sketch, by
looking at the extrusion properties. 

27. Click the Edit button next to Visibility.  
 
28. Clear the Plan/RCP check box, as well as 

Front/Back (this means that these doors are 
not displayed in the plan or elevation view). 

29. Click OK to return to the Element Properties 
dialog box. 

 

 

 
 

 

30. Click the button next to Material and select 
Glass. Click OK. 

 
31. Click OK again to close the Element Properties 

dialog box. 
 
32. On the Design Bar, click Finish Sketch.  
 
33. Save the file (File>Save). 
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Create Pulls for the Glass Doors 
When you assign a material in this way, the material is static. You cannot assign a different material to the 
element placed in a project. 

34. Select Solid Form>Solid Extrusion.  
 
35. On the Design Bar, click Set Work Plane. In the 

dialog box make sure that the active work plane 
is set to Glass.  

 
36. Select Lines, and on the Options Bar, click the 

circular shape. Activate the Radius and set it to 
10mm. 

 
37. Add two circles, as shown on the right. Note 

that the center of insertion is the intersection 
point of the reference planes. 

  

 
38. On the Design Bar, click Extrusion Properties 

and set 30mm as an extrusion end. 
 

 

 

 

39. Click the Edit button next to Visibility and clear 
Plan/RCP. For Detail Levels, set only the Fine 
one to be active. (This means that knobs are 
visible only in a Fine level of detail). 

 
40. Click OK to close all open dialog boxes. 
 
41. On the Design Bar, click Finish Sketch. Thus 

you are exiting sketch mode, and you have 
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finished creating the 3D object. 
 

 
 

42. Set current Floor Plans: Ref Level. 

 
 

Assumptions about the start and end of the
extrusions were opposite because the
reference plane was drawn from left to right. A
negative value extrudes toward the viewer, and
a positive value extrudes away. 

43. Select pulls. 
44. On the Options Bar, click Properties. 
45. Set Depth = -30mm (negative). 
46. Click OK. 

   
 

 
The door pulls are reversed. 

47. Select glass door. 
48. On the Options Bar, click Properties. 
49. Set Depth = 8mm (positive). 
50. Click OK. 

 

 
You have access to this information from the
Extrusion Properties on the Design Bar as you
sketch the extrusion or after you finish the
sketch from the object properties. 
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51. From the File menu, choose Save (make it a 

habit to save your work often). 
 
52. Flex your family to test it. 

 
Create a Display Control Yes/No Parameter 

 
 

53. On the Design Bar, click Family Types. 
 
54. In the dialog box, under Parameters click Add. 
 
55. In the Parameter Properties dialog box set the 

following: 
 

• Under Name, enter Glass Door. 
• Group Parameter Under: Construction. 
• Under Type, select Yes/No. 
• Select Instance (parameter can vary from

one piece of furniture to another). 
56. Click OK to return to the Family Types dialog 

box. 
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57. Verify the parameter. 
 
58. Click OK to return to the drawing window. 

 
 

 

The glass door parameter appears, ready to be
assigned to the visibility of an element. 
 
A checked box means show, and a cleared box
means hide. 

59. Select the glass doors and doorknobs, and click 
Properties. 

 
60. In the Element Properties dialog box, click the 

gray button at the right end of the Visible line. 
This button enables you to link one parameter 
to one property. 

 
61. In the Associate Family Parameter dialog box, 

select Glass Door. 
 
62. Click OK twice. 
 
 
63. To verify functioning of this parameter, load the 

family in a project. 
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64. Save your work again.  
 
 
65. Start a new project, load your family, insert a 

few instances of the family in the project, and try 
modifying the parameters. The new, added 
parameter lets you control visibility of the glass 
doors and the doorknobs per instance. Try 
changing to different levels of detail in 3D view. 
The doors and knobs should display only in a 
Fine level of detail. Try also changing the level 
of detail in plan view. There, regardless of the 
level of detail, the doors and knobs should not 
display. 
 

 
 
 

Unit 11, Exercise D: Nested Families 
In this exercise you add drawers to the shelf unit. To create the drawers you first create a new furniture family and build a single drawer in it. You load this drawer 
family into the shelf unit family, “nesting” the drawer family in the shelf unit file. 
 
To finalize your family, you add two drawers in the opening between the glass doors. Instead of modeling it in the shelf unit family, you create a new family for the 
drawer and then insert it in this one as a nested family. The width of this interior space is determined by the overall width of the family type—or the width 
parameter. You create formula-type parameters that are based on the depth, width, and height parameters of the shelves and pass these parameters through to 
the nested drawer family. However, first things first: let’s create the drawer family. 
 
Note that the description for creating the drawer is less detailed than the previous one. If necessary, refer to the inital creation of the shelf unit to review the 
processes. Roughly, this exercise breaks down into the following sections: 
 
• Create a drawer family: This is a new family you create. 
• Create a drawer shelf: This takes place in the shelf unit family and is a review of the Unit 10 exercise. 
• Create drawer parameters in shelf unit family. These drive the geometry of the nested drawer family. 
• Create formulas for the drawer parameters within the shelf unit family. The formulas perfom arithmetic operations on other family parameters.  
• Load, place, and position a drawer. You can load other families to use inside families as components. 
• Link parameters from the shelf unit family to the drawer family. 
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Create a Drawer Family 

 
 

1. From the File menu, choose New and select 
Family. Select the Metric Furniture.rft family 
template and click Open. 

 
2. Activate the Ref. Level view (Project Browser, 

Floor Plans). 
 
3. Add three reference planes, as shown. 
 
4. Add dimensions, as shown. 
 

 

 

5. Set the dimensions to labels (parameters), as 
shown. (You need to create two new 
parameters: Width and Depth). 
• Group = Dimensions 
• Type parameter 

 

 

6. Select the horizontal reference plane and in 
its properties select: 
• Name = Front 
• Is Reference = Front 

 

 

7. Activate the front view and add another 
reference plane above the existing one. 
Create a new parameter Height. 
• Group = Dimensions 
• Type parameter 
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8. Activate the Ref. Level view. Add a solid 
form using the extrusion method. The sketch 
of the solid should be a rectangle with sides 
locked to the reference planes. At this stage 
do not click Finish Sketch. 
 

 

Note on drawing lines with the (rectangle tool) 
over reference planes: As you hold the cursor 
over an intersection of two reference planes, 
notice that one or both of the reference planes 
are highlighted.  
 
If only one reference plane is highlighted, 
move the cursor slightly until both reference 
planes are highlighted. Then click the 
intersection. If you do this with both corners of 
the rectangle, the locks automatically appear 
as shown. 

9. Click Extrusion Properties.  

 

 

10. In the dialog box, click the gray rectangle on 
the Extrusion End line.  

 
11. Select the Height parameter.  
 
12. Click OK to close the dialog boxes.  

‘  

The Extrusion End (depth) is now dimmed 
because it is being driven by the height 
parameter. There is an equal (=) symbol here 
to let you know this has been assigned to a 
different parameter. 

13. Click the Finish Sketch button. 
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14. On the Design Bar, this time click Void 
Form>Void Extrusion. 

 
15. Draw a rectangle on the interior side of the 

existing solid. Using the Dimension tool, lock 
the edges of the void to the reference planes 
(fix the distance to 10mm). At this stage do 
not click Finish Sketch. 

 

 

It is a good practice to dimension to the 
reference plane rather than the geometry of 
the previous solid form. 

16. Just as in the previous case, in the Extrusion 
Properties dialog box, associate the 
Extrusion End to the height parameter and 
set the Extrusion Start to 10mm. 

 
17. This is the thickness of the bottom of your 

drawer. You can see this better in the front 
view. 

 
18. Finish the sketch. 
 

 

 
19. Activate the front view. 
 
20. On the Design Bar, click Void Form>Void 

Extrusion. 
 
21. Add a new sketch. This time it is a circle 

cutting out the opening spot for the drawer. 
Draw the circle as shown on the right. Don’t 
click Finish Sketch as yet. 

 
 

You need to assure that this sketch remains 
always aligned to the axis of the drawer 
width and that its position doesn’t change in 
vertical sense either. To facilitate the 
aligning of a circle, activate the Center Mark 
Visible option and use it as a reference point 
for constraining. 
 

22. Right-click the circle, and choose Center 
Mark Visible. Confirm with OK. 
 

 

 

Note the cross in the middle of the circle. It is 
from this point that you define the constraints 
to the reference planes. 
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23. Using the Align tool, align and lock the circle 
to the central reference plane. 

 
 

24. Add a dimension between the reference plane 
that defines the height of the drawer and the 
center of the circle. Set the distance to 30mm 
and lock it. 

 

 

25. In the Extrusion Properties dialog box, set 
the Extrusion Start to 0. 

 
26. Click OK, and then click Finish Sketch. 
 

 

 

The extrusion is heading the wrong direction. 
You need to fix that problem. 

27. Open the Ref. Level view and select the void. 
Select the lower blue point and start sliding it 
toward the interior of the drawer. Lock that 
position.  
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28. Finally, add a new Material parameter. Name 
it Finish and associate the entire 3D 
geometry to it. 

 
29. Flex the model to test your work. Try out 

different values for width, height, depth, and 
so forth. 

 
30. From the File menu, choose Save As and 

save the family as Drawer.rfa. Close this file. 
 

 
Note that a nested family can also be a shared 
family. Make a shared family by choosing Family 
Categories and Parameters from the Settings 
menu. 

 

By selecting the Shared check box, you 
change the behavior of the nested family when 
it is loaded into a project. When a nested 
family is shared 
 

• You can load the family directly into 
a project to update all families that 
have that nested family 

 
• You can schedule the nested family 

even though it resides inside a 
different family 

The drawer family is now ready to be inserted in 
the furniture family, but you need to make a few 
adjustments.  

• You are missing a small shelf that is 
positioned between the two drawers 
when placed in the opening. 

• There are no parameters in the big 
family that define the width, depth, and 
height of the drawer. 

The first problem can be resolved using the same 
techniques used to create the shelf unit as well as the 
drawer. 
 
The second problem requires formulas to help calculate 
the values of the drawer parameters. You create three 
new parameters: 
 

Drawer Width = (total width / 3) – (2 x 
thickness of the separation panel) 
 
Drawer Height = ((((total height – 84mm) / 5) / 
2) – 1 x shelf thickness)  
 
Drawer Depth = total depth -15 
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Create Drawer Shelf in the Shelf Unit Family 
 

 

31. Open workbook Data set\Unit 11d Shelf - 
Start.rfa. 

 

The Unit 11d Shelf -Start.rfa is the end product 
of Exercise 11c. Use this as a starting point, or 
continue with a shelf unit you have tested in a 
project. 
 
Now add the separation shelf between the two 
drawers. We won’t explain in detail, because 
by now you have already learned how to do 
that. To review, see Unit 10. 

32. Activate the front view. 
 
33. On the Design Bar, click Solid and click 

Extrusion. 
 
34. Double-check that the active work plane is set 

to Back. 
 
35. Add a rectangular sketch in the upper part of 

the empty middle shelf, as shown in the 
drawing on the right. 

 

   

36. Align the sketch and lock, as shown. 
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37. Add a dimension for the shelf thickness. 
 
38. Select the dimension chain, set it to 19mm and 

confirm. 
 
39. Lock this dimension. 

 
 

 

40. Click Finish Sketch. 
 
41. Open the Ref. Level (Coarse – Medium), 

select the 3D geometry, and using the blue 
point in the front, align it to the second 
reference plane from the bottom (see image). 

 
42. Lock it to that position. 

 

 

 

43. In the Properties dialog box for this geometry, 
associate the Finish parameters to Material. 

 

 
 

 

 

44. Click the Edit button next to Visible, and clear 
Plan/RCP. 

 
45. Click OK until you return to the drawing 

window. 
 

 

Everything is ready to embrace the new 
nested family. The next step is to load the 
family you want to nest and correctly link its 
parameters to the parameters of the shelf 
unit. 
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Create Drawer Parameters in Shelf Unit Family 
 

 

46. On the Design Bar, click Family Types. 
 
47. Click Parameter Add and set the following: 

a.  Name = Drawer Width 
b.  Group Parameter Under = Dimensions 
c.  Type = Length 
d.  Select Type radio button 

 
48. Click OK to return to Family Types dialog box. 

 
 
 

 

49. Click Parameter Add to create Drawer Height 
parameter. 

a. Name = Drawer Height 
b. Group Parameter Under = Dimensions 
c. Type = Length 
d. Select Type radio button 

 
50. Click OK to return to Family Types dialog box. 
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51. Click Parameter Add to create Drawer Depth 
parameter. 

a. Name = Drawer Depth 
b. Group Parameter Under = Dimensions 
c. Type = Length 
d. Select Type radio button 

52. Click OK to return to Family Types dialog box. 
 

 

53. Verify the parameters in the Family Types 
dialog box. 

 
54. Click OK to return to the drawing window. 

  

The parameters have been created and are 
available for use. 

Create Formulas for the Drawer Parameters 
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55. Now, in the Family Types dialog box, in the 
Drawer Depth, Drawer Height, and Drawer 
Width lines, enter the formulas as shown in the 
image. 

 
56. For Autodesk Revit Building to understand the 

formulas you have just entered, it is necessary 
to respect case (for Revit Building, width isn’t 
the same as Width). The suffix "mm" is 
automatically added when you confirm your 
formula, so it’s not necessary to enter it. 

 
57. Click OK to confirm all. 

  
58. Click Apply to test your formulas as you create 

them. 

 

Type the formula and click the Apply button. If 
everything is correct, the calculated width  
shows up in the value column. Revit Building 
alerts you to any errors. 

 
 

 
59. Click OK. 

 
 

60. Save the family. 
 

 

Load, Place, and Position a Drawer 
In this section you nest the drawer family into the shelf 
unit family. 

 

61. From the File menu, choose Load from 
Library/Load Family. 

 
62. Browse to find the drawer family (you have to 

remember where you saved it) and click Open. 
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63. Set the Ref Level view current. 
64. On the Design Bar, click Component and 

insert one instance of the drawer family in the 
shelf unit. 

 

 
 

65. Using the Align tool, align the axis of the 
drawer to the axis of the shelf unit and lock this 
alignment. 

 
 

When you place the cursor in align mode 
over the axis of the drawer, Autodesk Revit 
Building displays a thick black line indicating 
the reference plane of the drawer family. 
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66. Align the front of the drawer to the second 
reference plane from the bottom (see image). 

 
67. Lock this alignment as well. 
 

 

For a perfect match of the drawer family in 
the shelf unit, you need to link the 
parameters of both families. 
 

Link Parameters from the Shelf Unit Family to 
the Drawer Family  

 

68. On the Design Bar, click Modify and select the 
drawer. 

 
69. On the Options Bar, click Properties. 
 
70. In the Element Properties dialog box, click 

Edit/New to view the type properties of the 
element and thus the drawer parameters. 

 

 

 
 

 

The element properties are the same 
properties you would expect to see if you 
loaded this family into a project. 
 
Use the small gray boxes at the far right of 
the Width, Depth, Height, and Finish 
parameters to make the link between the 
parameters. 
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71. Click the small gray box in the Depth line and 
select Drawer Depth in the Associate Family 
Parameter dialog box. Click OK. 

 
72. Repeat for all three parameters and associate 

them as follows: 
• Width = Drawer Width 
• Height = Drawer Height 
• Finish = Finish 

73. Click OK until you return to the drawing 
window. 

 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 

74. Activate the front view, and using the Align 
tool, align and lock the drawer in the upper 
empty space. 

 
75. If you have trouble selecting the lower line of 

the drawer, just position your cursor near that 
line and use the Tab key until that line is 
activated, then click to select it. (The Tab key is 
a great help whenever you have overlapping 
geometry.) 

  

76. Switch to the Ref Level view. 
 
77. Repeat the same method to insert, align, and 

lock the second drawer. 
 
78. Switch to the front view and repeat aligning and 

locking vertically. 
 
79. Test the family by flexing the model. 
 

 

 

 
 

Because all drawer parameters are Type 
parameters, you do not need to repeat the 
same for the second drawer. The new 
drawer instance automatically inherits the 
instance properties of the existing one. All 
you need to do is align it in plan view and in 
elevation. 



Autodesk Revit Building Student Workbook Autodesk 

 217 

80. Select both drawers, and on the Options Bar 
click Visibility. 

 
81. Clear Plan/RCP. 
 
82. Click OK. 
 

 
 

If you are daring, try copying the drawer in 
elevation instead of reinserting it in plan view. 
Can you get all the alignments in this front 
view? 
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83. Save your file. 

 

You are almost finished with your family. But 
before you use it in a project, you might want 
to add subcategories. With subcategories, 
you can control the entire display of the 
family in all views (line thickness, line color, 
line style, material, and so forth). 

 
 
 

Unit 11, Exercise E: Subcategories and Families 
 
The family category was defined when you selected the template to make it with. You can change this template later, but it is not advisable to do so. Always make 
sure to select the correct template when you create a new family. Next, you set new subcategories within your family. 
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Create Subcategories of the Furniture Category This exercise builds on work performed in previous exercises. If you have not completed the previous 
exercises, but want to work through this exercise on subcategories and families, open Workbook Data 
set\Unit 11e Shelf - Start.rfa.  

1. From the Options menu, choose Object 
Styles. 

 
2. Scroll down to the Furniture category. By default 

there are two predefined subcategories: Hidden 
Lines and Overhead Lines. You need three new 
subcategories: Glass, Shelf, and Accessories. 

 

 

 
 

3. Click the New button. 
 
4. Enter Shelf for Name, and under Subcategory 

of, select Furniture. Click OK. 
 

 

 
5. Repeat the same operation for Glass and 

Accessories. 

 
For each subcategory, you can set whatever line thickness, color, or material you want. The material is 
assigned to the family subcategories only if under the Finish parameter the value is set to <by category>. 
Here, you simply change the color of one of the subcategories. 

6. In the Object Styles dialog box, in the Shelf 
line, click the Line Color button. 

 
7. Select any color from the Color dialog box and 

click OK. 
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8. To see just the symbolic lines, activate the Ref. 
Level (Fine) and using the Hide/Isolate tool, 
hide: 
• Reference planes  
• 3D geometry 
• Nested families  

 
9. Select all these lines, and on the Options Bar 

go to their Properties. 
 
10. In the Element Properties dialog box, click 

Subcategory and select Shelf. 
 
11. Click OK. 
 
12. Repeat for the Ref. Level (Coarse – Medium). 

 

      

In principle, using the same method for both 2D 
and 3D, here are the associations you need to 
define: 
• For all vertical separations, horizontal 

shelves, and the plinth, associate the Shelf 
subcategory. 

• For the Glass doors, choose Glass. 
• For the Doorknobs, choose Accessories. 
The easiest way to select the geometry when 
associating the subcategories is to work in a 3D 
view. 

 

As for the drawers, if you have tried associating
a subcategory to them, you will notice that there
is no subcategory parameter within their
properties. The reason is that the drawers are
nested families. So, go back to the drawer
family to effectuate this. 

Use In-Place Family Editing to Modify the
Drawer Family 

Use the same process you used in an earlier exercise to 
access the drawer family and modify the shelf in the 
project file. 
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13. Select a drawer, and on the Options Bar click 
the Edit Family button. 

 
14. Click Yes to open the family for editing. 

 

In the next step you create a subcategory in the
drawer family called Shelf (same as the
subcategory in the family file). All geometry
uses the existing shelf definition once it is
loaded back into the family file. 
 
Alternatively, you could create a subcategory
called Bin. In this case, when loaded into the
shelf family, it would bring this subcategory with
it and you would then have direct control over
this subcategory in the shelf unit family file.
Likewise, when you load the shelf unit into a
project, it brings all the subcategories, including
Bin. You would then have access to this
subcategory in the project file. 

15. Click Settings>Object Styles. 
 
16. Create a new subcategory Shelf. 
 
17. Associate the entire geometry to this 

subcategory.  

 

 

18. On the Design Bar, click the Load into Project 
tool. 

 
19. Check the current shelf family you are working 

on. 
 
20. Click OK. 
 
21. Click Yes to overwrite. 
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22. Use the Window menu to switch back to the 
drawer family. 

 
23. Close the drawer family. 
 
24. Click No at the Save Changes prompt. 

 

You can save the changes if you want. If you do
so, the software tries to locate where the
original drawer family file came from when it
was loaded into the family. 
 
You do not need to save because the changes
have already been loaded into the shelf unit
family. 

25. You should now be back at the shelf unit family.
 
26. Save the family. 

 
The drawers assume the properties of the shelf
subcategory defined in the shelf unit family. 

Create Types 

 

The family is finished and is fully parametric. 
What you still can do is create types. In other 
words, you can preset different types of this 
family with predefined parameters like width, 
depth, height, and material so the shelf unit 
can automatically be inserted in various 
standard sizes or materials, enabling users to 
simply select the type from a list. Should the 
type not be found on that list, the user can 
always create it on the fly. Let’s see how to 
do that. 
 

27. On the Design Bar, click Family Types and 
then click New. 

 
28. As a name for the new type, enter 2100 x 1100 

x 350 with Doors, and click OK. 
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29. You can now change the corresponding values 
in the dialog box. 

 

 

30. Create a new type 2100 x 1300 x 450 and click 
OK.  

31. Adjust the parameters to Width (1300), Height 
(2100), Depth (450), and clear the Glass Door 
check box.  

 
32. Click OK. 
 
33. From the File menu, choose Save. 
 

 

 
 
 

 

34. Start a new project or open an existing one. 
Load the newly saved shelf unit family and 
insert a few instances of it in the project. Note 
that in the unit’s Properties dialog box under 
Type, you see two or three different predefined 
types of this family. 

 

The family name is displayed along with the
type name. The family in this case is the name
of the RFA file you have been working in. 
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35. Insert a few instances of each type and change 
their parameters to see the differences. Try to 
change both the instance parameters (Glass 
Door) as well as the type parameters (width, 
height, and so forth). Remember that you will 
not see the door pulls unless the view is set to 
Fine. 

36. Activate Level 1 and in the Properties of the 
view, click Visibility Edit button. 

 
37. Expand the Furniture category. 
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38. Click By Category in the Projection column in 
the Shelf line to override. 

 
39. Change the Line Color and the Line Pattern and 

click OK. 
  

 

  

40. Make sure the changes you have just made are 
propagated correctly. 

 

 

41. Activate the 3D view, and in the Properties 
dialog box click Visibility.  

 
42. Expand the Furniture category. 
 
43. Clear Accessories and click OK. 
 

 

Again, thanks to the subcategories, you can 
have an instance of this family in which the 
doorknobs are simply turned off and thus 
invisible. 
 
If you do not see the accessories in the view,
remember these are set to Fine. 
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44. Select any instance of the shelf unit, go to its 
Properties dialog box, and click Edit/New. 

 
45. In the dialog box that opens, select Duplicate. 

Autodesk Revit Building prompts you to enter a 
new name: you are about to create a new type 
of this family. Name this new type 210 x 110 x 
350 – Red Finish and click OK to close all 
dialog boxes. 

 
46. Create a red paint material and click OK to 

close all dialog boxes 
 
47. You have just created a new type of this family.
 

 

 
You can create as many types of a family as you want, and they don’t exist only in this project but can be used in any other project. 

 
 

Unit 12 
Theory: Interdependencies 

Autodesk Revit Building: Site 
This unit explains Autodesk Revit Building’s Site features and workflow as well as linking files and AutoCAD drawings. This unit has four exercises. 

• 12a takes you through the process of creating importing an AutoCAD drawing. 
• 12b illustrates how to link a Revit Building project into a current project. 
• 12c works with the site tools to develop the model. 
• 12d exports a view and sheet into AutoCAD DWG format.  

 

Unit 12, Exercise A: Importing AutoCAD Drawings 
In this exercise you start with the workbook template and import an AutoCAD drawing to use as a basis for the site work in the rest of this unit. This AutoCAD site 
drawing has polylines that are placed at elevation. In a later exercise you will convert this geometry to a Revit Toposurface. 
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Exercise Setup   

1. Start a new project with the workbook template.  Refer to Unit 1 if you need help creating a 
project from the workbook template. 

2. From the File menu, choose Save As and save 
your project as Unit 12.rvt in the Revit Workbook
folder. 

  

3. Set the Site view current.   

Import an AutoCAD Drawing   

4. From the File menu, choose Import/Link>CAD 
Formats. 

 

 

5. Browse to and click once on the drawing file 
Import Site Plan.dwg in the workbook folder. 

  

6. Match the settings in the Import dialog box to 
the settings shown at right: 

a. Link (Instead of Import) 
b. Current View Only 
c. All layers 
d. Preserve colors 
e. Automatically place: Origin to Origin 

Link Instead of Import: This option maintains a 
live link to the drawing. If the drawing changes, 
you can reload it into the Revit Building project. 
 
Current view only: It is a good idea to link 
drawings to a specific view. This approach cuts 
down on the amount of information needed to be 
regenerated as you switch from view to view. 
 
Origin to Origin: Although you do not have 
access to the project origin as in AutoCAD 
software, the origin is near the intersection of the 
elevation marks. 

7. Click the Open button to proceed with the 
import. 
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8. Right-click in the drawing area and click Zoom 
to Fit. 

 

 

Layer Control of Linked Drawing: Query   

9. Click the imported DWG in the drawing window.   

10. On the Options Bar, click the Query button.  

 

 

11. Click one of the magenta lines in the drawing. 

 

 

12. Click Hide in View. 

 

The Query dialog box is a convenient way to find 
out information about the object you have 
selected in the linked drawing.  
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Layer Control of Linked Drawing: Visibility 
Graphics 

In addition to the on-off control afforded by the Query tool,
you have complete control over the linework in the linked
drawing though the visibility graphics override of the view.

 

13. Type VG to access the view’s visibility graphics 
override. 

  

14. Click the Imported Categories tab.   

15. Click the Line Style for Major Contour to access 
the override for this layer in the linked drawing. 

 

 

16. Set the line color to a purple or dark red and the 
line pattern to Long Dash. 
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17. Click OK two times to return to the project’s 
drawing window. 

The linked drawing now has overrides for this 
specific view. 
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Unit 12, Exercise B: Importing Revit Building Projects 
In this exercise you continue from exercise 12a, but import a Revit Building project with a building in it. You then look at some of the display controls you have over 
the linked Revit Building file. If you completed the last exercise, you can continue to work in that file. If you choose to work in the provided project file, note that for 
consistency the AutoCAD drawing has been inserted rather than linked. 
 
Exercise Setup   

1. Open file Unit 12b – Start. You should be in 
site view. 

  

Link a Revit Building Project into the Current 
Project 

Revit Building files may be linked into one another. Like 
the linked AutoCAD DWG file, as the linked Revit 
Building file changes, it may be reloaded to update the 
current project with the new information. Also like the 
linked DWG, you have control over how the linked Revit 
Building file is displayed in the current view.  

Unlike the AutoCAD drawing file there is no 
way to insert a Revit Building project into 
another project completely. It will only import as 
a linked file. 

2. From the File menu, choose 
Import/Link>Revit, and browse to the 
workbook’s data set folder. Click one time on 
Unit 12 Building.rvt. 

 

 

3. Select the Origin to Origin option under  
Positioning Automatically Place, and click the 
Open button. 

 

Linked Revit Building Project by View 
 

You have several levels of control over the display of the 
linked Revit Building file. You can view the linked file with 

 



Autodesk Revit Building Student Workbook Autodesk 

 232 

the default visibility of the view, or the default settings of 
a view within the linked file, or override any of the linked 
constituent parts. 

4. Duplicate with detailing the Site view and 
rename the new view Site-Concept. 

  

5. Tile the Site and Site-Concept views. 

 

 

6. Set the Site-Concept view current, and type VG 
to access the view’s visibility graphics override. 

  

7. Click the Revit Links tab and then click the plus 
(+) sign to the left of Unit 12 Building.rvt. 

 

If you have more than one instance of the 
linked file in your project, each instance is listed 
in this tree. You control the display of each 
instance independently. 

8. Under Display Settings, click the By Host View 
button to override the default display settings. 
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9. In the RVT Link Display Settings dialog box, 
click the Basics tab, and then click the By 
Linked View radio button and set the linked 
view to Floor Plan: Level 1. 

 

10. Click OK two times to return to the drawing 
window. 

 

The linked file now uses the current display 
settings stored by the linked file rather than the 
host file’s current view settings. 

Linked Revit Building Project View Display 
Override 

You can also control each item in the linked file 
independently of the view settings stored in the linked 
project files view. 

 

11. With the Site-Concept view current, type VG to 
access the view’s visibility graphics override. 
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12. In the RVT Link Display Settings dialog box, 
click the Basics tab, and then click the Custom 
radio button. 

a. Verify the Linked View is set to Floor 
Plan: Level 1. 

b. Change the Detail Level to Coarse. 

 

13. Click the Model Categories tab: 
a. Set the Model Categories drop-down 

to <Custom>. 
b. Under Walls, clear the Surface 

Pattern check box. 

 

 

This step turns off the wall hatch you see on 
the reveal at the base of the wall. 
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14. Click the Annotation Categories tab: 
a. Set the Annotation Categories drop-

down to <Custom>. 
b. Clear the Show Annotation 

Categories in This View check box. 

 

15. Click OK two times to return to the drawing 
window. 

 

All of the view visibility controls can also be 
applied to a linked Revit Building project. 

 
 
 
 

Unit 12, Exercise C: Site Tools 
 
 
Autodesk Revit Building software’s site features and workflow are explained in this unit. 
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1. Open file Unit 12 – Start. You should be in site 
view. 

 

The site file has an imported DWG instance. 
The DWG data consists of 2D polylines on 
different heights.  

2. Set the 3D view current. 

 

Note that the DWG drawing was imported as 
“Current view only” so it displays only in the 
view where it was positioned—the Floor Plans 
Site view. It does not appear in the 3D view.  
It is a good idea when you link in AutoCAD 
site drawings to link them into only one view. 
You will create a toposurface that shows the 
site grading in 3D, section, and elevation. 

3. Set the Floor Plans Site View current.  

4. Right-click the Design Bar and activate the Site 
Design Bar if it’s not already visible. 

 

 

5. On the Design Bar, click Toposurface. You 
enter sketch mode. 
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6. On the Design Bar, click Use Imported and then 
click the imported DWG file.  

 
 
 
 
 
 
 
 
7. Use image on the right to select the layers to 

use for creating the surface. Click OK. 

   

Toposurfaces can also be created directly by 
clicking the Point command and positioning 
points (the height can be set on the Options 
Bar) in the workspace. 
 
Site information is usually imported from a 
DWG file. 
 
 
 
Once the DWG instance has been selected, 
Autodesk Revit Building recognizes the layers 
contained within it and lets you pick which 
ones you want to use to create the surface. 

8. On the Design Bar, click Properties and change 
the surface material to Site – Grass. Click OK to 
close the dialog box. 

 

You can change surface material later by 
opening its Properties dialog box. 

9. On the Design Bar, click Finish Surface.  
10. Open a 3D view. Note that the building is sunk 

inside the topographic surface. 
 
11. Open site view again. 

 

Note that the DWG drawing was imported as 
“Current view only” so it displays only in the 
view where it was positioned. 

Create a Pad  
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16. On the Design Bar, click Pad. You are once 
again in sketch mode. 

 

17. Use the Lines tool to draw a rectangle around 
the building, as shown in the image. You can 
follow the property lines for the sketch. 

 

These property lines were sketched, but you 
can enter their coordinates directly in a table 
and the sketch is automatically generated. 

18. On the Design Bar, click Pad Properties, and 
change the Pad Level to Level 1. 

 Change this property at any time. 

19. Click Finish Sketch.  
20. Open the visibility settings for the view, go to 

the Imported Categories tab, and turn off 
visibility for all the DWG layers except Site 
Layout.  

21. Click OK to exit the Visibility Graphics dialog 
box. 

22. Click OK to exit the View Properties dialog box.

 

Turn off the unnecessary DWG data in your 
view. 
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23. Open the 3D view to see the pad. Tile windows 
(choose Tile from the Window menu). 

 

Working with side-by-side windows is helpful 
in many situations. 
 
Before you tile the windows, choose Close 
Hidden Windows from the Window menu, and 
then open just the views you want to tile. 
 
If you minimize a view, it does not tile with the 
other open views. 

Add Site Components  

24. Set the Floor Plans : Site Plan Current.   
25. On the Design Bar, click the Parking 

component, and add a 4800 x 2400mm - 70 
deg as shown in image. 

 

Parking components, as site components, 
automatically recognize the height of their 
host during positioning. 
 
Use the blue arrows to flip the parking space. 
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26. Select the parking component and array nine 
instances of it to the left (west). 

 

Parametric arrays are helpful when 
positioning this kind of component. 

27. Click Site Component, and add a few tree 
components, as shown in image. 

 

Trees are specific site components that have 
their own editor and can be customized, 
though Autodesk Revit Building comes with 
an extensive tree library. 
 
To navigate through the library, create a new 
planting family and open the Family Types 
dialog box. Clicking the Plant Name 
parameter opens an AccuRender dialog box 
with the tree library. 
 
The symbol used for plans, elevations, 
sections, and normal 3D is a simple stick 
symbol. 

Change the Site Settings  
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28. Maximize the site view. From the Settings 
menu, choose Site Settings. 

 

 

29. Change the settings for the first row from 
Secondary Contours to Primary Contours (see 
image). 

  

You can add as many contour lines as you 
want. 
 
 
The poche base elevation setting in the 
bottom left defines how thick the surface 
displays in section views. 
 
The Cut material defines what type of 
hatching the poche has. 

30. Click Insert to add other secondary contours 
and apply the following settings:  
• Start: 0 
• Stop: 100m 
• Increment: 250 
• Range type: multiple values 
• Subcategory: secondary contours 

 

  
 

Once finished, if you zoom in the drawing you 
see that primary and secondary contours 
display with different lineweights, which are 
set in the Object Styles dialog box under the 
Topography category. 
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31. Click OK to exit dialog box. Note the additional 
contours that appear on the toposurface. 

 
 
 

Add Contour Labels   

32. On the Design Bar, click Label Contours and 
draw a straight horizontal line, approximately as 
shown in image. 

  

You can draw the Contour Label line in any 
direction. 

33. Zoom in to see the labels. 
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Add a Site Section  

34. On the View Design Bar, click Section and 
draw a section on the same line as the contour 
label line. 

 

 

35. Open the section. From the View menu, choose 
Apply View Template>Site Section. 

 

          

 

 
 

Unit 12, Exercise D: Exporting AutoCAD Drawings 
In this exercise you export the site model and a sheet for use with AutoCAD software. 
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Exercise Setup   

1. Open file Unit 12d – Start. You should be in 
site view. 

  

2. Open the Sheet A101 and zoom out to see the 
extents of the views. 

 

The views that were placed on the sheet have 
grown because of the site work now makes the 
extents of the views much larger than when the 
views were originally placed on the sheet. This 
is typical behavior if a view does not have its 
crop region active.  

3. For each of the views on the sheet: 
a. Open the view properties and select 

in the Crop Region check box. 
b. Select and left drag the crop region 

into a more sensible boundary for the 
view. 

   
 

You can also access the view properties from 
the sheet by selecting a view on the sheet and 
clicking Activate View from the context-
sensitive menu. 

 

 

 

The finished sheet is now ready to export to 
AutoCAD software. 

Export a Sheet to AutoCAD Drawing Format Before you export to AutoCAD, verify that the export
settings are correct. 
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4. From the File menu, choose Import/Export 
Settings>Export Layers DWG/DXF. 

 

5. Make any changes needed to the export 
settings. 

Each of the Revit Building objects is assigned a 
layer and color ID for instances where the 
object is cut (such as a wall in plan view) or as 
projection (a wall in elevation). The Layer 
names are created automatically in the new 
drawing file. The color IDs are the standard 
AutoCAD ACI colors that will be assigned to the 
layers as they are created. 

Note: By clicking the Load button, you have access 
to several different preset export layer files. 

 

The Standards button enables you to change the 
standards also. 
 

 
 

6. Click OK to return to the drawing window.   
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7. From the File menu, choose Export>CAD 
Formats. 

 

 

8. In the Export dialog box: 
• Select the Manual radio button for File 

Naming. 
• Type in a file name for the drawing. 
• Verify that AutoCAD is the format to save to.
• Click the Options button. 
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9. The Export Options dialog box gives you 
several options as to how the drawing will be 
created. Verify the settings are as shown, and 
click OK to return to the Export dialog box. 

 

 

10. Click the Save button to create the new drawing 
file. 

 

The new drawing is created along with a PCP 
file for the pen settings that AutoCAD can use 
to plot this file. 

 



Unit 14 
Theory: Detail 

Autodesk Revit Building: Drafting and Linework 
 
This unit explains how to create detailed drawings using Autodesk Revit Building. 
  

 

1. Open the file Unit 14 – Start.rvt in the training 
files directory. The project should open up to 
the view Floor Plans: Level 2. 
 

 

 

2. On the Basics Design Bar, click Section. 
3. On the Options Bar set the following: 

• Section Type = Detail View 
• Scale = 1:10 

 
 

 

You can create as many section types as you 
want by duplicating them. 
 
In the Project Browser, details (including 
sections) appear under the category called 
Detail Views, while other section types have 
their own category.  
 
The scale affects the detail level of the newly 
created view. Normally, all views 1:5 and 
bigger have detail level set to Fine, but it is 
possible to change the settings by choosing 
Detail Level from the Settings menu. 
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4. Draw a section mark over the window, as 
shown in image. 

 
 
5. Open the section by double-clicking the section 

bubble or the detail view in the Project 
Browser. 

 

 

 

6. If needed, resize section on top to display 
Levels 2 and 3, as shown in image. 

 

  

You may need to resize section views, or 
maybe even turn off the crop region if it 
disturbs your drawing: right-click, choose 
View Properties, and clear Crop Region 
Visible. 

7. Right-click and choose View Properties in 
the section detail view, and under Model 
Categories turn off visibility of windows.  
 

8. Click OK to exit dialog box. Click OK again to 
close view properties. 

 

 

 

The keyboard shortcut for displaying the 
visibility settings for the view is VV. It provides 
a quick way to jump directly to the dialog box. 

9. From the File menu, choose Load from 
Library>Load Family. Navigate to the 
Workbook Data set\Extra rfa files and select 
the file called Window Section.rfa. This detail 
component was generated from a DWG file. 

Detail components can be created by drawing 
directly or by importing a DWG, DXF™, or 
DGN file if you already have the detail in one 
of these file formats. 



Autodesk Revit Building Student Workbook Autodesk 

 250 

 
10. On the Drafting Design Bar select Detail 

Component. The loaded Window section 
detail component should be ready to be placed 
on the drawing. 
   

 

11. Place the window detail component as shown 
in image. Use the Align tool to help align it 
correctly to the sill and the wall finish. 

 

 
Align sill to bottom of window opening. 

 

 
Align interior face to interior face. 

 

 

Edit Cut Profile   

12. Click the Edit Cut Profile icon on the toolbar. 
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13. Click the hatch or boundary of the 
subcomponent you want to modify. 

 

This takes you into sketch mode, where you 
draw the linework for the new cut profile of the 
component. 

14.  Use the Lines tool to draw a new profile 
where you want the subcomponent to be cut. 

 

 

15.  Click the blue arrow toward the side you want 
to keep. 

 

 

16.  Click Finish Sketch. 
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17. Repeat the process with all four wall 
components underneath the window detail 
component. 

 

 
The profile of each material must be edited 
separately because the tool works on one 
hatch at a time. 
 
 
 

 

18. On the Drafting Design Bar, click Repeating 
Detail, and on the Options Bar, click Brick –
Section. 
 

Use detail components in arrays to create a 
repeating detail, or you can use the repeating 
detail tool. A simple example is a series of 
bricks in section view. There are various ways 
to assemble the detail component in a 
repeating detail. 

4 3 2 1
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19. Draw a line on the exterior part of the wall, as 
shown in image. Don’t worry about correct 
positioning. Move it into the correct position 
after placing it. 
 

     

Use the Align tool to move a repeating detail into 
position. 

Start here 

Draw in this direction 
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20. Add another Brick – Section repeating detail 
below the window. 
 

Note that this brick detail component contains 
an invisible line that defines the width of the 
mortar. You could add a hatch in the detail 
component so it displays the mortar in the 
repeating detail. 

21. If the brick repeating detail is in front of the 
window detail, select the former and on the 
Options Bar click the Bring to Front icon. 
 

Annotations and detail components are view 
specific: they are visible only in the view they 
were created in. 
 
It is possible to define the order of their 
appearance by using the toolbar displayed on 
the left. This toolbar appears on the Options 
Bar once a detail component has been 
selected. 
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22. On the drafting Design Bar, select Repeating 
Detail: Concrete-Masonry Slab – Section 
500mm. 
 

 
23. Draw the repeating detail as shown in the 

image: from the left intersection with the wall 
toward the right. 

 

The hatch of the underlying floor slab should 
not be visible in the detail component. You 
can edit its cut profile as you did with walls, 
but it would be more convenient to add some 
hatches directly in the detail component to 
hide whatever lies beneath. 

Start here 

Draw in this direction 
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24. On the Drafting Design Bar, click Insulation, 
and set the size on the Options Bar to 70mm. 

 
 
25. Draw the insulation in the exterior wall, as 

shown in image, both above and below the 
window detail. 
 

Change the insulation width after designing it by 
right-clicking it and choosing Properties>Width 
Field, or simply by changing the Width value on 
the Options Bar. 

  
 
 
 

Start here 



Unit 16 
Theory: Is Architecture Engineering? 

Autodesk Revit Building: Formulas 
This exercise starts with a data set that is a window family. The window family is already complete; you add some formulas to control the geometry and visibility of 
some of the solid elements that compose the window family. In particular, you create 
• Formulas that control the relative height of the frames (and the glass) depending on the sill thickness  
• A formula that controls visibility of the crown, to be displayed only if the window width is equal to or larger than 1400mm’ 
 
Parameter values should always be changed in the Family Types window to verify if the model flexes correctly. 
 
In Unit 11 you added formula parameters to control the width of the drawer of the shelf unit. You also added a visibility parameter.  
In this exercise you create fomulas and tie the display of the crown or lintel of the window to the result of the formula. 
 
This exercise assumes you have worked through the exercises in Units 10 and 11. If you have questions about terminology or processes, you can go back to 
those exercises for review. 
 
 
Explore the Window Family in the Project  In this section you explore the existing 

parameters set up in the window family. 
1. Open file Unit – 16 – Start.rvt. 
2. Set current 3D Views: {3D}. 

 

The window family is already complete, but 
you will add formulas to control the geometry 
and visibility of some of the solid elements 
that compose the window family. In particular, 
you create formulas that control the relative 
height of the frames (and the glass), 
depending on the sill thickness and whether it 
is visible. Another formula controls visibility of 
the crown, to be displayed only if the window 
width is equal to or larger than 1400mm.  

3. Click the window in the view.   
4. Note that there are already a few types inside 

the family. Select them from the drop-down 
menu. Return to the type named 1200 
x1200mm. 
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5. Open the type parameters for the 1200 x 
1200mm window type. 

 
6. Change the sill thickness to 100. 
 
7. Click the Apply button. 

 

 with Sill Thickness = 40 
 

 with Sill Thickness = 100 
 
Note when you do this, the H parameter 
changes as well. The current definition of the 
H parameter is height (of the window 
opening) less the sill thickness. 
 

8. In the Type Properties for the window, clear 
Sill Visible. 

 
9. Click OK to return to the drawing window. 

 

 
The window has a gap where the sill is still 
taken into consideration, but is not displayed. 

Edit the Window Family   

10. Click the window. 
 
11. On the Options Bar, click Edit Family. 
 
12. Click Yes to edit the family. 

 

You add a formula to control the relative 
frame height according to the sill visibility. 
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Formulate the H Parameter 

 

The H parameter was specifically created and 
assigned to the frame height. To see how it is 
defined, select the outer frame and click Edit on 
the Options Bar. Click Sketch 2D Path on the 
Design Bar, and go to exterior elevation view. 
Note the gap from the bottom of the sketch 
line to allow for the sill. 

13. In the Family Types dialog box, click the H 
Parameter row, and under the Formulas 
column replace the formula Height-Sill Height 
with the IF formula: if (Sill Visible, Height - 
Sill Thickness, Height).   

 

The formula syntax is: 
 
IF (<condition>, <result-if-true>, <result-if-
false>) 
 
Because Sill Visible is a Yes/No parameter, 
you only need to type the condition by itself. 
 
Formulas and parameters are case sensitive. 
 
To put this into plain English: 
 
If the sill is visible (condition is true), then Height 
- Sill Thickness (raise the frame for the sill). 
 
If the sill is not visible (condition false), then use 
the value held by the Height parameter as the 
height of the window, filling in the space that 
would otherwise be occupied by the sill. 

14. Click Apply. Change the Sill Thickness 
parameter to different values, and click Apply 
each time you change the value. Note how the 
height of the window frame now changes 
correctly.  

 Always flex your family from the Family Types 
dialog box to make sure the model responds 
correctly. 

15. Clear the Sill Visible parameter, and click 
Apply. Note how the frame resizes accordingly 
to fit precisely in the opening. 

 

Note that the sill is still visible in the model but is 
dimmed. In the Family Editor even if visibility of 
a specific component is turned off, you still see it 
for editing purposes. In the normal project 
environment, the sill would not be visible. 

Create Crown Visibility Parameter  In the last section you controlled a length 
parameter by the visibility Yes/No parameter. In 
this section you do the opposite and control a 
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visibility parameter based on a length. If the 
window width is greater than a specified width, 
show the Crown/Header. If it is less than the 
specified width, do not show it.  

16. You next create a visibility parameter to control 
the crown visibility. Click the Add button under 
the Parameters category in the Family Types 
dialog box. 

  

17. Create a new Yes/No parameter called Crown 
Visible (see image on the right). Click OK to 
return to the Family Types dialog box and click 
OK again to close the dialog box. 

You can create different types of parameters, 
by opening the Type drop-down menu to see 
them all. 

18. Select the solid that acts as the crown and 
open its Properties dialog box by right-
clicking Properties or by clicking the 
Properties icon on the Options Bar. 

 

 

19. Click the gray icon displaying the ellipsis (…) 
under the Visible row of its properties. 

 

Clicking the button enables you to assign 
control of that element parameter to an 
equivalent family parameter that can then be 
either used in formulas or changed directly in 
the project. 
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20. Assign it the Crown Visibility parameter, 
which you created in the previous step. 

 

The family parameters displayed are only 
those of the same type: length parameter if 
you are setting a distance, Yes/No if you are 
selecting a visibility parameter, material if you 
are assigning a material parameter, and so 
on. 

21. Click OK twice to close the dialog boxes.   
22. Open the Family Types dialog box, and under 

the Crown Visible parameter row enter the 
formula: 

 or(Width>1400mm, Width=1400mm) 

 

Formulas are case sensitive. 
 
It’s a good idea to type the unit suffix in 
formulas directly to avoid confusion.  

23. Change the window type from the active one to 
1400 x 1400mm and note the changes in the 
Crown Visibility. 

 

 

24. On the Design Bar, click Load into Projects. 

 

If you have more than one project open, you see 
an additional dialog box to select which projects 
to load the family into. Select the Unit 16 – Start 
project. 
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25. Select the check box to override parameter 
values of existing types. 

 
26. Click Yes. 

 

 

27. Flex the family in the project.   
28. Turn off the sill in type properties. 

 

The frame now fills in the full height when the sill 
is turned off. 

29. Change the window to different types. 

  

 

30. Use the Window menu to change back to the 
window family. 

  

31. Close without saving the family.  The family is already loaded into the project. 
You can save it as a different family or just close 
it without saving. 
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Unit 17 
Databases 
In this exercise you export a Revit Building project to an ODBC-compliant database. 
 
 

Export a Database 
There is no data set provided for this exercise.   

1. Open a project. If you are not working on your 
own project, just open one of the projects 
provided with the workbook.  

2. From the File menu, choose Export ODBC 
Database. 

ODBC stands for Open DataBase Connectivity. The 
purpose of this is to create a database that can be 
used by any database management system 
regardless of the application. Part of an ODBC-
compliant database is a data source name file. This 
file is like a translator to the database and provides a 
link between the database and the software used to 
interpret the data. 
 
In this exercise, you create both an access database 
(MDB) file and the data source name file. 

3. In the Select Data Source dialog box, click 
the New button. 
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4. Click the Microsoft Access Driver and then 
click the Next button. 

 

5. In the Create New Data Source dialog box: 

a. Click the Browse button.  
b. Browse to the workbook’s data set folder. 
c. Name the file. 
d. Click the Save button. 
e. Click the Next button. 
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6. Click the Finish button.  

7. In the ODBC Microsoft Access Setup dialog 
box, click the Create button. 

 

8. Enter a name for the database and verify the 
location were you want to create the 
database.  

9. Click OK. 
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10. Click OK again.  

11. Click OK again.  

12. Click OK again. The database has been created in the folder you 
specified. This sample is provided in the Completed 
folder of the workbook data sets. 
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13. Click OK again. 

 

 

 
 



Unit 18 
Theory: Schedules, Tables and Legends 
Schedules are just another view of the building model, but instead of representing the data in a graphical format, the information in the building database is 
presented in tabular format. 

 

Autodesk Revit Building: Tags and Schedules 
The seven exercises in this unit cover the scheduling capabilities of Autodesk Revit Building. Each covers a different aspect of schedules in the Revit Building 
environemt. 
• 18a: Door schedules 
• 18b: Room objects schedule and tags 
• 18c: Calculated values in a room schedule 
• 18d: Room finish keys 
• 18e: Color fill legends 
• 18f: Symbol legends 
• 18g:  Material takeoff schedules 
 
 

Unit 18, Exercise A: Door Schedules 
In this exercise you create a door schedule, modify its properties, and place it on a sheet. 
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1. From the File menu, choose Open. Browse to 
the file Unit 18a – Start delivered with the 
workbook and open it.  
 

 

 
 

The file opens with a 3D view of the building. 
The active view doesn’t have an effect on the 
creation of the schedule table. You can make a 
schedule table of any object having any view of 
the model. There are two ways to make a 
schedule table: using the Schedule button on 
the View Design Bar or by choosing: 
New>Schedule Table from the View menu. 
 

2. On the Design Bar, click Views and then 
Schedule/Quantity. 
 

3. From the Category list, select Doors and click 
OK. 

 
 

 

4. In the Schedule Properties dialog box under 
Available Fields, click Family and Type and 
then click Add. 
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The Family and Type field is now moved to the 
right, under Scheduled Fields. This will now be one 
of the columns in the schedule. Repeat for two 
other fields: Width and Height. 

 
 
 

The Available Fields list contains all information 
that can be extracted from the door object. On 
the right is an empty list in which you are going 
to add the information that you want to see 
displayed in the schedule table.  
 
The schedule table is displayed in table form. 
The order of the fields determines the order of 
the columns in the schedule table. You can 
easily modify this using the Move Up and Move 
Down buttons. 
 
 

5. Click OK to close the Schedule dialog box. 

 

You can change the appearance of your 
schedule table by adjusting the width of the 
columns. The principle is simple: just drag the 
separation line between two columns in the title 
to the desired width.  
 

 

6. Right-click over the schedule table. From the 
context-sensitive menu, choose View 
Properties. 
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7. In the Element Properties dialog box, click the 
Edit button next to Sorting/Grouping. 

 

 

8. In the newly opened dialog box, under Sort By, 
select Family and Type. 

 
9. Click OK to close the Schedule Properties 

dialog box. 
 
10. Click OK to close the Element Properties dialog 

box. 
 
  

 

The schedule table displays correctly according 
to the sorting criteria you have defined. 
Autodesk Revit Building allows four levels of 
sorting. 
 
Every line in the schedule table represents a 
door within the project. You might think this is 
an odd way to represent a door, but Revit 
Building can represent an object in a textual 
manner, showing all important information 
about that object. 
 

Before you continue working on your door schedule, you need to analyze the possibilities that Autodesk Revit Building proposes at this stage.  
Let’s look at the Options Bar. 
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11. Click in any schedule table field, and then click 
the Show button.  

 
12. You can achieve the same by right-clicking the 

schedule field, and choosing Show. 
 
13. Revit Building opens a view in which you see a 

graphical representation of the selected door. 

 
  Autodesk Revit Building enables you to search for 

other views in which this door is displayed. To do 
that, click the Show button. Should you not want to 
continue, simply click the Close button. 
 

14. Click again in any schedule table field, and on 
the Options Bar, click Delete. 

 
 
 

Autodesk Revit Building double-checks that you 
really want to delete that instance so you have a 
final choice of accepting (OK) or Cancel. 
 
Again, you can find the same command by right-
clicking and using the context-sensitive menu. 
 

 Notice that the schedule table cells are editable. 
You can change any value in the schedule table (for 
example, the width of the door). You should be 
careful when doing that however, because the door 
width is a type parameter, which means you would 
change the width of all instances of this type in the 
project.  
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Finally, you can change the family and type by 
simply clicking the family and type field. This 
field contains a pull-down list from which you 
can select the desired door family or type. 
 

What is important to understand here is that no matter what changes you undertake in the schedule table, they are populated everywhere in the project. The 
opposite works as well. If, for example, you delete or add a door in the project, the door is automatically deleted or added in the schedule table. In the Revit 
Building model, the schedule tables are always directionally synchronized with the project.  
 
You are now going to work further on your schedule table, refine it, add new fields, sort it, modify its parameters, and finally place it on a layout sheet. 
15. Right-click over the schedule table. 

 
16. From the context-sensitive menu, choose 

View Properties. 
 
17. In the Element Properties dialog box, click 

Edit next to Fields. 
 

You have now set all necessary fields. Next 
you sort your schedule table to make it more 
usable. Revit Building lets you sort with four 
different criteria simultaneously. Here, you want 
to sort by level and then by family and type. 
 

18. Add the fields Count and Level, reorganize 
them as shown in the image using the Move 
Up and Move Down buttons.  

 

 

 

19. Click the Sorting/Grouping tab. 
 

 

On the Sorting/Grouping tab you find the 
criteria set previously. You need to change 
them. You want to sort this time by level and 
then family and type. As there are two criteria 
for sorting, you need to intervene on the 
Header and Footer. 
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20. On the Sorting/Grouping tab set the 
following: 

 
21. Under Sort by select Level. 
 
22. Select the Header and Footer check boxes, 

and in the list next to Footer, select Count and 
Totals. Also select the Blank Line check box. 
  

23. In the Then By field, select Family and Type. 
 
24. Select the Header and Blank Line check boxes.
 
25. Click OK to close all dialog boxes. 

As a result of the criteria you defined, you find 
doubling parameters. For example, you can 
see the Header M_Double: 1640 x 2000mm in 
every row of the door, but it’s the same for the 
level as well. This isn’t a problem, because 
Revit Building lets you hide fields you don’t 
want to be visible. 

26. Right-click over the schedule table. 
 
27. Go to View Properties. 
 
28. In the Element Properties dialog box, click 

Edit in the Formatting field. 
 

 

29. Verify that the selected field is Family and 
Type. 

 
30. Select the Hidden Field check box at the 

bottom of the dialog box.  
 
 
31. Click OK to close all dialog boxes. 

 

  

 
 
As you can see, those fields are not displayed. 
However, notice that the schedule table 
displays every instance of your doors, but you 
need to know the total number of doors of the 
same type. So, you need to fix that final 
problem. 
 

32. Right-click anywhere over the schedule table 
again. 

 
33. Select View Properties. 

 

Should you need it, you can also display the 
total number of doors in your building. To make 
that visible, you need to select the Grand Totals 
check box on the Sorting/Grouping tab. 
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34. In the Element Properties dialog box, click the 

Edit button next to Sorting/Grouping. 
 
35. Clear the Itemize Every Instance check box. 
36. Click OK to close all dialog boxes. 

 
Duplicate the View For the moment, you can consider your schedule table 

ready. However, you haven’t yet learned about schedule 
filters. The filters allow you to filter through the data in 
the schedule tables. As for sorting/grouping, there are 
four levels of filtering. You can filter only fields that are 
already present on the Fields tab.  

 

Next, you duplicate the schedule table view and 
apply a filter to the duplicated view. The goal is 
to have a schedule table that shows only the 
doors on Level 2. You reuse the schedule table 
in the second part of the exercise (Create a 
Room Schedule Table). 

37. In the Project Browser, scroll to the door 
schedule and right-click it. From the context-
sensitive menu, choose Duplicate. 
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38. Right-click the Copy of Door Schedule, and 
choose Rename from the context-sensitive 
menu. 

 
39. Change the Name to Door Schedule (Level 2) 

and click OK. 

 
 

 

40. Right-click the Door Schedule (Level 2) 
schedule table and choose Properties. 

 
41. In the Element Properties dialog box, click the 

Edit button next to Fields. 

 

 
42. In the Schedule Table Properties dialog box, 

set the following: 
43. Using the Remove button, delete the Count 

field. 
 
44. Using the Select Available Fields From drop- 

down menu, click From Room. 
 
45. Under Available Fields, click From Room 

Name. 
 
46. Click the Add button. 
 
47. Repeat to add To Room: Name. 

  

 
You can just as easily insert or delete fields 
from the schedule table by double-clicking the 
desired field. 
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48. Again, arrange the list of fields as shown on the 
right using the Move Up and Move Down 
buttons. 

 

 

49. In the Schedule Properties dialog box, click 
the Filter tab. 

 
50. In the Filter By list, select Level. 
 
51. In the next field select Equals and set Level 2 

in the next field below Filter By. 

 
 

 

52. Click the Sorting/Grouping tab. 
 
53. Verify that Sort By shows Family and Type. 
 
54. Verify that Header, Footer, and Count and 

Totals are selected. 
55. Verify that the Then By sorting line is set to 

None. 
 
56. Select Blank Line, and at the bottom of the 

dialog box select Itemize Every Instance. 
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57. Click the Formatting tab. 
 
58. Verify that Family and Type is the active field, 

and select Hidden Field. 
 

 
 

 

59. Click OK twice to close all dialog boxes. 

 

Here you have the schedule table displaying 
the new criteria you have just defined. For the 
moment the two new parameter fields (From 
Room Name to Room Number) are empty. The 
software automatically fills them in the moment 
you define the rooms themselves (in other 
words, when you add a room tag in the room, 
which is what you do in the second exercise in 
this unit). 

 

Create New Sheet for Door Schedule 
Certain parameters of the schedule tables are only 
visible once a schedule table has been placed on a 
sheet. That’s the case with parameters on the 
Appearance tab of the Schedule Table Properties dialog 
box. You are now going to study the placement 
possibilities of a schedule table on a sheet. For that 
purpose, you use the entire schedule table of all doors 
in this building. 
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60. From the Project Browser select the Sheet 
A110 – Schedules and open it by double-
clicking.  

 
61. From the Project Browser, drag the door 

schedule table to the sheet you just created. 
 

 

As you can see, the schedule table is too long 
for the sheet. You need to adjust it. 
 

62. Click the schedule on the sheet, and use the 
small symbols to split the schedule table, as it is 
too long for the sheet. 
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You have just split the schedule table in two 
parts that are placed next to each other. You 
can still modify the width of the columns and 
the height of the split parts. Here are the 
meanings of the different symbols: 
  

-  Allows dimensioning of the column 
width (select, hold, move, and release 
at the desired position). Note that when 
you change the width of a column on 
one part of the split table, it changes in 
all other parts. 

-   Allows horizontal splitting of the 
table. Click the symbol and it’s done. 
To reunite the split parts, select one 
part and move it over the other. Revit 
Building automatically reconnects the 
parts. 

-  Allows you to move the table (click, 
hold, move, release). 

-   Allows you to change the height of a 
split part of a table (click, hold, move, 
release). The allowed moves are up 
and down. Obviously, changing the 
height of one schedule part means 
changing the height of the other. Try it 
out! 

 
63. Save and close the project. The next exercise creates a room schedule in the same 

project. If you are going to work through the next 
exercise, you can keep this project open. 

 

 
 
 

Unit 18, Exercise B: Room Schedules, Room Objects, and Room Tags 
In this exercise you work with the room schedule and tags. In the last exercise, we did not address the issue of tags. To work with or create a door schedule, all 
you need are the doors in a project. The tags just present information already associated with the door or in the schedule. The same is true for room schedules. A 
room does not appear in a schedule unless you place a room object.  
 
The exercise uses the same data set as the previous exercise, but does not build on the information created in that exercise. 
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Create a Duplicate View of the 2nd Floor 

 
 

1. From the File menu choose Open>Browse to 
find the file Unit 18b – Start.rvt delivered with 
the workbook and open it. 
 

2. From the Project Browser, Verify Level 2 is 
current. 
 

 

 
 

When you create a schedule view, it can be useful 
to duplicate the plan view in question so you have 
one plan view free of tags and colors. 

3. Right-click the Level 2 view and choose 
Duplicate.  

 

 

4. Right-click the copy of Level 2 view and choose 
Rename. 
 

5. Change the Name to Level 2- Rooms. 
 
6. Click OK. 

 
 

The duplicated view automatically becomes the 
active view. 
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7. From the View menu, choose 
Visibility/Graphics. 
 

8. In the dialog box, click Annotation Categories 
and clear Grids, Sections, and Elevations. 

 

 

9. In the Visibility/Graphics dialog box, click the 
Model Categories tab and clear Property 
Lines under the Site category. 
 

10. Click OK. 

 

11. Right-click the Design Bar and verify that 
Room and Area is checked.  

 

This step enables the Room and Area tab of tools 
on the Design Bar. 
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12. With the same view Level 2 – Rooms active, 
from the Window menu, choose Close All 
Hidden Windows. 

 

Before you start tagging your plan, split the screen 
so you can simultaneously view the Level 2 - Room 
view as well as the Door Schedule (level 2). 
 

13. From the Project Browser, activate the Door 
Schedule (Level 2). 
 

14. From the Window menu, choose Tile to see 
both views parallel. 

 

15. In the plan view, zoom into the upper-left 
quadrant of the plan. 
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16. On the Room and Area Design Bar, click Room 
and set the Options Bar settings as shown at 
right. 

 

 
 

 
 

 
17. Click the center room shown here. 

 

After you place the room, you should be able to 
hover over the room and see an “X” in the room. 
This is the room object. You should also now see 
the room in the door schedule under the To Room 
column. 

 

18. Click the Room Tag tool and tag (click) the room 
you just added.  

 

 

19. Click the tag and change the room name from 
Room to Bathroom. 
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20. On the Room and Area Design Bar, click the 
Room tool. Set the parameters in the Options 
Bar as shown.  

21. Click all rooms except for the two rooms on the 
lower left. Don’t worry about the name or 
number of the rooms you are tagging at the 
moment. 

  

Note how the door schedule updates automatically 
with each room tag definition. For the moment, all 
rooms are named “Room.” That changes later as 
you define the exact room names elsewhere in the 
project. Revit Building automatically populates that 
change within this schedule table as well. 
 
You now proceed with the correct naming of your 
rooms. Revit Building offers many different ways to 
do that.  
 
 
At any time you can select a tag to modify its 
properties. However, this method requires a lot of 
manipulation and isn’t very effective. 
 

 

 

Autodesk Revit Building also allows modification of 
the names of the rooms from within the schedule 
table itself. For this, however, you need to have 
created the room schedule, something you have not 
yet done. Although the room names appear in your 
door schedule table, you cannot modify them from 
here. When the room schedule is created before the 
actual tagging and with the condition that the room 
names exist in that table, you can select that room 
as soon as it has been inserted using the Options 
Bar. 
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22. Using that principle, you are now going to 
change the name of each room. You may 
sometimes use the same names (Living Room, 
Bathroom). Try to name four apartments on 
this level. 

 

You now create a room schedule table listing those 
values. 
  
23. On the View tab of the Design Bar, select 

Schedule\Quantities. 
 

24. Select Rooms as a category, and click OK. 
 

 

 

25. In the Schedule Properties dialog box, add 
the fields Number, Name, Area, Perimeter, 
and Level. 
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26. Click the Sorting/Grouping tab. 
 

27. Under Sort By, select Number. 
 

 

 

28. Click the Formatting tab. 
 

29. Select Level and select the Hidden Field 
check box. 

 

 

30. Select Area and click Field Format. 
 

31. Clear the Use Project Settings check box, and 
then set Square Meters as Units, 1 Decimal 
Place as rounding, and m2 as Unit Suffix. 

 
32. Repeat for the Perimeter field (set units as 

square meters, rounding one decimal place). 
 
33. Click OK to return to the schedule window. 
 

 

 

 
 

Adding Rooms via the Room Schedule  You can use the Add Rows button on the schedule 
to create rooms that are unassigned. Once you are 
adding rooms these rooms are available from the 
Options Bar pull-down menu. 
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34. Set the room schedule view current, and click 
the New row button two times.  

 

If you have not used the room name Kitchen you can 
just type the entry in the cell in the schedule. 

35. Type Kitchen for the name for the first row that 
appears at the bottom of the schedule. 

 

 

36. Click in the room name cell for the second row 
you added. Select Living Room from the list. 

 

If you have entered a value, you can pick it using the 
drop-down list in the schedule cell. 

37. On the Room and Area Design Bar, click Room 
and set the Options Bar settings as shown at 
right.  

 
 

 

Any unassigned room is available from the room 
pull-down on the Options Bar. 
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38. Add the kitchen and living room as shown at 
right. 

 

In this same manner you can use the Options Bar to 
delete any room in the schedule. 

 
If the room has not been placed in the project yet, it 
is simply deleted from the schedule.  
 
If the room exists as an object in the project you 
receive a warning that you are deleting the room 
and the tag associated with it. 

Separate Rooms In this section you add room separation lines to 
separate out the stair from the corridor area. 

 

39. Find the corridor in the center of the building. 
 

 

40. Click that room number in the schedule, and 
then on the Options Bar, click Show. 

 

The plan zooms to this room, the same as the Show 
button on the door schedule functions. 
 
Note the stair and corridor are the same space.  
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41. On the Design Bar, click the Room Separation 
tool. 

 

 

42. Draw lines from wall to wall at the treads. 

 

 

43. Click the room object to verify that it extends 
only to the risers at these locations. 

 

 

Add a Multifloor Spanning Room Stairs and how their areas are calculated vary from 
region to region. Often, stairs, atriums, or other 
spaces that span multiple floors are calculated only 
once. To do this, the room must have parameters 
that tell it to extend the full height of the buildilng. 

In this case, the stair extends from level 1 up to level 
4 with an offset above level 4 of 2030 (the height at 
which is hits the roof object. 

44. Click the Room tool, and set the parameters in 
the Options Bar as shown. 
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45. Click the area of the stair to place this room. 

 

 

46. Click the tag, and change the name from Room 
to Stair.  

 

47. Open Level 3 plan view. 
48. Click the Room Tag tool. 
49. Click the same area to tag the stair room in this 

view. 

 

The room object extends up through this floor level 
and so is found by the tag.  
 
None of the other spaces on this floor have a room 
object and thus cannot be tagged by the tool. 

50. Click the stair’s room object. 
51. On the Options Bar, click Properties.  
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Add a Volume Column to the Room Schedule If you turn on volume in the room and area settings, 
you can then add the volume column to the room 
schedule. 

 

52. On the Design Bar, click Room and 
Area>Settings tool. 

 

 

53. Click Compute Room Volumes. 

 

This dialog box also gives you control over how the 
room areas are calculated. 

 

54. Set the Room schedule current and open its 
view properties. 

  

55. Edit the fields to add Volume to the schedule. 

 

 



Autodesk Revit Building Student Workbook Autodesk 

 293 

56. Click OK to return to the schedule The Schedule now reports volume for each of the 
rooms in the project. 

 
 
 
 

Unit 18, Exercise C: Calculated Values for Rooms 
Using a room schedule table, you can easily create another in which you directly read the total of each room (kitchen, living room, room) as well as the percentage 
of that room type according to the total area of the building. 
 
 
1. From the File menu, choose Open>Browse to 

find the file Unit 18c – Start.rvt delivered with 
the workbook and open it. 
 

 
 

 

In the Project Browser, duplicate the room 
schedule and name it Room Schedule 
(Level 2 – Surfaces). 

 

 

 
 

2. Right-click the new schedule, and choose 
Properties. 
  

3. Click the Edit button next to Fields. 
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4. On the Fields tab, click the Calculated Value 
button. 
 

5. In this dialog box set the following: 
 
6. Next to Name, enter a name for the new field 

(% (Total), for example). 
 

7. Select the Percentage radio button. 
8. Next to Of select Area. 
9. Next to By select Grand Total. 
 

 
 

10. Click the Sorting/Grouping tab.  
 
11. Change the sorting condition to Name. 

 
12. Select Header and Footer (keep Title, Count, 

and Totals). 
 
13. Select Blank Line. 
 
14. Select Grand Total (keep the Title, Count, 

and Totals). 
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15. Click the Formatting tab. 
 
16. Select the calculated field that you created 

previously (%Total). 
 

17. Select Calculate Totals. 
 
18. Click Field Format. 
 
19. Next to Units, select Percentage, Rounding 1 

Decimal Place. 
 
20. Click OK to return to the schedule. 

 

 

 
 

Unit 18, Exercise D: Room Schedule Keys 
In this exercise you add room finish keys to the schedule. 
 
 
To finish your schedule table, you are going to create a schedule key. The idea is to be able to associate to each room a finish for the walls, floor, and ceiling. 
Instead of tediously copying and pasting these values to each room, you prepare a new schedule in which all those finishes are listed and then link it to your room 
schedule. 

 

1. From the File menu, choose Open>Browse to 
find the file Unit 18d – Start.rvt delivered with 
the workbook and open it. 
 

 
 

 

2. On the Views Design Bar, click 
Schedule/Quantities. 

 
3. From the Category list select Rooms. 

 
4. Select Schedule Keys. 

 
5. You can change the name of the schedule if you 

want to.  
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6. Click OK. 
 

 
7. Under Available Fields, select Floor Finish, 

Wall Finish, and Ceiling Finish. 

 

The Key Name field is automatically generated. It is 
this field that creates the link between the two 
schedules. So, do not delete it!  
 

8. Click OK. 

 

The schedule key tables are usually empty when 
created. Your next task is to fill it with all the 
necessary information. 
 

9. On the Options Bar, click New. 
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In principle you should now fill out all the 
information you have about all possible finishes. 
The first column is automatically generated as a 
numeric column in which the number increments 
with every added line. You can change the 
numbers but you cannot duplicate numbers.  
 
Next, you link this schedule to the room schedule 
so that you can use these values within it. 
 
 

 

10. From the Project Browser right-click the 
room schedule and choose Properties. 
 

11. Click the Edit button next to Fields. 
 
12. Under Available Fields, you can now add the 

following fields: Room Style, Floor Finish, 
Wall Finish, and Ceiling Finish.  

 
13. Click OK to return to the room schedule. 
  

 

The principle is simple: you click the Room Style 
fields and select the key corresponding to the 
finishes in that room. The Floor, Wall, and Ceiling 
Finish columns are automatically filled. 
 

 
 
 



Autodesk Revit Building Student Workbook Autodesk 

 298 

Unit 18, Exercise E: Color Fills 
In this exercise you create a color fill legend to give a visual indicator to the information held in the room objects. 
 
1. From the File menu, choose Open>Browse to 

find the file Unit 18e – Start.rvt delivered with 
the workbook and open it. 
 

 
 

 

Add a Color Fill 

To finalize your plan, you add a color fill of the areas. 

2. From the Project Browser, activate Level 2 - 
Room Areas.  
 

3. From the Drafting menu, choose Color Fill 
and place the legend next to the floor plan. 

 
4. Click OK in the information dialog box telling 

you it will disable visibility. 
 

     

 

 

Autodesk Revit Building automatically fills each 
tagged room with the corresponding color. All rooms 
with the same area are given the same color 
defined in the legend. These colors can be modified 
at any point and that change is populated on the 
legend, as well as in the entire drawing. 
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5. Select the legend. 

 

 Allows redimensioning of the width of the legend. 
If the legend has more than one column, you can 
change their widths independently. 
 

 Allows you to redimension the height of the 
legend. Should the height you are setting not be 
sufficient for the entire legend, Revit Building 
automatically splits the legend into various columns. 
 

6. Click Properties (the legend should still be 
selected). Click Edit/New and under Color 
Scheme, click the Edit button. 
 

 
 

You can also change the size of the color box in the 
legend (symbol size) as well as all text attributes 
(font, size, bold, italic, underline). 
 
The Edit button is also represented directly on the 
Options Bar. Its use is explained in the coming 
steps. 

7. Click Cancel to close all dialog boxes.  
8. Select the color fill legend again, and on the 

Options Bar, click Edit Color Scheme. 
 

The default color scheme for this project is set to 
color the rooms by area range. 
 
In principle, By Range works the same way as By 
Value. To modify the conditions of the color fill, fix a 
minimum value (default: 20m²) and click the Split 
button. The first condition you get is a double of the 
start condition. If you continue to split, the result 
depends on which cell was active when you clicked 
the Split tool. In any case, you can set any number 
as a value in the cells. 
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9. Change the color value to Room Name. 

 

If the color scheme does not automatically fill in all 
the values, click OK and then Edit Color Scheme 
again. 

 
 

 

You can do the following: 
- Change the colors associated to 

certain criteria. Click the Color button 
and select new color. 

- Change the fill pattern used for the 
color fill. Click Fill Pattern and select a 
new one. 

- In the pull-down Color list, you can set 
the criteria according to which of the 
colors is applied. By default it is the 
name of a room, but you can change it 
to Floor Finish if you want. You find all 
possible criteria for room coloring in 
that list. 

 
Finally, depending on the field you have chosen 
under Color, the option By Range may be 
displayed. If the chosen value is numeric (surface, 
length), By Range is displayed. 
 

Many options are available for the color theme. 
Explore the different types of color schemes. Using 
the Properties page you can duplicate color 
themes and store them in the project as types. 
Once defined, you can change them directly from 
the Options Bar Type drop-down. 
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Unit 18, Exercise F: Legends 
In this exercise you create a window legend. A legend is a chart of symbols in the project. You can create legends for any Autodesk Revit Building object, including 
walls, windows, and furniture. 
 
 
 
Create a Legend 

 
 

1. From the File menu, choose Open. Browse to 
the file Unit 18f – Start delivered with the 
workbook. Open it.  
 

 

 
 

 

2. On the Design Bar, click Views, and then click 
the Legend tool. 

     
 

This creates and opens a new view. The new
view is created in its own category in the Project
Browser. 
 

3. Rename the legend Window Legend. 

 

The legend view appears blank with no views 
of the building model. Think of a legend as a 
piece of paper on which you place symbols that 
represent the objects in the building model. 
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4. Click the Design Bar Modeling tab. 
 

Notice that all the tools are unavailable. There 
is a special tool you use to add the objects in 
symbol mode to the legend. 

5. Click the Design Bar Drafting tab. 
 
6. Click the Legend Component tool. 

 

 

7. Use the Options Bar drop-down to select 
• Family = M_Case Double All

Bar:1200x1350mm 
 

• View = Elevation Front 

 
 

The window symbol is shown in the legend. 

8. Click in the legend to place the window. 
 

 

9. Repeat, adding the window types shown here. 
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10. Change the scale of the legend to 1:20. 

 

 

11. On the Design Bar Basic tab, use the 
Dimension tool to dimension the windows. 

 

Because this is a window type, the window 
legend is a convenient location to place 
common information about this window that 
occurs in multiple locations in the project. 



Autodesk Revit Building Student Workbook Autodesk 

 304 

12. On the Design Bar Basic tab, use the Text tool 
to add notes to the legend. 

 

 

13. You can place a legend on any sheet by 
dragging from the Project Browser.  

 

 
 

Unit 18, Exercise G: Material Takeoffs 
A material takeoff is just a specialized form of a schedule. This exercise leads you through creating a material takeoff view for the walls. 
 
The exercise uses the same data set as the previous exercise but does not build on the information created in that exercise. 
 
Create a Material Takeoff List   

1. From the File menu, choose Open>Browse 
to find the file Unit 18g – start delivered with 
the workbook. 
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2. From the View menu, choose New>Material 
Takeoff. 

 

3. In the New Material Takeoff dialog box: 

a. Click Category: Walls. 
b. Click OK. 

 

4. On the Field tab add the fields shown in the 
illustration at right. 
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5. Leave the Filter set to None.  

6. On the Sorting/Grouping tab: 

a. Set Sort By to Material Name. 
b. Select Footer, and set to Title Count and 

totals. 
c. Check Blank Line for this sort criterion. 
d. Clear Itemize Every Instance. 

 

7. On the Formatting tab: 

a. Click Material: Area. 
b. Select Calculate Totals. 
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8. Click OK. The schedule of materials is now part of the project. 
On your own add the cost field and add a calculated 
parameter than multiplies the area field time the cost 
field. 

 



Unit 19 
Theory: Time 

Autodesk Revit Building: Walkthrough and Phasing 
 
This unit explains how the time parameter is managed in Autodesk Revit Building. 
 
 
1. Open File Unit 19 – Start.  

2. In the Project Browser, right-click Floor Plan 
Level 2 and Duplicate the view. Rename the 
new view Level 2 Demolitions. 
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3. Open the View Properties for Level 2 
Demolitions and change the Phase Filter to 
Show All and Phase to New Construction. 

  

To open View Properties you can right-click 
the view in the Project Browser and choose 
Properties, or right-click anywhere in the view 
and choose View Properties from the context-
sensitive menu. 
 
 

4. Click OK to close the dialog box. 

 

Note how the appearance of the existing 
components changes when the phase of the 
view is changed. 
 
The first thing you should notice is that views 
have a parameter called phase. 
 
Depending on the value of this parameter, all 
components created (or demolished) in this 
view have their created phase set as the one 
the view belongs to. In this case, the walls 
and doors you demolish were created in the 
existing phase and are demolished in the new 
construction phase. 

5. Click one of the walls in the plan. Open its 
properties. 

 
6. Verify the wall’s Phase Created is set to 

Existing and Phase Demolished is set to 
None. 

 

For every object in the building model there is 
also a phasing property. For each object 
Autodesk Revit Building tracks the phase 
created and the phase demolished. As noted 
earlier, the phase created is read from the 
phase property of the view in which it is 
created. 
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Demolish Walls and Doors  

7. Click the Demolish icon on the toolbar, and 
then click the walls in the middle of the building 
(see image). 

 
 
 
 
 
 
 
 
 
 
 
 
8. Click the wall dividing the bathroom area on 

the bottom left (see image). 

 

 

When you demolish a component, its display 
changes according to the phase filter 
assigned to the view. 
 
Phase filters are found in the view properties. 
 
The override for the display of the 
components is defined in the phase settings: 
from the Settings menu, choose 
Phases>Graphic Overrides tab. 

9. Add new walls and doors as shown in image. 
You don’t need to be exact about positioning 
the components, but you should design a plan 
that makes sense. 

 As you add the walls, verify that the height is set 
to Level 3. 
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10. Duplicate the Level 2 Demolitions plan view 
and rename it to Level 2 – Complete. 

  

11. Open the View Properties and change the 
Phase Filter parameter to Show Complete. 

 
12. Click OK to exit the dialog box. 

 

13. On the Room and Area Design Bar, click 
Room and create (and rename) the rooms as 
shown in the image. 
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14. In the Project Browser>Schedules/ Quantities, 
right-click the Schedule table: Room Schedule 
– Existing and duplicate it. 

 
15. Rename it to Room Schedule – New 

Construction. 

 

 

16. In the Project Browser, right-click the new 
schedule, and choose Properties from the 
context-sensitive menu. 
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17. Change the Phase parameter to New 
Construction. 

 
18. Click OK to close the window. 

 

  
19. In the Project Browser duplicate the 3D view: 

3D Cutout – Existing and rename the new 
view 3D Cutout – Demolitions. 

 
20. Open the newly created 3D View properties 

and change the Phase to New Construction. 
 
 
21. Click OK to close the dialog box. 

 

 

22. Duplicate this 3D view and name the new view: 
3D Cutout – Complete. 

 
23. Open the newly created view’s properties and 

change the Phase Filter to Show Complete. 
 
24. Click OK to close the dialog box. 
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25. Open the Sheet view: A100 - Commercial – 
Residential. 

 

This sheet already has the original views placed 
on the sheet: 
• 3D Existing Cropped 
• Existing Room Schedule 
• Level 2 (Floor Plan) 

26. Drag the view: Level 2 Demolitions on the 
sheet and position it in the middle, as shown in 
image. 
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27. Drag on the sheet the views:  
 

a. Level 2 – Complete 
b. 3D Cutout – Demolitions 
c. 3D Cutout – Complete 
d. Room Schedule – New 

Construction 
 

Position them as shown in image. 

 

 



Unit 20 
Theory: Variation 

Autodesk Revit Building: Options 
 
 
This unit guides you through the powerful Design Options feature. You start using a file that already contains a couple of design options. 
 
 
1. Open File Unit 20 – Start. This file contains an 

option set with two different design options. 
 
2.  Open Floor Plan: Op 2 Level 2. 
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3. Close hidden windows. Open Floor Plan Op 1 
– Level 2 and tile windows to display both 
options. 

Note how tiling windows lets you visualize 
both, or more, options in different views. 
 
Both views represent the 2nd floor of the 
building. All components are held in the 
building model. However, the interior walls of 
the floor, along with the stair and east wall are 
held in Design Options. 
 
When the project contains Design Options, the 
Options Bar displays a check box to allow 
selection of components that are part of the 
option set: 

 

View the Options   

4. Right-click the toolbar and select the Design 
Options toolbar.  

 

In this file you have only one option set, but 
you can have as many as you want. Normally, 
an option set is a specific part of a building 
where you want to try different design 
alternatives. An option set can contain as 
many options as you want. 

5. Click the Design Options tool to open the 
Design Options dialog box. 

 

 

6. Select Option Set 1 - Standard (Primary) and 
click Edit Selected. 

The Now Editing window displays the active, 
edited option. 
 
When you edit an option, all components that 
are not part of the option are displayed in 
gray. 
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7. Do not dismiss the Design Options dialog box 
yet. 

 
8. In Design Options dialog box: 
 
• Click Finish Editing. 
 
• Click Curtain Wall. 
 
• Click Edit Selected. 
 

 

With two options, as in this case you have three 
sets of objects: 
 
• Those in the main model 
 
• Those in sets unique to each of the options 
 
When you are editing an option, you can see 
and refer to objects in the main model, but by 
default you cannot edit them. 

9. While still in Edit Curtain Wall option mode, 
click Close in the Design Options dialog box. 

 The Options Bar displays a check box that 
allows selection of components that belong to 
the main model (not to an option set).  

 
10. Click the Edit Options Tool button to end 

editing of the curtain wall option. 
 You are returned to standard editing mode 

with neither option open. 
11. Click the Edit Options Tool button and from 

the drop-down menu, select Options Set 1: 
Standard (Primary). 

 

This shortcut bypasses the Design Options 
dialog box.  
This tool is cyclical. If you click it again, you 
exit the edit option mode (don’t do this yet). 

Modify Options   
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12. While editing the Standard Option, select the 
stairway on the east end of the building.  

 
13. From the Edit menu, choose Copy to 

Clipboard. 

  

Copy to Clipboard and Paste Aligned (Same 
Place) constitute an easy way to replicate a 
situation among different options. 
 
You can also duplicate an option within an 
option set by selecting it in the Design 
Options dialog box and clicking Duplicate. 

14. On the Design Option toolbar, click Edit 
Option to finish editing the option.  

The Design Option toolbar allows for quick 
selection of the available design options. 

15. Click the Edit Option button again, and from 
the drop-down list select Option Set 1: 
Curtain Wall. 

  

 

16. From the Edit menu, choose Paste 
Aligned>Same Place. 
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17. Select the stair, and on the Options Bar click 
Edit. 

 
 
 
 
 
 
 
 
 

When editing stairs, you enter sketch mode. 

18. Reshape the landing boundary of the stair as 
shown in image. On the Design Bar, click 
Finish Sketch. 

 When working in the stair sketch mode, click the 
Boundary button on the Design Bar to draw the 
boundary lines. Select the arc line template. 
Draw the line, and click Finish Sketch. 
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19. Add walls and doors to complete the design as
shown in image. 

  

 

20. On the Basics Design Bar click Room. Add 
room to all rooms in the option. After placing 
the tags, rename the rooms as shown in 
image. 

 

Make sure you are still editing the option 
before adding the rooms if you want the 
rooms to be part of the option. You might get 
an error if you have tagged the same rooms 
when in normal mode (not in option editing). 

21. On the Design Option toolbar, click the Edit 
Option button to finish editing the option.  

 

Assign an Option to a View  



Autodesk Revit Building Student Workbook Autodesk 

 322 

22. Open 3D View 1.  You have been working in two views that are 
both views of the 2nd level. The only difference 
between these is a setting in the view properties 
assigning one option or the other. 
 
By default, a view shows the option marked 
(Primary), in this case the standard option. 

23. In the Project Browser, right-click the 3D view 1 
and choose Duplicate. 

 

 

24. Rename the view 3D View - Option 2. 

 

 



Autodesk Revit Building Student Workbook Autodesk 

 323 

25. Open the View Properties dialog box by right-
clicking the view in the Project Browser and 
choosing Properties. On the Visibility line, 
click the Edit button. 

  

When there are Design Options in the project 
file, Autodesk Revit Building adds a new tab 
in the visibility settings of the views.  
 
You can display any option in any desired 
view: plans, elevations, sections, and so forth. 

26. On the Design Options tab, select Curtain 
Wall from the drop-down menu under Option 
Set 1. 

  

  

The drop-down menu displays the available 
options for the option set. 
 
When the value is set to Automatic, the view 
displays the primary option but switches to 
show the one you are modifying when in edit 
mode. 
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27. Click OK to close the dialog boxes and see the 
changes. 

 

  
Assign an Option to a Schedule  

28. In the Project Browser go to the 
Schedules/Quantities category and right-click 
Room Schedule – Standard 
Option>Duplicate. 

 Schedules are views as plans and sections. 
They can display the desired design option to 
evaluate the different quantities or costs 
according to the option displayed. 

29. Rename the new schedule view to Room 
Schedule - Curtain Wall Option.  

 

 

30. Right-click the Room Schedule – Curtain 
Wall option again, and choose Properties. 
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31. Click the Visibility Edit button. 

   

Although access to this component is a bit 
different for the schedule than for the 3D view, 
the theory is the same. A schedule is just a text 
view of the building model. 

32. From the drop-down menu, select Curtain 
Wall. Click OK to close the dialog box. 

  
 
 
 

 

 

 
Predesign options set shows the entire model along with 

the standard option (primary) rooms 

 
After you assign the option, it lists only those 
rooms that have been tagged in that option. 
This is essential because one option may call a 
room an office, and in another office a similar 
area may be a storage closet.  

Place Views of the Options on a Sheet  

33. In the Project Browser, double-click the sheet 
A101 – Options Compared. 

  

34. In the Project Browser, drag Floor Plan: Op 2 
Level 2 onto the sheet as shown in the image. 
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35. Place the following views on the sheet, as 
shown in image: 3D view Option 2, Door 
Schedule Curtain Wall Option, and Room 
Schedule – Curtain Wall Option. 

 

You have to turn on the crop region of the 3D 
view Option 2 and adjust the boundaries of the 
crop region to fit on the sheet. 

Change Primary Option and Accept Primary   

36. Open Floor Plan Level 2 – Main Model.   
37. On the Design Option toolbar, click the Design 

Option button. 
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38. Choose the Curtain Wall option, and click 
Make Primary. You might get a warning, but 
ignore it. 

 

A warning may appear when accepting the 
primary option, depending on how walls are 
joined.  
 
You can normally ignore these warnings and 
proceed with the next step. 

39. Choose Option Set 1. 
40. Click Accept Primary. 
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41. Click Yes when the dialog box opens. 

 
Because you are finished with the options process, accepting the primary option deletes all the elements
that are stored in Option Set 1: Standard option. 
 

42. Click Delete when the dialog box opens. 

 

Because you are deleting all the objects that are 
shown in these views, deleting the views makes 
sense. 
 
The other views, such as 3D View 1, as well as 
the schedules, are set to display, which 
automatically displays the primary option. These 
views are not deleted when you accept the 
primary option. 
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43. The Design Options dialog box is now empty. 

 

After clicking the Accept Primary button, all 
options disappear and the components in the 
primary option become part of the main 
model. 
 
Note that the sheet now displays the same 
information twice and the views display the 
same model. 
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